Bug 269350 - Plasma crash working in Kpackagekit
Summary: Plasma crash working in Kpackagekit
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-25 00:10 UTC by Sebastián Ramírez
Modified: 2011-03-25 11:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.43 KB, text/plain)
2011-03-25 07:05 UTC, phant.acc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastián Ramírez 2011-03-25 00:10:42 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Plasma crash work on kpackagekit searching .dbg packages to report an crash on amarok. I mark a lot of then and the application fail.

-- Backtrace:
Application: Área de trabajo de Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7757720 (LWP 1624))]

Thread 2 (Thread 0xae7b9b70 (LWP 1626)):
#0  0x00514610 in __i686.get_pc_thunk.bx () from /lib/libpthread.so.0
#1  0x005183b7 in pthread_mutex_lock () from /lib/libpthread.so.0
#2  0x00ca4f66 in pthread_mutex_lock () from /lib/libc.so.6
#3  0x036f3412 in g_main_context_release (context=0x94b4b1c) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2274
#4  0x036f5473 in g_main_context_iterate (context=0x94b4b18, block=<value optimized out>, dispatch=1, self=0x94b4460) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2783
#5  0x036f5848 in g_main_context_iteration (context=0x94b4b18, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#6  0x0493059f in QEventDispatcherGlib::processEvents (this=0x94be500, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#7  0x04900609 in QEventLoop::processEvents (this=0xae7b9280, flags=) at kernel/qeventloop.cpp:149
#8  0x04900a8a in QEventLoop::exec (this=0xae7b9280, flags=...) at kernel/qeventloop.cpp:201
#9  0x047fcb7e in QThread::exec (this=0x94b25a8) at thread/qthread.cpp:490
#10 0x048df35b in QInotifyFileSystemWatcherEngine::run (this=0x94b25a8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x047ffdf9 in QThreadPrivate::start (arg=0x94b25a8) at thread/qthread_unix.cpp:266
#12 0x00515cc9 in start_thread () from /lib/libpthread.so.0
#13 0x00c9769e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7757720 (LWP 1624)):
[KCrash Handler]
#7  0x04fd93aa in KJob::isAutoDelete (this=0xa5b9d88) at ../../kdecore/jobs/kjob.cpp:353
#8  0x0028a5a7 in Plasma::ServiceJob::setResult (this=0xa5b9d88, result=...) at ../../plasma/servicejob.cpp:80
#9  0x04781d6d in StatusNotifierItemJob::contextMenuReady (this=0xa5b9d88, menu=0xa3f2e60) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0x04781ded in StatusNotifierItemJob::qt_metacall (this=0xa5b9d88, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfedfed8) at ./statusnotifieritemjob.moc:75
#11 0x049078ca in QMetaObject::metacall (object=0xa5b9d88, cl=77814200, idx=27, argv=0xbfedfed8) at kernel/qmetaobject.cpp:237
#12 0x0491a6ad in QMetaObject::activate (sender=0xa5b64a0, m=0x4788c40, local_signal_index=0, argv=0x22789) at kernel/qobject.cpp:3280
#13 0x0477b0a3 in StatusNotifierItemSource::contextMenuReady (this=0xa5b64a0, _t1=0xa3f2e60) at ./statusnotifieritemsource.moc:109
#14 0x0477b2b1 in StatusNotifierItemSource::contextMenuReady (this=0xa5b64a0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#15 0x04780803 in StatusNotifierItemSource::qt_metacall (this=0xa5b64a0, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfedfffc) at ./statusnotifieritemsource.moc:90
#16 0x049078ca in QMetaObject::metacall (object=0xa5b64a0, cl=77814200, idx=11, argv=0xbfedfffc) at kernel/qmetaobject.cpp:237
#17 0x0491a6ad in QMetaObject::activate (sender=0xa2a3c38, m=0xbb9d84, local_signal_index=0, argv=0x22789) at kernel/qobject.cpp:3280
#18 0x00ba4567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#19 0x00ba9cdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x00baaf2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#21 0x049078ca in QMetaObject::metacall (object=0xa2a3c38, cl=77814200, idx=12, argv=0xbfee023c) at kernel/qmetaobject.cpp:237
#22 0x0491a6ad in QMetaObject::activate (sender=0xa3f2e60, m=0x7db0fe8, local_signal_index=0, argv=0x22789) at kernel/qobject.cpp:3280
#23 0x078efee7 in QMenu::aboutToShow (this=0xa3f2e60) at .moc/release-shared/moc_qmenu.cpp:151
#24 0x078f7193 in QMenu::qt_metacall (this=0xa3f2e60, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfee038c) at .moc/release-shared/moc_qmenu.cpp:97
#25 0x049078ca in QMetaObject::metacall (object=0xa3f2e60, cl=77814200, idx=27, argv=0xbfee038c) at kernel/qmetaobject.cpp:237
#26 0x0490b352 in QMetaMethod::invoke (this=0xbfee051c, object=0xa3f2e60, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#27 0x0490ca1f in QMetaObject::invokeMethod (obj=0xa3f2e60, member=0xbb03e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#28 0x00ba493e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#29 0x0477c6ef in StatusNotifierItemSource::contextMenu (this=0xa5b64a0, x=1035, y=1004) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#30 0x0478333e in StatusNotifierItemJob::start (this=0xa5b9d88) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#31 0x0028a423 in Plasma::ServiceJobPrivate::slotStart (this=0xa551068) at ../../plasma/servicejob.cpp:37
#32 0x0028a4f4 in Plasma::ServiceJob::qt_metacall (this=0xa5b9d88, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xa5e9988) at ./servicejob.moc:72
#33 0x04781dca in StatusNotifierItemJob::qt_metacall (this=0xa5b9d88, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xa5e9988) at ./statusnotifieritemjob.moc:70
#34 0x049078ca in QMetaObject::metacall (object=0xa5b9d88, cl=77814200, idx=26, argv=0xa5e9988) at kernel/qmetaobject.cpp:237
#35 0x04912df6 in QMetaCallEvent::placeMetaCall (this=0xa3eea38, object=0xa5b9d88) at kernel/qobject.cpp:534
#36 0x049146a2 in QObject::event (this=0xa5b9d88, e=0x909d750) at kernel/qobject.cpp:1219
#37 0x0742bfdc in QApplicationPrivate::notify_helper (this=0x8feeb28, receiver=0xa5b9d88, e=0xa3eea38) at kernel/qapplication.cpp:4396
#38 0x0743204e in QApplication::notify (this=0x8fde5e0, receiver=0xa5b9d88, e=0xa3eea38) at kernel/qapplication.cpp:3798
#39 0x00efc68a in KApplication::notify (this=0x8fde5e0, receiver=0xa5b9d88, event=0xa3eea38) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x04901b3b in QCoreApplication::notifyInternal (this=0x8fde5e0, receiver=0xa5b9d88, event=0xa3eea38) at kernel/qcoreapplication.cpp:732
#41 0x04904d8b in sendEvent (receiver=0x0, event_type=0, data=0x8fc8040) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8fc8040) at kernel/qcoreapplication.cpp:1373
#43 0x04904f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x04930a74 in sendPostedEvents (s=0x8ff0f10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x8ff0f10) at kernel/qeventdispatcher_glib.cpp:277
#46 0x036f1855 in g_main_dispatch (context=0x8ff0e90) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2149
#47 g_main_context_dispatch (context=0x8ff0e90) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2702
#48 0x036f5668 in g_main_context_iterate (context=0x8ff0e90, block=<value optimized out>, dispatch=1, self=0x8fee9e0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2780
#49 0x036f5848 in g_main_context_iteration (context=0x8ff0e90, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#50 0x04930565 in QEventDispatcherGlib::processEvents (this=0x8fc7d00, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#51 0x074edbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8fc7d00, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0x04900609 in QEventLoop::processEvents (this=0xbfee12f4, flags=) at kernel/qeventloop.cpp:149
#53 0x04900a8a in QEventLoop::exec (this=0xbfee12f4, flags=...) at kernel/qeventloop.cpp:201
#54 0x0490500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#55 0x0742ae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#56 0x009d386e in kdemain (argc=1, argv=0xbfee1504) at ../../../../plasma/desktop/shell/main.cpp:118
#57 0x080485bb in main (argc=1, argv=0xbfee1504) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 268033, bug 266605, bug 265668, bug 265352, bug 264250.

Reported using DrKonqi
Comment 1 phant.acc 2011-03-25 07:05:41 UTC
Created attachment 58319 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:

- Unusual behavior I noticed:

auto started KpackageKit update-check is running.
but crashed Plasma.

-- Backtrace (Reduced):
#7  0x075b73aa in KJob::isAutoDelete (this=0x945e580) at ../../kdecore/jobs/kjob.cpp:353
#8  0x006a05a7 in Plasma::ServiceJob::setResult (this=0x945e580, result=...) at ../../plasma/servicejob.cpp:80
#9  0x06c6dd6d in StatusNotifierItemJob::contextMenuReady (this=0x945e580, menu=0x8dfa630) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0x06c6dded in StatusNotifierItemJob::qt_metacall (this=0x945e580, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbf9f4768) at ./statusnotifieritemjob.moc:75
[...]
[...]
#13 0x06c670a3 in StatusNotifierItemSource::contextMenuReady (this=0x95c6528, _t1=0x8dfa630) at ./statusnotifieritemsource.moc:109
Comment 2 Dario Andres 2011-03-25 11:24:14 UTC
[Comment from a bug triager]
This is fixed in KDE SC 4.6.0 and later
Merging with bug 241562. Thanks

*** This bug has been marked as a duplicate of bug 241562 ***