Bug 270245 - After an incorrect password is changing the size of the input window (regression)
Summary: After an incorrect password is changing the size of the input window (regress...
Status: RESOLVED FIXED
Alias: None
Product: kdesu
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: kdesu bugs tracker
URL:
Keywords:
: 354857 (view as bug list)
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2011-04-06 20:51 UTC by Igor Strelnikoff
Modified: 2017-11-29 23:30 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
After an incorrect password (147.52 KB, image/jpeg)
2011-04-06 20:56 UTC, Igor Strelnikoff
Details
Before the wrong password (146.10 KB, image/jpeg)
2011-04-06 20:58 UTC, Igor Strelnikoff
Details
kdesu dialog after the 2nd time wrong password (52.95 KB, image/png)
2012-10-06 00:50 UTC, Misbachul Munir
Details
Screenshot of password field (54.90 KB, image/png)
2014-02-26 19:47 UTC, Roman Bysh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Strelnikoff 2011-04-06 20:51:19 UTC
Version:           4.6 (using KDE 4.6.1) 
OS:                Linux

After you enter it incorrectly flogged root in KDE settings, resize the window I was flogged. It increases in length and decreases in height.
See screenshots
In KDE 4.5.5 this problem is absent.

Reproducible: Always
Comment 1 Igor Strelnikoff 2011-04-06 20:56:52 UTC
Created attachment 58649 [details]
After an incorrect password
Comment 2 Igor Strelnikoff 2011-04-06 20:58:47 UTC
Created attachment 58650 [details]
Before the wrong password
Comment 3 Igor Strelnikoff 2012-07-28 14:59:39 UTC
Still present in KDE 4.7.4
Comment 4 Misbachul Munir 2012-10-06 00:48:01 UTC
I can confirm that this bugs still exist on KDE SC 4.9.2. As an additional note, the dialog size changed again after the second wrong password. See screenshot.
Comment 5 Misbachul Munir 2012-10-06 00:50:22 UTC
Created attachment 74367 [details]
kdesu dialog after the 2nd time wrong password
Comment 6 Misbachul Munir 2012-10-06 00:53:39 UTC
I think this bug should be marked as an Extra Mile Bug (http://community.kde.org/Getinvolved/Extra_Mile)
Comment 7 Roman Bysh 2014-02-26 19:47:20 UTC
Created attachment 85340 [details]
Screenshot of password field
Comment 8 Roman Bysh 2014-02-26 19:48:40 UTC
Update requesting a patch 

This bug still exists in 4.10x with openSUSE 12x series and 4.11.1 right to 4.11.5 with openSUSE 13.1. So for the last three years people have been requesting a patch.
Comment 9 Roman Bysh 2014-02-27 19:46:28 UTC
Follow Up Please
Can someone please add this bug 270245 to the ExtraMile bug tracker? 
https://bugs.kde.org/show_bug.cgi?id=extramiler?
Comment 10 Roman Bysh 2015-03-22 23:47:28 UTC
Status Please

Can this be resolved some time in 2015?
Comment 11 Christoph Feck 2015-11-04 22:13:17 UTC
*** Bug 354857 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2016-07-29 14:48:11 UTC
The size increasing when additional messages need to be displayed is intended.

The wrong initial minimum size should be fixed in kde-cli-extras master.
Comment 13 Nate Graham 2017-11-29 23:30:28 UTC
As Christoph mentioned, the greater subsequent size is intentional and required, to display the extra text. The incorrect minimum size was recently fixed in Bug 381231.