Bug 270021 - Plasma Workspace crashed without any reason
Summary: Plasma Workspace crashed without any reason
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-03 18:53 UTC by someone
Modified: 2011-04-04 13:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description someone 2011-04-03 18:53:41 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1) "release 2"
Qt Version: 4.7.2
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I was listening to music in Amarok and I did some settings in Amaroks settings: I switched off (ticked off) "show icon in taskbar" in Amarok and as soon as I hit "apply" Plasma crashed and restored immediatly. This can not be repeated anymore.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc9e55e9760 (LWP 4324))]

Thread 2 (Thread 0x7fc9c2cbe700 (LWP 4328)):
#0  0x00007fc9e2cd8503 in poll () from /lib64/libc.so.6
#1  0x00007fc9dfb3a114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fc9dfb3a650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fc9e42ce286 in QEventDispatcherGlib::processEvents (this=0xd8c800, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc9e42a28d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc9e42a2ae5 in QEventLoop::exec (this=0x7fc9c2cbdde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc9e41b77a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fc9e4284008 in QInotifyFileSystemWatcherEngine::run (this=0xca9580) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc9e41ba095 in QThreadPrivate::start (arg=0xca9580) at thread/qthread_unix.cpp:320
#9  0x00007fc9e3f29a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fc9e2ce167d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc9e55e9760 (LWP 4324)):
[KCrash Handler]
#6  0x00007fc9e4f31e8f in QString (this=0xdc0075, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0xdc0075, group=0, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#8  0x00007fc9e4f33410 in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#9  0x00007fc9e5060ef1 in KIconLoader::loadIcon (this=0x6ead70, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#10 0x00007fc9e5061fb0 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
#11 0x00007fc9e34f5a65 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007fc9db0a87a1 in Plasma::IconWidgetPrivate::decoration (this=0x10ca7f0, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:812
#13 0x00007fc9db0ae60b in Plasma::IconWidget::paint (this=0x130c6b0, painter=0x7fffa64da9d0, option=0x721518, widget=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:1128
#14 0x00007fc9ca7c3c19 in SystemTray::DBusSystemTrayWidget::paint (this=0x130c6b0, painter=0x7fffa64da9d0, option=0x721518, widget=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#15 0x00007fc9e3a33eed in _q_paintItem (item=<value optimized out>, painter=0x7fffa64da9d0, option=0x721518, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007fc9e3a34200 in _q_paintIntoCache (pix=0x7fffa64daf20, item=0x130c6c0, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x721518, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007fc9e3a48192 in QGraphicsScenePrivate::drawItemHelper (this=0x7212f0, item=0x130c6c0, painter=0x7fffa64dcfa0, option=<value optimized out>, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007fc9e3a48cf8 in QGraphicsScenePrivate::draw (this=0x7212f0, item=0x130c6c0, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, transformPtr=0x7fffa64db5f0, exposedRegion=0xf7d140, widget=0x6e9f40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007fc9e3a49957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7212f0, item=0x130c6c0, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, exposedRegion=0xf7d140, widget=0x6e9f40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007fc9e3a48b70 in QGraphicsScenePrivate::draw (this=0x7212f0, item=0xa0d870, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, transformPtr=0x7fffa64dbc00, exposedRegion=0xf7d140, widget=0x6e9f40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007fc9e3a49957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7212f0, item=0xa0d870, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, exposedRegion=0xf7d140, widget=0x6e9f40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007fc9e3a48b70 in QGraphicsScenePrivate::draw (this=0x7212f0, item=0x9eab60, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, transformPtr=0x7fffa64dc210, exposedRegion=0xf7d140, widget=0x6e9f40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007fc9e3a49957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7212f0, item=0x9eab60, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, exposedRegion=0xf7d140, widget=0x6e9f40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007fc9e3a48b70 in QGraphicsScenePrivate::draw (this=0x7212f0, item=0x8ba960, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, transformPtr=0x7fffa64dc820, exposedRegion=0xf7d140, widget=0x6e9f40, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007fc9e3a49957 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7212f0, item=0x8ba960, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, exposedRegion=0xf7d140, widget=0x6e9f40, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007fc9e3a4a1ec in QGraphicsScenePrivate::drawItems (this=0x7212f0, painter=0x7fffa64dcfa0, viewTransform=0x7fffa64dcd30, exposedRegion=0xf7d140, widget=0x6e9f40) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007fc9e3a6749c in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007fc9e349fc0e in QWidget::event (this=0xd938a0, event=0x7fffa64dd8f0) at kernel/qwidget.cpp:8405
#29 0x00007fc9e3844a86 in QFrame::event (this=0xd938a0, e=0x7fffa64dd8f0) at widgets/qframe.cpp:557
#30 0x00007fc9e3a6873b in QGraphicsView::viewportEvent (this=0xd938a0, event=0x7fffa64dd8f0) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007fc9e42a3607 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x6e9f40, event=0x7fffa64dd8f0) at kernel/qcoreapplication.cpp:846
#32 0x00007fc9e344e111 in QApplicationPrivate::notify_helper (this=0x6a6010, receiver=0x6e9f40, e=0x7fffa64dd8f0) at kernel/qapplication.cpp:4458
#33 0x00007fc9e34566fa in QApplication::notify (this=<value optimized out>, receiver=0x6e9f40, e=0x7fffa64dd8f0) at kernel/qapplication.cpp:4341
#34 0x00007fc9e4f48d46 in KApplication::notify (this=0x69be00, receiver=0x6e9f40, event=0x7fffa64dd8f0) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#35 0x00007fc9e42a347c in QCoreApplication::notifyInternal (this=0x69be00, receiver=0x6e9f40, event=0x7fffa64dd8f0) at kernel/qcoreapplication.cpp:731
#36 0x00007fc9e349cae2 in sendSpontaneousEvent (this=0xf52160, pdev=0xab2b28, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf26a90) at ../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0xf52160, pdev=0xab2b28, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf26a90) at kernel/qwidget.cpp:5492
#38 0x00007fc9e349d6af in QWidgetPrivate::paintSiblingsRecursive (this=0xf7ccb0, pdev=0xab2b28, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xf26a90) at kernel/qwidget.cpp:5699
#39 0x00007fc9e349c84a in QWidgetPrivate::drawWidget (this=0xf7ccb0, pdev=0xab2b28, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0xf26a90) at kernel/qwidget.cpp:5545
#40 0x00007fc9e365fcf1 in QWidgetBackingStore::sync (this=0xf26a90) at painting/qbackingstore.cpp:1333
#41 0x00007fc9e3492720 in QWidgetPrivate::syncBackingStore (this=0xf7ccb0) at kernel/qwidget.cpp:1842
#42 0x00007fc9e34a0112 in QWidget::event (this=0xd938a0, event=0x6ead70) at kernel/qwidget.cpp:8552
#43 0x00007fc9e3844a86 in QFrame::event (this=0xd938a0, e=0x6ead70) at widgets/qframe.cpp:557
#44 0x00007fc9e38c5bab in QAbstractScrollArea::event (this=0xd938a0, e=0x6ead70) at widgets/qabstractscrollarea.cpp:996
#45 0x00007fc9d3064250 in PanelView::event (this=0xd938a0, event=0x6ead70) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/panelview.cpp:1505
#46 0x00007fc9e344e144 in QApplicationPrivate::notify_helper (this=0x6a6010, receiver=0xd938a0, e=0x6ead70) at kernel/qapplication.cpp:4462
#47 0x00007fc9e34566fa in QApplication::notify (this=<value optimized out>, receiver=0xd938a0, e=0x6ead70) at kernel/qapplication.cpp:4341
#48 0x00007fc9e4f48d46 in KApplication::notify (this=0x69be00, receiver=0xd938a0, event=0x6ead70) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#49 0x00007fc9e42a347c in QCoreApplication::notifyInternal (this=0x69be00, receiver=0xd938a0, event=0x6ead70) at kernel/qcoreapplication.cpp:731
#50 0x00007fc9e42a6c75 in sendEvent (receiver=0xd938a0, event_type=77, data=0x6103e0) at kernel/qcoreapplication.h:215
#51 QCoreApplicationPrivate::sendPostedEvents (receiver=0xd938a0, event_type=77, data=0x6103e0) at kernel/qcoreapplication.cpp:1372
#52 0x00007fc9e3a40a6a in dispatchPendingUpdateRequests (this=0x7212f0) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x7212f0) at graphicsview/qgraphicsscene.cpp:510
#54 0x00007fc9e3a40e6a in QGraphicsScene::qt_metacall (this=0x798ec0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x1306c20) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0x00007fc9daffc2b5 in Plasma::Corona::qt_metacall (this=0x798ec0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1306c20) at /usr/src/debug/kdelibs-4.6.1/build/plasma/corona.moc:109
#56 0x00007fc9d3058285 in DesktopCorona::qt_metacall (this=0x798ec0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1306c20) at /usr/src/debug/kdebase-workspace-4.6.1/build/plasma/desktop/shell/desktopcorona.moc:101
#57 0x00007fc9e42b737a in QObject::event (this=0x798ec0, e=<value optimized out>) at kernel/qobject.cpp:1217
#58 0x00007fc9e3a4db40 in QGraphicsScene::event (this=0x798ec0, event=0x1089bd0) at graphicsview/qgraphicsscene.cpp:3544
#59 0x00007fc9e344e144 in QApplicationPrivate::notify_helper (this=0x6a6010, receiver=0x798ec0, e=0x1089bd0) at kernel/qapplication.cpp:4462
#60 0x00007fc9e34566fa in QApplication::notify (this=<value optimized out>, receiver=0x798ec0, e=0x1089bd0) at kernel/qapplication.cpp:4341
#61 0x00007fc9e4f48d46 in KApplication::notify (this=0x69be00, receiver=0x798ec0, event=0x1089bd0) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#62 0x00007fc9e42a347c in QCoreApplication::notifyInternal (this=0x69be00, receiver=0x798ec0, event=0x1089bd0) at kernel/qcoreapplication.cpp:731
#63 0x00007fc9e42a6c75 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#64 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1372
#65 0x00007fc9e42ce093 in sendPostedEvents (s=0x6a8690) at kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=0x6a8690) at kernel/qeventdispatcher_glib.cpp:277
#67 0x00007fc9dfb39bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#68 0x00007fc9dfb3a3b0 in ?? () from /lib64/libglib-2.0.so.0
#69 0x00007fc9dfb3a650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#70 0x00007fc9e42ce22f in QEventDispatcherGlib::processEvents (this=0x69c840, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#71 0x00007fc9e34f3bae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x00007fc9e42a28d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#73 0x00007fc9e42a2ae5 in QEventLoop::exec (this=0x7fffa64df970, flags=...) at kernel/qeventloop.cpp:201
#74 0x00007fc9e42a6f2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#75 0x00007fc9d305ed48 in kdemain (argc=1, argv=0x67e6b0) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/main.cpp:118
#76 0x00000000004075c9 in _start ()

This bug may be a duplicate of or related to bug 269147.

Possible duplicates by query: bug 270009, bug 269944, bug 269869, bug 269672, bug 269615.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-04-04 13:17:28 UTC

*** This bug has been marked as a duplicate of bug 258706 ***