Bug 269788 - OSD display preview cannot be positioned at the bottom half of the screen
Summary: OSD display preview cannot be positioned at the bottom half of the screen
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Notifications (show other bugs)
Version: 2.6-git
Platform: openSUSE RPMs Linux
: NOR normal with 85 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords: junior-jobs, regression
: 281437 288709 301404 316670 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-30 23:26 UTC by Vadym Krevs
Modified: 2013-03-13 22:19 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vadym Krevs 2011-03-30 23:26:27 UTC
Version:           2.4.0.90 (using KDE 4.6.1) 
OS:                Linux

Go to Settings->Configure Amarok ->Notifications.
Check "Use On-Screen-Display" and attempt to drag and drop the OSD preview to the bottom right corner using the mouse. 
As soon as mouse key is released, the OSD jumps back to midscreen. Same when trying to put the OSD at the mid bottom or bottom left corner of the screen.

This wasn't an issue with previous versions of amarok.

Reproducible: Always




OS: Linux (x86_64) release 2.6.37.1-1.2-desktop
Compiler: gcc
Comment 1 Myriam Schweingruber 2011-03-31 11:46:06 UTC
Confirmed with current Amarok 2.4-git, using Kubuntu 10.10 with KDE 4.6.1
Comment 2 Myriam Schweingruber 2011-06-04 12:24:47 UTC
This is an automated message from the triager:

Amarok 2.4.1 has been released on May 8 already. Could you please upgrade and test if you can still reproduce this bug?

Without feedback within a month we will close this bug as resolved.

Thank you for your understanding.
Comment 3 Vadym Krevs 2011-06-04 12:58:25 UTC
Still an issue with Amarok 2.4.1 from latest openSUSE 11.4 OBS.
Comment 4 Myriam Schweingruber 2011-06-04 14:04:12 UTC
Thank you for the fast feedback :)
Comment 5 Myriam Schweingruber 2011-09-06 07:37:44 UTC
*** Bug 281437 has been marked as a duplicate of this bug. ***
Comment 6 Myriam Schweingruber 2011-12-27 20:25:40 UTC
*** Bug 288709 has been marked as a duplicate of this bug. ***
Comment 7 Eduard Huguet 2011-12-28 07:49:41 UTC
Confirmed on openSUSE 12.1 from KDE:UpdatedApps repository, which right now
contains Amarok 2.4.3.

In my case, the OSD wants to stay vertically centered on the screen, I'm only
allowed to change its horizontal position, and only to 3 predefined snap points
at left, center and right side.

Is this a bug or a new "feature" we are not aware of...?
Comment 8 Michael Skiba 2012-03-03 17:34:07 UTC
I can confirm this behavior with Amarok 2.5.0 (KDE 4.8) on Ubuntu
Comment 9 Myriam Schweingruber 2012-03-04 00:15:18 UTC
Thank you for the feedback.
Comment 10 Oliver Hoffmann 2012-03-25 12:20:52 UTC
I have the same problem and I want to mention that there's a workaround:

Just edit /.kde4/share/config/amarokrc, while amarok is *not* running, and change the following line:

[OSD]
Osd Y Offset=...

Don't know how to change the X Offset so, as the obvious doesn't seem to work.
Comment 11 daniel 2012-04-13 17:29:26 UTC
I confirm this bug in amarok 2.5.0 on Kubuntu 4.12 beta ,kde 4.8
Comment 12 Myriam Schweingruber 2012-06-07 23:05:37 UTC
*** Bug 301404 has been marked as a duplicate of this bug. ***
Comment 13 Myriam Schweingruber 2012-06-07 23:06:14 UTC
This is partially solved in the upcoming Amarok 2.6, you can already test with Amarok 2.6 beta1.

What currently doesn't work:
* can't be placed on a second monitor that is not set as the primary output.
* can not be moved to the bottom half of the screen, only the upper and middle parts of the screen can be used.
Comment 14 Dan Duris 2012-07-10 11:49:46 UTC
why was this bug even introduced? it has been working alright for ages and now we are suddenly stuck with OSD notification completely unusable taking the middle of the screen where other important information are covered over by this.

and how is the bug resolved, if you still can't move OSD to the bottom in 2.6.1? this is definitely not "solved".
Comment 15 Myriam Schweingruber 2012-07-11 16:12:18 UTC
Well, we certainly don't introduce bugs on purpose...

Also I said partially solved, read again, please. I didn't close the bug, didn't I?
Comment 16 Michael Skiba 2012-07-11 18:59:06 UTC
No, the bug is still "new" and as valid as before ;-)

Does someone know if/when there was the last amarok version that had the OSD working correctly?
Or has this bug been present ever since in the amarok 2.x series?
Comment 17 Heitor Moreira da Silva 2012-09-01 18:33:42 UTC
(In reply to comment #10)
> I have the same problem and I want to mention that there's a workaround:
> 
> Just edit /.kde4/share/config/amarokrc, while amarok is *not* running, and
> change the following line:
> 
> [OSD]
> Osd Y Offset=...
> 
> Don't know how to change the X Offset so, as the obvious doesn't seem to
> work.

Thanks Oliver Hoffmann.

Just in addition I confirm the bug in version 2.5.0.

For those running Kubuntu 12.04.1 the right location of the configuration file is: ~/.kde/share/config/amarokrc

Check this section of the indicated file:
[OSD]
Osd Alignment=Right
Osd Enabled=true
Osd Y Offset=750

In a screen resolution of 1440x900 it will be enough to put the OSD on the right bottom of your screen. In case of bigger or smaller resolution just change the value of the attribute "Osd Y Offset" with the Amarok closed.
Comment 18 Mayank Madan 2012-11-30 09:47:09 UTC
Bug is reproducible in 2.6-git
Comment 19 Myriam Schweingruber 2012-11-30 10:52:37 UTC
Adapting bug description to the current status.
Comment 20 Mayank Madan 2012-12-18 13:49:25 UTC
Can reproduce this bug with v2.6.90-25-g9b18527
Comment 21 Ralf Engels 2013-02-10 13:02:53 UTC
Reading throught the code it seems like the OSD cannot be vertical positioned at all.
The only possible alignments are
 enum Alignment { Left, Middle, Center, Right };

It's confusing but working as implemented.
So I change this to a wish and the title and add junior_job
Comment 22 Heitor Moreira da Silva 2013-02-10 17:12:37 UTC
(In reply to comment #21)
> Reading throught the code it seems like the OSD cannot be vertical
> positioned at all.
> The only possible alignments are
>  enum Alignment { Left, Middle, Center, Right };
> 
> It's confusing but working as implemented.
> So I change this to a wish and the title and add junior_job

Dear @Ralf Engels,
Since it used to work in the past, as mentioned here, wouldn't it be a regression problem?
Comment 23 Myriam Schweingruber 2013-02-11 08:57:57 UTC
Yes, this is definitely a regression as it did work before, so a real bug, not a wish. I am also not sure a Junior Job is a good idea in this case, as finding what caused the regression might be tricky.
Comment 24 Dan Duris 2013-02-11 09:31:47 UTC
It's interesting that this used to always work, just with recent changes in Amarok we are now stuck with vertically centered OSD and unable to drag it conveniently.

This regression has been around for long enough to be fixed, but rather somebody just tags it as a wish instead. Great. [sarcasm off]
Comment 25 Myriam Schweingruber 2013-02-11 09:36:13 UTC
(In reply to comment #24)
> It's interesting that this used to always work, just with recent changes in
> Amarok we are now stuck with vertically centered OSD and unable to drag it
> conveniently.
> 
> This regression has been around for long enough to be fixed, but rather
> somebody just tags it as a wish instead. Great. [sarcasm off]

Right, and how does your comment contribute to the fix of it?
Comment 26 Michael Skiba 2013-02-11 09:48:49 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > It's interesting that this used to always work, just with recent changes in
> > Amarok we are now stuck with vertically centered OSD and unable to drag it
> > conveniently.
> > 
> > This regression has been around for long enough to be fixed, but rather
> > somebody just tags it as a wish instead. Great. [sarcasm off]
> 
> Right, and how does your comment contribute to the fix of it?
+1 Myriam

To make the search easier: Does anyone happen to know whether this is this a regression inside amarok 2 or was this behavior introduced during the switch from amarok 1.x to amarok 2.x?
Comment 27 Dan Duris 2013-02-11 10:00:28 UTC
no, it used to work in 2.x
Comment 28 Ralf Engels 2013-02-11 18:36:16 UTC
I am looking at the code here and it's clear.

- There are four possible positions and only the "Middle" position influences the Y position.
- The jumping around is part of the code.
- There were no substential changes since years.

I can't see how that was a regression and it is really a nice junior job to extend the code.
Comment 29 Dan Duris 2013-02-11 18:39:24 UTC
Interesting, so you are saying that bottom vertical position has not been possible before? Then how is it that I have always had it there (bottom left corner) and just with a recent updates (maybe 5 months back) it stopped working?
Comment 30 Ralf Engels 2013-02-11 18:54:51 UTC
I still have it at the bottom right corner and I am running the latest Amarok version.

Just looking at the code again.
It's confusing, inconsistent and somebody should clean the code up.
Since it's so confusing I am admitting that I might have overlooked a slight change that could have broken the whole thing.
Comment 31 Myriam Schweingruber 2013-03-02 20:30:15 UTC
Git commit 9dae4c63d69658b97f6844d87cc4ef8fd4175851 by Mark Kretschmann.
Committed on 02/03/2013 at 19:00.
Pushed by markey into branch 'master'.

Fix vertical positioning of On-Screen-Display.

Due to a bug the widget could not be moved vertically.

M  +1    -0    ChangeLog
M  +11   -15   src/widgets/Osd.cpp
M  +3    -3    src/widgets/Osd.h

http://commits.kde.org/amarok/9dae4c63d69658b97f6844d87cc4ef8fd4175851
Comment 32 Myriam Schweingruber 2013-03-13 22:19:21 UTC
*** Bug 316670 has been marked as a duplicate of this bug. ***