Bug 264250 - Plasma workspace crashed
Summary: Plasma workspace crashed
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 263539 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-25 14:16 UTC by Dave
Modified: 2011-03-05 11:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2011-01-25 14:16:07 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
browsing web with mozilla firefox
Listening music via VLC player
Making some counting via BOINC Manager
Using Skype

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ac720 (LWP 1368))]

Thread 2 (Thread 0xaebb9b70 (LWP 1370)):
#0  0x05061e36 in clock_gettime () from /lib/librt.so.1
#1  0x06d5450b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x06e2b6e5 in QTimerInfoList::updateCurrentTime (this=0xafb21054) at kernel/qeventdispatcher_unix.cpp:339
#4  0x06e2b72a in QTimerInfoList::timerWait (this=0xafb21054, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x06e297a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaebb90ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x06e2983d in timerSourcePrepare (source=0x0, timeout=0x5065ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x05d8ae6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x05d8b279 in ?? () from /lib/libglib-2.0.so.0
#9  0x05d8b848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x06e2959f in QEventDispatcherGlib::processEvents (this=0xafb0a5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x06df9609 in QEventLoop::processEvents (this=0xaebb9280, flags=) at kernel/qeventloop.cpp:149
#12 0x06df9a8a in QEventLoop::exec (this=0xaebb9280, flags=...) at kernel/qeventloop.cpp:201
#13 0x06cf5b7e in QThread::exec (this=0x9f06a08) at thread/qthread.cpp:490
#14 0x06dd835b in QInotifyFileSystemWatcherEngine::run (this=0x9f06a08) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x06cf8df9 in QThreadPrivate::start (arg=0x9f06a08) at thread/qthread_unix.cpp:266
#16 0x00c2dcc9 in start_thread () from /lib/libpthread.so.0
#17 0x001e069e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77ac720 (LWP 1368)):
[KCrash Handler]
#7  0x00aad3aa in KJob::isAutoDelete (this=0xab73030) at ../../kdecore/jobs/kjob.cpp:353
#8  0x004185a7 in Plasma::ServiceJob::setResult (this=0xab73030, result=...) at ../../plasma/servicejob.cpp:80
#9  0x0825bd6d in StatusNotifierItemJob::contextMenuReady (this=0xab73030, menu=0xaba4868) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0x0825bded in StatusNotifierItemJob::qt_metacall (this=0xab73030, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbff82958) at ./statusnotifieritemjob.moc:75
#11 0x06e008ca in QMetaObject::metacall (object=0xab73030, cl=116582840, idx=27, argv=0xbff82958) at kernel/qmetaobject.cpp:237
#12 0x06e136ad in QMetaObject::activate (sender=0xa965d98, m=0x8262c40, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#13 0x082550a3 in StatusNotifierItemSource::contextMenuReady (this=0xa965d98, _t1=0xaba4868) at ./statusnotifieritemsource.moc:109
#14 0x082552b1 in StatusNotifierItemSource::contextMenuReady (this=0xa965d98) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#15 0x0825a803 in StatusNotifierItemSource::qt_metacall (this=0xa965d98, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbff82a7c) at ./statusnotifieritemsource.moc:90
#16 0x06e008ca in QMetaObject::metacall (object=0xa965d98, cl=116582840, idx=11, argv=0xbff82a7c) at kernel/qmetaobject.cpp:237
#17 0x06e136ad in QMetaObject::activate (sender=0xa7fba88, m=0x3bc6d84, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#18 0x03bb1567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#19 0x03bb6cdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x03bb7f2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#21 0x06e008ca in QMetaObject::metacall (object=0xa7fba88, cl=116582840, idx=12, argv=0xbff82cbc) at kernel/qmetaobject.cpp:237
#22 0x06e136ad in QMetaObject::activate (sender=0xaba4868, m=0x9112fe8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#23 0x08c51ee7 in QMenu::aboutToShow (this=0xaba4868) at .moc/release-shared/moc_qmenu.cpp:151
#24 0x08c59193 in QMenu::qt_metacall (this=0xaba4868, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff82e0c) at .moc/release-shared/moc_qmenu.cpp:97
#25 0x06e008ca in QMetaObject::metacall (object=0xaba4868, cl=116582840, idx=27, argv=0xbff82e0c) at kernel/qmetaobject.cpp:237
#26 0x06e04352 in QMetaMethod::invoke (this=0xbff82f9c, object=0xaba4868, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#27 0x06e05a1f in QMetaObject::invokeMethod (obj=0xaba4868, member=0x3bbd3e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#28 0x03bb193e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#29 0x082566ef in StatusNotifierItemSource::contextMenu (this=0xa965d98, x=1056, y=1009) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#30 0x0825d33e in StatusNotifierItemJob::start (this=0xab73030) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#31 0x00418423 in Plasma::ServiceJobPrivate::slotStart (this=0xa4f6c10) at ../../plasma/servicejob.cpp:37
#32 0x004184f4 in Plasma::ServiceJob::qt_metacall (this=0xab73030, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xaad79c8) at ./servicejob.moc:72
#33 0x0825bdca in StatusNotifierItemJob::qt_metacall (this=0xab73030, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xaad79c8) at ./statusnotifieritemjob.moc:70
#34 0x06e008ca in QMetaObject::metacall (object=0xab73030, cl=116582840, idx=26, argv=0xaad79c8) at kernel/qmetaobject.cpp:237
#35 0x06e0bdf6 in QMetaCallEvent::placeMetaCall (this=0xa6c9b88, object=0xab73030) at kernel/qobject.cpp:534
#36 0x06e0d6a2 in QObject::event (this=0xab73030, e=0x9a6e400) at kernel/qobject.cpp:1219
#37 0x0878dfdc in QApplicationPrivate::notify_helper (this=0x99a2060, receiver=0xab73030, e=0xa6c9b88) at kernel/qapplication.cpp:4396
#38 0x0879404e in QApplication::notify (this=0x99935e8, receiver=0xab73030, e=0xa6c9b88) at kernel/qapplication.cpp:3798
#39 0x0110268a in KApplication::notify (this=0x99935e8, receiver=0xab73030, event=0xa6c9b88) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x06dfab3b in QCoreApplication::notifyInternal (this=0x99935e8, receiver=0xab73030, event=0xa6c9b88) at kernel/qcoreapplication.cpp:732
#41 0x06dfdd8b in sendEvent (receiver=0x0, event_type=0, data=0x997d028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x997d028) at kernel/qcoreapplication.cpp:1373
#43 0x06dfdf4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x06e29a74 in sendPostedEvents (s=0x99a4db0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x99a4db0) at kernel/qeventdispatcher_glib.cpp:277
#46 0x05d87855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x05d8b668 in ?? () from /lib/libglib-2.0.so.0
#48 0x05d8b848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x06e29565 in QEventDispatcherGlib::processEvents (this=0x997cce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0x0884fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x997cce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x06df9609 in QEventLoop::processEvents (this=0xbff83d74, flags=) at kernel/qeventloop.cpp:149
#52 0x06df9a8a in QEventLoop::exec (this=0xbff83d74, flags=...) at kernel/qeventloop.cpp:201
#53 0x06dfe00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x0878ce07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0x00ef586e in kdemain (argc=1, argv=0xbff83f84) at ../../../../plasma/desktop/shell/main.cpp:118
#56 0x080485bb in main (argc=1, argv=0xbff83f84) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 263539, bug 262559, bug 262062, bug 260710, bug 259530.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-29 14:09:37 UTC
[Comment from a bug triager]
This is fixed in KDE SC 4.5.5 and later
Merging with bug 241562. Thanks

*** This bug has been marked as a duplicate of bug 241562 ***
Comment 2 Dario Andres 2011-03-05 11:51:58 UTC
*** Bug 263539 has been marked as a duplicate of this bug. ***