Bug 182372 - kded4 random SIGABRT while idle (KDirWatchPrivate::removeEntries, QListData::realloc assert)
Summary: kded4 random SIGABRT while idle (KDirWatchPrivate::removeEntries, QListData::...
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords: investigated, triaged
: 268173 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-30 03:01 UTC by WhyDoIHaveToRegister
Modified: 2018-10-27 02:18 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Another crash log (3.00 KB, application/octet-stream)
2009-06-05 04:25 UTC, WhyDoIHaveToRegister
Details

Note You need to log in before you can comment on or make changes to this bug.
Description WhyDoIHaveToRegister 2009-01-30 03:01:37 UTC
Version:            (using KDE 3.5.10)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Ubuntu Packages

Just woke up, clicked the update manager in the panel and let it update, and about 20 minutes after it was done, shut the monitors off and went out for a few hours like I usually do. When I got back I found a message on the screen saying kded4 had crashed with the following backtrace:
Application: KDE Daemon (kded4), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb61e58d0 (LWP 11193)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb803f430 in __kernel_vsyscall ()
#7  0xb7eca880 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7ecc248 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7cbe795 in qt_message_output () from /usr/lib/libQtCore.so.4
#10 0xb7cbe872 in qFatal () from /usr/lib/libQtCore.so.4
#11 0xb7cea086 in QListData::realloc () from /usr/lib/libQtCore.so.4
#12 0xb7cea2b3 in QListData::append () from /usr/lib/libQtCore.so.4
#13 0xb7507871 in ?? () from /usr/lib/libkio.so.5
#14 0xb7575127 in ?? () from /usr/lib/libkio.so.5
#15 0xb75754a0 in KDirWatch::~KDirWatch () from /usr/lib/libkio.so.5
#16 0xb8002310 in ?? () from /usr/lib/libkdeinit4_kded4.so
#17 0xb8004d20 in ?? () from /usr/lib/libkdeinit4_kded4.so
#18 0xb8004db9 in ?? () from /usr/lib/libkdeinit4_kded4.so
#19 0xb8007393 in ?? () from /usr/lib/libkdeinit4_kded4.so
#20 0xb7dcba60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb7dcc7e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#22 0xb7e067a7 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#23 0xb7dd240e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#24 0xb7dc653f in QObject::event () from /usr/lib/libQtCore.so.4
#25 0xb6b478ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#26 0xb6b4f72e in QApplication::notify () from /usr/lib/libQtGui.so.4
#27 0xb78b9b2d in KApplication::notify () from /usr/lib/libkdeui.so.5
#28 0xb7db6e61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#29 0xb7de4d81 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb7de1520 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb687a6f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb687dda3 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb687df61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb7de1478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#35 0xb6be1ea5 in ?? () from /usr/lib/libQtGui.so.4
#36 0xb7db552a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#37 0xb7db56ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#38 0xb7db7da5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#39 0xb6b47767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#40 0xb80080a6 in kdemain () from /usr/lib/libkdeinit4_kded4.so
#41 0x080485a2 in _start ()
#0  0xb803f430 in __kernel_vsyscall ()


The only KDE app running was Amarok, which is still running and working fine. I'm using Xubuntu 8.10, Linux 2.6.27-9-generic, GNOME 2.24.1, which as far as I know came with a few bits of KDE already installed (or they came with Amarok).
Comment 1 Christoph Wurm 2009-01-30 22:02:22 UTC
Thanks for taking the time to report this bug.
Unfortunately, that backtrace is missing some elements that will help a lot to solve the problem, so it will be hard for the developers to fix that crash. 
Can you get us a backtrace with debugging symbols? 
Please see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports for more information on how to do so. 

Thanks in advance!
Comment 2 WhyDoIHaveToRegister 2009-01-31 01:56:43 UTC
I can install the debug libraries and wait for it to happen again, but what's the debug version of libkio?
Comment 3 Dario Andres 2009-01-31 14:48:48 UTC
libkio is part of kdelibs, so installing "kdelibs5-dbg" would do the trick
Not sure why Version is "(using KDE 3.5.10)"

And you have to register because we need to ensure that you will get out mails in order to answer out questions to triage and fix the bugs.

Thanks
Comment 4 WhyDoIHaveToRegister 2009-02-25 17:16:27 UTC
It just crashed again while browsing the web. Got a more useful backtrace this time.

Application: KDE Daemon (kded4), signal SIGABRT

Thread 1 (Thread 0xb613c8d0 (LWP 20443)):
[KCrash Handler]
#6  0xb7f97430 in __kernel_vsyscall ()
#7  0xb7e218a0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7e23268 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7412795 in qt_message_output () from /usr/lib/libQtCore.so.4
#10 0xb7412872 in qFatal () from /usr/lib/libQtCore.so.4
#11 0xb743e086 in QListData::realloc () from /usr/lib/libQtCore.so.4
#12 0xb743e2b3 in QListData::append () from /usr/lib/libQtCore.so.4
#13 0xb7c109b1 in QList<QString>::append (this=0xbf896118, t=@0x8e5e268) at /usr/include/qt4/QtCore/qlist.h:421
#14 0xb7c7eb07 in KDirWatchPrivate::removeEntries (this=0x8d25bf0, instance=0x8d25bd0) at /build/buildd/kde4libs-4.1.4/kio/kio/kdirwatch.cpp:873
#15 0xb7c7ee80 in ~KDirWatch (this=0x8d25bd0) at /build/buildd/kde4libs-4.1.4/kio/kio/kdirwatch.cpp:1541
#16 0xb7f59040 in Kded::updateDirWatch (this=0x8cccbf8) at /build/buildd/kde4libs-4.1.4/kded/kded.cpp:378
#17 0xb7f5b2e0 in Kded::recreate (this=0x8cccbf8, initial=false) at /build/buildd/kde4libs-4.1.4/kded/kded.cpp:439
#18 0xb7f5b379 in Kded::recreate (this=0x8cccbf8) at /build/buildd/kde4libs-4.1.4/kded/kded.cpp:421
#19 0xb7f5dab3 in Kded::qt_metacall (this=0x8cccbf8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf896248) at /build/buildd/kde4libs-4.1.4/obj-i486-linux-gnu/kded/kded.moc:81
#20 0xb751fa60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#21 0xb75207e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#22 0xb755a7a7 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#23 0xb752640e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#24 0xb751a53f in QObject::event () from /usr/lib/libQtCore.so.4
#25 0xb6a9d8ec in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#26 0xb6aa572e in QApplication::notify () from /usr/lib/libQtGui.so.4
#27 0xb79d9d1d in KApplication::notify (this=0xbf8969d0, receiver=0x8ccd178, event=0xbf8966dc) at /build/buildd/kde4libs-4.1.4/kdeui/kernel/kapplication.cpp:311
#28 0xb750ae61 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#29 0xb7538d81 in ?? () from /usr/lib/libQtCore.so.4
#30 0xb7535520 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb64cd6f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb64d0da3 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb64d0f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0xb7535478 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#35 0xb6b37ea5 in ?? () from /usr/lib/libQtGui.so.4
#36 0xb750952a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#37 0xb75096ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#38 0xb750bda5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#39 0xb6a9d767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#40 0xb7f5eec6 in kdemain (argc=1, argv=0xbf896c64) at /build/buildd/kde4libs-4.1.4/kded/kded.cpp:851
#41 0x080485a2 in main (argc=) at /build/buildd/kde4libs-4.1.4/obj-i486-linux-gnu/kded/kded4_dummy.cpp:3

Again just had Amarok idling in the background. I know it uses directory watching... it looks like a realloc failed, but I have just over 400MB of RAM free.
Comment 5 WhyDoIHaveToRegister 2009-06-05 04:25:25 UTC
Created attachment 34274 [details]
Another crash log

Been a while, but it happened again.
Comment 6 Dario Andres 2009-06-07 16:04:34 UTC
Backtrace on comment 5 looks the same as the one on comment 4.
I wonder if this could be fixed on KDE4.2. (you are encouraged to update if there are packages availables). Thanks
Comment 7 WhyDoIHaveToRegister 2009-06-07 17:00:57 UTC
Doesn't look like there are new versions of any KDE packages available on Xubuntu 8.10. Would I have to update to 9.04?
Comment 8 Dario Andres 2009-06-07 20:50:22 UTC
(In reply to comment #7)
> Doesn't look like there are new versions of any KDE packages available on
> Xubuntu 8.10. Would I have to update to 9.04?

Only if you want to ;)
Comment 9 WhyDoIHaveToRegister 2009-06-08 17:54:33 UTC
Well the automatic upgrade has had a history of breaking my system so I've been putting off doing it manually. How would I update KDE on 8.10?
Comment 10 Dario Andres 2009-07-07 22:40:18 UTC
Using shell commands. "apt-get dist-upgrade" 
Thanks
Comment 11 Christoph Feck 2011-07-28 16:44:51 UTC
What is the status of this bug in recent KDE versions (4.6.5 or 4.7)? Please add a comment.
Comment 12 Asen Lekov 2011-11-24 17:24:57 UTC
Duplicate of bug 182372
Comment 13 Myriam Schweingruber 2011-11-25 20:03:01 UTC
*** Bug 268173 has been marked as a duplicate of this bug. ***
Comment 14 Myriam Schweingruber 2011-11-25 20:05:19 UTC
bug 268173 shows the same problem with KDE 4.6.x

Can this still be reproduced with KDE 4.7.3 or later?
Comment 15 Andrew Crouthamel 2018-09-22 01:56:43 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 16 Andrew Crouthamel 2018-10-27 02:18:54 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!