Bug 267957 - Plasma Crash
Summary: Plasma Crash
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-08 11:27 UTC by Jens Mander
Modified: 2011-03-08 14:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Mander 2011-03-08 11:27:32 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Since I upgraded to KDE 4.61 Plasma crashes once in a while.
Other KDE Apps do the same.
Big Probs with Kontact and Akregator.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f650a2a1780 (LWP 1760))]

Thread 3 (Thread 0x7f64e2186700 (LWP 1763)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f64e2185a70 in ?? ()
#2  0x00007fffb57ff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f64e0bf8700 (LWP 1764)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f64e0bf7a70 in ?? ()
#2  0x00007fffb57ff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f650a2a1780 (LWP 1760)):
[KCrash Handler]
#6  0x00007f6507b92a7a in QString (this=0x2840075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#7  KIconEffect::fingerprint (this=0x2840075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f6507b964be in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f6507b9e544 in KIconLoader::loadIcon (this=0x3305090, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f6507b95070 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007f6506309e55 in QIcon::pixmap (this=<value optimized out>, size=..., mode=QIcon::Normal, state=65223488) at image/qicon.cpp:676
#12 0x00007f6509791f73 in Plasma::IconWidgetPrivate::decoration (this=0x3636d80, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#13 0x00007f650979420c in Plasma::IconWidget::paint (this=0x280aec0, painter=0x7fffb56585b0, option=0x1554de8, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1128
#14 0x00007f64efef8159 in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#15 0x00007f65068940dd in _q_paintItem (item=<value optimized out>, painter=0x7fffb56585b0, option=0x1554de8, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4318
#16 0x00007f650689661c in _q_paintIntoCache (pix=0x7fffb5658bd0, item=<value optimized out>, pixmapExposed=..., itemToPixmap=<value optimized out>, renderHints=) at graphicsview/qgraphicsscene.cpp:4356
#17 0x00007f65068ae9b2 in QGraphicsScenePrivate::drawItemHelper (this=<value optimized out>, item=0x280aed0, painter=0x7fffb565aa80, option=0x1554de8, widget=<value optimized out>, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4654
#18 0x00007f65068af2ad in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x280aed0, painter=0x7fffb565aa80, viewTransform=<value optimized out>, transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=0x2b18270, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4895
#19 0x00007f65068aff42 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x280aed0, painter=0x7fffb565aa80, viewTransform=0x7fffb565a810, exposedRegion=0x2cc9490, widget=0x2b18270, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#20 0x00007f65068af348 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x1b77b40, painter=0x7fffb565aa80, viewTransform=<value optimized out>, transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=0x2b18270, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#21 0x00007f65068aff42 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x1b77b40, painter=0x7fffb565aa80, viewTransform=0x7fffb565a810, exposedRegion=0x2cc9490, widget=0x2b18270, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#22 0x00007f65068af348 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x1d33fa0, painter=0x7fffb565aa80, viewTransform=<value optimized out>, transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=0x2b18270, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#23 0x00007f65068aff42 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x1d33fa0, painter=0x7fffb565aa80, viewTransform=0x7fffb565a810, exposedRegion=0x2cc9490, widget=0x2b18270, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#24 0x00007f65068af348 in QGraphicsScenePrivate::draw (this=<value optimized out>, item=0x1656990, painter=0x7fffb565aa80, viewTransform=<value optimized out>, transformPtr=<value optimized out>, exposedRegion=<value optimized out>, widget=0x2b18270, opacity=<value optimized out>, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#25 0x00007f65068aff42 in QGraphicsScenePrivate::drawSubtreeRecursive (this=<value optimized out>, item=0x1656990, painter=0x7fffb565aa80, viewTransform=0x7fffb565a810, exposedRegion=0x2cc9490, widget=0x2b18270, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#26 0x00007f65068b0784 in QGraphicsScenePrivate::drawItems (this=0x1554bc0, painter=0x7fffb565aa80, viewTransform=0x7fffb565a810, exposedRegion=0x2cc9490, widget=0x2b18270) at graphicsview/qgraphicsscene.cpp:4699
#27 0x00007f65068cc2e3 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3467
#28 0x00007f65062aac2e in QWidget::event (this=0x3389110, event=0x7fffb565b3b0) at kernel/qwidget.cpp:8333
#29 0x00007f65066765e6 in QFrame::event (this=0x3389110, e=0x7fffb565b3b0) at widgets/qframe.cpp:557
#30 0x00007f65068c887b in QGraphicsView::viewportEvent (this=0x3389110, event=0x7fffb565b3b0) at graphicsview/qgraphicsview.cpp:2862
#31 0x00007f6506eed507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2b18270, event=0x7fffb565b3b0) at kernel/qcoreapplication.cpp:847
#32 0x00007f6506254fac in QApplicationPrivate::notify_helper (this=0x14cdaa0, receiver=0x2b18270, e=0x7fffb565b3b0) at kernel/qapplication.cpp:4392
#33 0x00007f650625aaed in QApplication::notify (this=0x14bab80, receiver=0x2b18270, e=0x7fffb565b3b0) at kernel/qapplication.cpp:4277
#34 0x00007f6507bf42c6 in KApplication::notify (this=0x14bab80, receiver=0x2b18270, event=0x7fffb565b3b0) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f6506eedcdc in QCoreApplication::notifyInternal (this=0x14bab80, receiver=0x2b18270, event=0x7fffb565b3b0) at kernel/qcoreapplication.cpp:732
#36 0x00007f65062b167d in sendSpontaneousEvent (this=0x3215d00, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x32b77c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x3215d00, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x32b77c0) at kernel/qwidget.cpp:5420
#38 0x00007f65062b2328 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x32b77c0) at kernel/qwidget.cpp:5627
#39 0x00007f65062b2159 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x32b77c0) at kernel/qwidget.cpp:5614
#40 0x00007f65062b2159 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=5, rgn=<value optimized out>, offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x32b77c0) at kernel/qwidget.cpp:5614
#41 0x00007f65062b13da in QWidgetPrivate::drawWidget (this=0x2cc9000, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x32b77c0) at kernel/qwidget.cpp:5473
#42 0x00007f6506485408 in QWidgetBackingStore::sync (this=0x32b77c0) at painting/qbackingstore.cpp:1328
#43 0x00007f65062a4730 in QWidgetPrivate::syncBackingStore (this=0x2cc9000) at kernel/qwidget.cpp:1805
#44 0x00007f65062ab2f5 in QWidget::event (this=0x3389110, event=0x3305090) at kernel/qwidget.cpp:8480
#45 0x00007f65066765e6 in QFrame::event (this=0x3389110, e=0x3305090) at widgets/qframe.cpp:557
#46 0x00007f650670471b in QAbstractScrollArea::event (this=0x3389110, e=0x3305090) at widgets/qabstractscrollarea.cpp:996
#47 0x00007f6509e95a00 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#48 0x00007f6506254fdc in QApplicationPrivate::notify_helper (this=0x14cdaa0, receiver=0x3389110, e=0x3305090) at kernel/qapplication.cpp:4396
#49 0x00007f650625aaed in QApplication::notify (this=0x14bab80, receiver=0x3389110, e=0x3305090) at kernel/qapplication.cpp:4277
#50 0x00007f6507bf42c6 in KApplication::notify (this=0x14bab80, receiver=0x3389110, event=0x3305090) at ../../kdeui/kernel/kapplication.cpp:311
#51 0x00007f6506eedcdc in QCoreApplication::notifyInternal (this=0x14bab80, receiver=0x3389110, event=0x3305090) at kernel/qcoreapplication.cpp:732
#52 0x00007f6506ef0c22 in sendEvent (receiver=0x3389110, event_type=<value optimized out>, data=0x147d530) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#53 QCoreApplicationPrivate::sendPostedEvents (receiver=0x3389110, event_type=<value optimized out>, data=0x147d530) at kernel/qcoreapplication.cpp:1373
#54 0x00007f65068b280a in dispatchPendingUpdateRequests (this=0x1554bc0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#55 QGraphicsScenePrivate::_q_processDirtyItems (this=0x1554bc0) at graphicsview/qgraphicsscene.cpp:510
#56 0x00007f65068b2d92 in QGraphicsScene::qt_metacall (this=0x1554560, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x3c357b0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#57 0x00007f65096d04d5 in Plasma::Corona::qt_metacall (this=0x7fffb56579f0, _c=42205301, _id=0, _a=0x0) at ./corona.moc:109
#58 0x00007f6509e83b45 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#59 0x00007f6506effbde in QObject::event (this=0x1554560, e=0x7fffb56579f0) at kernel/qobject.cpp:1219
#60 0x00007f65068ac020 in QGraphicsScene::event (this=0x1554560, event=0x3e1cad0) at graphicsview/qgraphicsscene.cpp:3548
#61 0x00007f6506254fdc in QApplicationPrivate::notify_helper (this=0x14cdaa0, receiver=0x1554560, e=0x3e1cad0) at kernel/qapplication.cpp:4396
#62 0x00007f650625aaed in QApplication::notify (this=0x14bab80, receiver=0x1554560, e=0x3e1cad0) at kernel/qapplication.cpp:4277
#63 0x00007f6507bf42c6 in KApplication::notify (this=0x14bab80, receiver=0x1554560, event=0x3e1cad0) at ../../kdeui/kernel/kapplication.cpp:311
#64 0x00007f6506eedcdc in QCoreApplication::notifyInternal (this=0x14bab80, receiver=0x1554560, event=0x3e1cad0) at kernel/qcoreapplication.cpp:732
#65 0x00007f6506ef0c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x147d530) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#66 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x147d530) at kernel/qcoreapplication.cpp:1373
#67 0x00007f6506f1a653 in sendPostedEvents (s=0x14d1140) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#68 postEventSourceDispatch (s=0x14d1140) at kernel/qeventdispatcher_glib.cpp:277
#69 0x00007f64fe9e8342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#70 0x00007f64fe9ec2a8 in ?? () from /lib/libglib-2.0.so.0
#71 0x00007f64fe9ec45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#72 0x00007f6506f1a193 in QEventDispatcherGlib::processEvents (this=0x147cc20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#73 0x00007f6506307a4e in QGuiEventDispatcherGlib::processEvents (this=0x7fffb56579f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#74 0x00007f6506eeca02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#75 0x00007f6506eecdec in QEventLoop::exec (this=0x7fffb565d7e0, flags=) at kernel/qeventloop.cpp:201
#76 0x00007f6506ef0ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#77 0x00007f6509e8bcf3 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#78 0x00007f6509ae5d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffb565dbb8) at libc-start.c:226
#79 0x0000000000400669 in _start ()

Possible duplicates by query: bug 267943, bug 267934, bug 267676, bug 265089, bug 263927.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-03-08 14:44:38 UTC

*** This bug has been marked as a duplicate of bug 258706 ***