Bug 267992 - digicam crashes after showing stat up splash
Summary: digicam crashes after showing stat up splash
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: ProgressManager-Splashscreen (show other bugs)
Version: 1.8.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-08 19:25 UTC by J Reitsma
Modified: 2022-02-05 12:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J Reitsma 2011-03-08 19:25:29 UTC
Application: digikam (1.8.0)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
When I start digikam, it crashes after showing the start up splash.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd52854f7c0 (LWP 19171))]

Thread 8 (Thread 0x7fd5102b2700 (LWP 19173)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd52390614b in wait (this=<value optimized out>, mutex=0xb25340, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xb25340, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000005e9c55 in Digikam::ScanController::run (this=0xbcc980) at /usr/src/debug/digikam-1.8.0/digikam/scancontroller.cpp:571
#4  0x00007fd523905a5e in QThreadPrivate::start (arg=0xbcc980) at thread/qthread_unix.cpp:285
#5  0x00007fd51ff1ca3f in start_thread (arg=0x7fd5102b2700) at pthread_create.c:297
#6  0x00007fd521f6967d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fd50fab1700 (LWP 19174)):
#0  0x00007fd51a24506d in g_main_context_prepare (context=0xc26520, priority=0x7fd50fab0c5c) at gmain.c:2759
#1  0x00007fd51a245fa9 in g_main_context_iterate (context=0xc26520, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3071
#2  0x00007fd51a246650 in g_main_context_iteration (context=0xc26520, may_block=1) at gmain.c:3154
#3  0x00007fd523a19976 in QEventDispatcherGlib::processEvents (this=0xb47eb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd5239ee052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd5239ee265 in QEventLoop::exec (this=0x7fd50fab0d80, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fd5239031e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fd5239cf968 in QInotifyFileSystemWatcherEngine::run (this=0xb97350) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd523905a5e in QThreadPrivate::start (arg=0xb97350) at thread/qthread_unix.cpp:285
#9  0x00007fd51ff1ca3f in start_thread (arg=0x7fd50fab1700) at pthread_create.c:297
#10 0x00007fd521f6967d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fd50f2b0700 (LWP 19176)):
#0  socketNotifierSourcePrepare (timeout=0x7fd50f2afc2c) at kernel/qeventdispatcher_glib.cpp:73
#1  0x00007fd51a245087 in g_main_context_prepare (context=0xcdf910, priority=0x7fd50f2afc9c) at gmain.c:2761
#2  0x00007fd51a245fa9 in g_main_context_iterate (context=0xcdf910, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3071
#3  0x00007fd51a246650 in g_main_context_iteration (context=0xcdf910, may_block=1) at gmain.c:3154
#4  0x00007fd523a19976 in QEventDispatcherGlib::processEvents (this=0xd26520, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fd5239ee052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fd5239ee265 in QEventLoop::exec (this=0x7fd50f2afdc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fd5239031e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fd523905a5e in QThreadPrivate::start (arg=0xd1f800) at thread/qthread_unix.cpp:285
#9  0x00007fd51ff1ca3f in start_thread (arg=0x7fd50f2b0700) at pthread_create.c:297
#10 0x00007fd521f6967d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fd50e818700 (LWP 19177)):
#0  0xffffffffff600148 in ?? ()
#1  0x00007fff2958a7a1 in ?? ()
#2  0x00007fd51a4f62b3 in clock_gettime (clock_id=1, tp=0x7fd50e817b00) at ../sysdeps/unix/clock_gettime.c:100
#3  0x00007fd5239572b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007fd523a1a33d in QTimerInfoList::updateCurrentTime (this=0xca7090) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007fd523a1a6b5 in QTimerInfoList::timerWait (this=0xca7090, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007fd523a1917c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7fd50e817c2c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007fd523a19225 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007fd51a245087 in g_main_context_prepare (context=0xce86d0, priority=0x7fd50e817c9c) at gmain.c:2761
#10 0x00007fd51a245fa9 in g_main_context_iterate (context=0xce86d0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3071
#11 0x00007fd51a246650 in g_main_context_iteration (context=0xce86d0, may_block=1) at gmain.c:3154
#12 0x00007fd523a19976 in QEventDispatcherGlib::processEvents (this=0xcd9d10, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007fd5239ee052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fd5239ee265 in QEventLoop::exec (this=0x7fd50e817dc0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007fd5239031e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007fd523905a5e in QThreadPrivate::start (arg=0xc84470) at thread/qthread_unix.cpp:285
#17 0x00007fd51ff1ca3f in start_thread (arg=0x7fd50e818700) at pthread_create.c:297
#18 0x00007fd521f6967d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fd50dfe4700 (LWP 19178)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd52390614b in wait (this=<value optimized out>, mutex=0xc69c38, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xc69c38, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fd525e294c7 in Digikam::ParkingThread::run (this=0xc69c20) at /usr/src/debug/digikam-1.8.0/libs/threads/threadmanager.cpp:119
#4  0x00007fd523905a5e in QThreadPrivate::start (arg=0xc69c20) at thread/qthread_unix.cpp:285
#5  0x00007fd51ff1ca3f in start_thread (arg=0x7fd50dfe4700) at pthread_create.c:297
#6  0x00007fd521f6967d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fd50d7e3700 (LWP 19179)):
#0  0x00007fd51ff2067e in __pthread_mutex_unlock_usercnt (mutex=0xd21218, decr=<value optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007fd51a245f1d in g_main_context_iterate (context=0xd21210, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3032
#2  0x00007fd51a246650 in g_main_context_iteration (context=0xd21210, may_block=1) at gmain.c:3154
#3  0x00007fd523a19976 in QEventDispatcherGlib::processEvents (this=0xc5a0d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd5239ee052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd5239ee265 in QEventLoop::exec (this=0x7fd50d7e2dc0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fd5239031e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fd523905a5e in QThreadPrivate::start (arg=0x185dd90) at thread/qthread_unix.cpp:285
#8  0x00007fd51ff1ca3f in start_thread (arg=0x7fd50d7e3700) at pthread_create.c:297
#9  0x00007fd521f6967d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd50cfe2700 (LWP 19180)):
#0  0x00007fd523a191da in idleTimerSourcePrepare (source=<value optimized out>, timeout=0x7fd50cfe1c2c) at kernel/qeventdispatcher_glib.cpp:215
#1  0x00007fd51a245087 in g_main_context_prepare (context=0x185eca0, priority=0x7fd50cfe1c9c) at gmain.c:2761
#2  0x00007fd51a245fa9 in g_main_context_iterate (context=0x185eca0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3071
#3  0x00007fd51a246650 in g_main_context_iteration (context=0x185eca0, may_block=1) at gmain.c:3154
#4  0x00007fd523a19976 in QEventDispatcherGlib::processEvents (this=0xc3ae70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fd5239ee052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fd5239ee265 in QEventLoop::exec (this=0x7fd50cfe1dc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fd5239031e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fd523905a5e in QThreadPrivate::start (arg=0xd32690) at thread/qthread_unix.cpp:285
#9  0x00007fd51ff1ca3f in start_thread (arg=0x7fd50cfe2700) at pthread_create.c:297
#10 0x00007fd521f6967d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd52854f7c0 (LWP 19171)):
[KCrash Handler]
#4  libvlc_media_player_new (instance=0x0) at control/media_player.c:381
#5  0x00007fd505f3068d in Phonon::VLC::VLCMediaObject::VLCMediaObject (this=0x18833a0, parent=<value optimized out>) at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/vlcmediaobject.cpp:54
#6  0x00007fd505f1d9e8 in Phonon::VLC::Backend::createObject (this=0xd82770, c=<value optimized out>, parent=0xd36dd0, args=...) at /usr/src/debug/phonon-backend-vlc-0.3.2/vlc/backend.cpp:134
#7  0x00007fd527f067ff in Phonon::Factory::createMediaObject (parent=0xd36dd0) at /usr/src/debug/phonon-4.4.4/phonon/factory.cpp:342
#8  0x00007fd527ef5476 in Phonon::MediaObjectPrivate::createBackendObject (this=0x1891120) at /usr/src/debug/phonon-4.4.4/phonon/mediaobject.cpp:47
#9  0x00007fd527ef69f8 in Phonon::MediaNodePrivate::backendObject (this=0x1891120) at /usr/src/debug/phonon-4.4.4/phonon/medianode.cpp:63
#10 0x00007fd527ef84ad in Phonon::Path::reconnect (this=0x7fff294946c0, source=0xd36de0, sink=0xc83490) at /usr/src/debug/phonon-4.4.4/phonon/path.cpp:158
#11 0x00007fd527ef87ad in Phonon::createPath (source=0xd36de0, sink=0xc83490) at /usr/src/debug/phonon-4.4.4/phonon/path.cpp:436
#12 0x00007fd527f0ab74 in Phonon::VideoPlayerPrivate::ensureCreated (this=0xd1b450) at /usr/src/debug/phonon-4.4.4/phonon/videoplayer.cpp:72
#13 0x00007fd527f0ad4d in Phonon::VideoPlayer::mediaObject (this=0xd1b3c0) at /usr/src/debug/phonon-4.4.4/phonon/videoplayer.cpp:102
#14 0x00000000005d981e in Digikam::MediaPlayerView::MediaPlayerView (this=0xd197a0, parent=0xc7aa00) at /usr/src/debug/digikam-1.8.0/digikam/mediaplayerview.cpp:166
#15 0x000000000057cc68 in Digikam::AlbumWidgetStack::AlbumWidgetStack (this=0xc7aa00, parent=<value optimized out>) at /usr/src/debug/digikam-1.8.0/digikam/albumwidgetstack.cpp:105
#16 0x00000000005b09dd in Digikam::DigikamView::DigikamView (this=0xc1fa00, parent=0x7fd50800d430, modelCollection=0xcfe510) at /usr/src/debug/digikam-1.8.0/digikam/digikamview.cpp:183
#17 0x0000000000588cad in Digikam::DigikamApp::setupView (this=0x7fd50800d430) at /usr/src/debug/digikam-1.8.0/digikam/digikamapp.cpp:512
#18 0x00000000005a14f2 in Digikam::DigikamApp::DigikamApp (this=0x7fd50800d430, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/digikam-1.8.0/digikam/digikamapp.cpp:234
#19 0x000000000062be83 in main (argc=11240640, argv=0x7fff29495698) at /usr/src/debug/digikam-1.8.0/digikam/main.cpp:177

Possible duplicates by query: bug 261241, bug 259269.

Reported using DrKonqi
Comment 1 J Reitsma 2011-03-08 19:57:39 UTC
Indeed this also seems related to the phonon-backend being set to vlc. Now set to gstreamer, and digikam functions normally.
Comment 2 Dario Andres 2011-03-08 21:08:12 UTC
[Comment from a bug triager]
This issue is being tracked at bug 259269. Merging.
- Can you perform the action on bug 259269 comment 13, then run Digikam, and paste the shell output on bug 259269 ?
Thanks

*** This bug has been marked as a duplicate of bug 259269 ***
Comment 3 caulier.gilles 2016-12-24 10:03:06 UTC
digiKam 5.4.0 bundles will use QtAV framework instead Qt5Multimedia to thumb
and play video/audio. The Slideshow tool will also support video as well.

QtAV use ffmpeg codecs. It's multi-platform and will always available in
OSX, Windows and Linux bundles that digiKam team provide.

For Linux packagers, you will need to turn on video support at compilation time
and solve QtAV dependencies...

See screenshots here :

https://www.flickr.com/photos/digikam/30886133553
https://www.flickr.com/photos/digikam/31679362466
https://www.flickr.com/photos/digikam/31572654722
https://www.flickr.com/photos/digikam/31726086736

Bundles have been recompiled are posted to GDrive for testing :

https://drive.google.com/drive/folders/0BzeiVr-byqt5Y0tIRWVWelRJenM