Bug 261241 - knotify crashed when peferring phonon-vlc backend in yast setup.
Summary: knotify crashed when peferring phonon-vlc backend in yast setup.
Status: RESOLVED DUPLICATE of bug 259269
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knotify (show other bugs)
Version: 4.0
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-25 18:05 UTC by margueritesu
Modified: 2010-12-25 21:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description margueritesu 2010-12-25 18:05:26 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I just swithed phonon-vlc backend up in sound&video configuration, hoping to make my soundcard work under KDE 4.6 RC1. then knotify kept crashing many times. even I closed the setup page.

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2816e15760 (LWP 1786))]

Thread 2 (Thread 0x7f2804b25710 (LWP 1787)):
#0  0x00007f28121a50a8 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f281164b343 in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f281164bedb in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f281164c510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f28147c8ae6 in QEventDispatcherGlib::processEvents (this=0x7604b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f281479d262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f281479d475 in QEventLoop::exec (this=0x7f2804b24de0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f28146b01a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f281477e918 in QInotifyFileSystemWatcherEngine::run (this=0x75a470) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f28146b2a1e in QThreadPrivate::start (arg=0x75a470) at thread/qthread_unix.cpp:285
#10 0x00007f28121a2a4f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f28140a082d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2816e15760 (LWP 1786)):
[KCrash Handler]
#6  0x00007f27fbe4062e in libvlc_media_player_new () from /usr/lib64/libvlc.so.5
#7  0x00007f27fc2849be in Phonon::VLC::VLCMediaObject::VLCMediaObject(QObject*) () from /usr/lib/kde4/plugins/phonon_backend/phonon_vlc.so
#8  0x00007f27fc2737e4 in Phonon::VLC::Backend::createObject(Phonon::BackendInterface::Class, QObject*, QList<QVariant> const&) () from /usr/lib/kde4/plugins/phonon_backend/phonon_vlc.so
#9  0x00007f28163c87df in Phonon::Factory::createMediaObject (parent=0x6e8980) at /usr/src/debug/phonon-4.4.3/phonon/factory.cpp:342
#10 0x00007f28163b7456 in Phonon::MediaObjectPrivate::createBackendObject (this=0x765f30) at /usr/src/debug/phonon-4.4.3/phonon/mediaobject.cpp:47
#11 0x00007f28163c7ee9 in Phonon::FactoryPrivate::phononBackendChanged (this=0x7466e0) at /usr/src/debug/phonon-4.4.3/phonon/factory.cpp:306
#12 0x00007f28163c8a02 in Phonon::FactoryPrivate::qt_metacall (this=0x7466e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4a6e5ca0)
    at /usr/src/debug/phonon-4.4.3/build/phonon/factory.moc:77
#13 0x00007f2814af43b8 in QDBusConnectionPrivate::deliverCall (this=0x6459f0, object=0x7466e0, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#14 0x00007f2814afff5f in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#15 0x00007f28147b1c6a in QObject::event (this=0x7466e0, e=<value optimized out>) at kernel/qobject.cpp:1211
#16 0x00007f28153c7cd4 in QApplicationPrivate::notify_helper (this=0x6526d0, receiver=0x7466e0, e=0xef3670) at kernel/qapplication.cpp:4445
#17 0x00007f28153d01ca in QApplication::notify (this=<value optimized out>, receiver=0x7466e0, e=0xef3670) at kernel/qapplication.cpp:4324
#18 0x00007f2816780c46 in KApplication::notify (this=0x7fff4a6e67b0, receiver=0x7466e0, event=0xef3670) at /usr/src/debug/kdelibs-4.5.90/kdeui/kernel/kapplication.cpp:311
#19 0x00007f281479de2c in QCoreApplication::notifyInternal (this=0x7fff4a6e67b0, receiver=0x7466e0, event=0xef3670) at kernel/qcoreapplication.cpp:732
#20 0x00007f28147a1625 in sendEvent (receiver=0x0, event_type=0, data=0x627420) at kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x627420) at kernel/qcoreapplication.cpp:1373
#22 0x00007f28147c88f3 in sendPostedEvents (s=0x6553f0) at kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x6553f0) at kernel/qeventdispatcher_glib.cpp:277
#24 0x00007f281164ba93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f281164c270 in ?? () from /usr/lib64/libglib-2.0.so.0
#26 0x00007f281164c510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f28147c8a8f in QEventDispatcherGlib::processEvents (this=0x62d540, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#28 0x00007f281546ceae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f281479d262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f281479d475 in QEventLoop::exec (this=0x7fff4a6e66d0, flags=...) at kernel/qeventloop.cpp:201
#31 0x00007f28147a18db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#32 0x000000000040a12f in _start ()

Possible duplicates by query: bug 259269.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-25 21:36:08 UTC
[Comment from a bug triager]
This issue is being tracked at bug 259269. Merging. Thanks

*** This bug has been marked as a duplicate of bug 259269 ***