Bug 267706 - rekonq asks to save file safari.jsp when visiting certain sites
Summary: rekonq asks to save file safari.jsp when visiting certain sites
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: latest git snapshot
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: 0.7
Assignee: Andrea Diamantini
URL:
Keywords:
: 267803 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-05 13:54 UTC by schmirrwurst
Modified: 2011-03-09 06:26 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description schmirrwurst 2011-03-05 13:54:21 UTC
+++ This bug was initially created as a clone of Bug #263870 +++

Version:           0.6.1 (using KDE 4.5.95) 
OS:                Linux

Rekonq asks me to save a file called safari.jsp when I visit certain sites. The website http://kde-look.org/ is a good example but I’ve also seen it appear when visiting other websites. When I cancel saving the file the website seems to work fine, but it sure is annoying if I’m asked every time.

However, I noticed this doesn’t happen when I visit http://kde-look.org/ with my notebook which runs the development version of Kubuntu 11.04, it only happens when I visit with my desktop which is running Kubuntu 10.10 and has been upgraded to KDE SC 4.6 RC2 through Kubuntu’s repositories. On my desktop I also made some changes to the cookie settings, namely disabling ‘Treat all cookies as session cookies’ and setting it to accept all cookies to avoid problems with web browsing caused by the default cookie settings. As far as I know I did not make any other changes to rekonq’s configuration.

Reproducible: Always

Steps to Reproduce:
[1] Visit http://kde-look.org/ with rekonq.
[2] Observe the ‘Save As’ dialog appearing asking to save the file ‘safari.jsp’
Comment 1 schmirrwurst 2011-03-05 13:54:55 UTC
This bug is actual again
Comment 2 schmirrwurst 2011-03-05 19:44:04 UTC
also in 0.6.85 and kde 4.6
Comment 3 Panagiotis Papadopoulos 2011-03-06 17:05:24 UTC
*** Bug 267803 has been marked as a duplicate of this bug. ***
Comment 4 Panagiotis Papadopoulos 2011-03-06 17:05:59 UTC
I can confirm this here and it is quite an annoying bug :-)
Comment 5 Rohan Garg 2011-03-06 23:14:46 UTC
I've narrowed it down to commit fd1f2205b673a41bedb3959c99b8958f99a7b269 , but the commit is pretty huge, so this might take some time, targetting 0.7 for now