Bug 266852 - Bookmark editor crashed when moving entries via drag'n'drop
Summary: Bookmark editor crashed when moving entries via drag'n'drop
Status: RESOLVED DUPLICATE of bug 245349
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-21 22:14 UTC by Thomas Fischer
Modified: 2011-02-22 16:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Fischer 2011-02-21 22:14:22 UTC
Application: keditbookmarks (4.6.00 (4.6.0))
KDE Platform Version: 4.6.00 (4.6.0) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.36-gentoo-r5-tf i686
Distribution (Platform): Gentoo Packages

-- Information about the crash:
I tried to move a group of entries using drag'n'drop from the main tree view to the folder view on the left. I was in the process of moving bookmarks around to clean up Konqueror's bookmark menu; several drag'n'drop moves before worked without problem. I am not sure, but maybe this was my first drag'n'drop move where several bookmarks were moved at once.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Aborted
[KCrash Handler]
#7  0xb7844424 in __kernel_vsyscall ()
#8  0xb76be451 in raise () from /lib/libc.so.6
#9  0xb76bfb92 in abort () from /lib/libc.so.6
#10 0xb5fb3f78 in qt_message_output (msgType=QtFatalMsg, buf=0x9f4d868 "ASSERT: \"bk.address() == m_to\" in file /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/kbookmarkmodel/commands.cpp, line 141") at global/qglobal.cpp:2282
#11 0xb5fb410f in qt_message (msgType=<value optimized out>, msg=0xb6132c08 "ASSERT: \"%s\" in file %s, line %d", ap=0xbfff17d4 "\260\017i\267\374\ri\267\215") at global/qglobal.cpp:2328
#12 0xb5fb420c in qFatal (msg=0xb6132c08 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2511
#13 0xb5fb4459 in qt_assert (assertion=0xb7690fb0 "bk.address() == m_to", file=0xb7690dfc "/var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/kbookmarkmodel/commands.cpp", line=141) at global/qglobal.cpp:2027
#14 0xb768942f in CreateCommand::redo (this=0x9b9f720) at /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/kbookmarkmodel/commands.cpp:141
#15 0xb768a0d8 in MoveCommand::redo (this=0x9c7cf00) at /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/kbookmarkmodel/commands.cpp:369
#16 0xb6d37dec in QUndoCommand::redo (this=0x9bd23e0) at util/qundostack.cpp:208
#17 0xb6d391c2 in QUndoStack::push (this=0x9a9a37c, cmd=0x9bd23e0) at util/qundostack.cpp:541
#18 0xb7686fc5 in CommandHistory::addCommand (this=0x9a7f548, cmd=0x9bd23e0) at /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/kbookmarkmodel/commandhistory.cpp:103
#19 0xb768c7cf in KBookmarkModel::dropMimeData (this=0x9aa4078, data=0x9b63580, action=Qt::MoveAction, row=-1, column=-1, parent=...) at /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/kbookmarkmodel/model.cpp:382
#20 0xb7808200 in BookmarkFolderViewFilterModel::dropMimeData (this=0x9b6d6b0, data=0x9b63580, action=Qt::MoveAction, row=-1, column=-1, parent=...) at /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/bookmarklistview.cpp:178
#21 0xb6ba3d01 in QAbstractItemView::dropEvent (this=0x9a552f0, event=0xbfff2484) at itemviews/qabstractitemview.cpp:1981
#22 0xb6631ed5 in QWidget::event (this=0x9a552f0, event=0xbfff2484) at kernel/qwidget.cpp:8390
#23 0xb6a54c1a in QFrame::event (this=0x9a552f0, e=0xbfff2484) at widgets/qframe.cpp:557
#24 0xb6af2387 in QAbstractScrollArea::viewportEvent (this=0x2494, e=0x6) at widgets/qabstractscrollarea.cpp:1043
#25 0xb6bb1b25 in QAbstractItemView::viewportEvent (this=0x9a552f0, event=0xbfff2484) at itemviews/qabstractitemview.cpp:1619
#26 0xb6bf6cb4 in QTreeView::viewportEvent (this=0x9a552f0, event=0xbfff2484) at itemviews/qtreeview.cpp:1256
#27 0xb6af4cc6 in viewportEvent (this=0x9a55e10, o=0x9a55bb8, e=0xbfff2484) at widgets/qabstractscrollarea_p.h:100
#28 QAbstractScrollAreaFilter::eventFilter (this=0x9a55e10, o=0x9a55bb8, e=0xbfff2484) at widgets/qabstractscrollarea_p.h:116
#29 0xb60c1d7e in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x99b0fb8, receiver=0x9a55bb8, event=0xbfff2484) at kernel/qcoreapplication.cpp:847
#30 0xb65d109f in QApplicationPrivate::notify_helper (this=0x99b0fb8, receiver=0x9a55bb8, e=0xbfff2484) at kernel/qapplication.cpp:4441
#31 0xb65da504 in QApplication::notify (this=0xbfff47ac, receiver=0x9a55bb8, e=0xbfff2484) at kernel/qapplication.cpp:4249
#32 0xb7198521 in KApplication::notify (this=0xbfff47ac, receiver=0x9a55bb8, event=0xbfff2484) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#33 0xb60c20d5 in QCoreApplication::notifyInternal (this=0xbfff47ac, receiver=0x9a55bb8, event=0xbfff2484) at kernel/qcoreapplication.cpp:732
#34 0xb6677e12 in sendEvent (this=0x99b4890, xe=0xbfff2588, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QX11Data::xdndHandleDrop (this=0x99b4890, xe=0xbfff2588, passive=false) at kernel/qdnd_x11.cpp:1183
#36 0xb6679eeb in QDragManager::drop (this=0x9c21290) at kernel/qdnd_x11.cpp:1725
#37 0xb667c8ac in QDragManager::eventFilter (this=0x9c21290, o=0x9b8ba48, e=0xbfff2bd4) at kernel/qdnd_x11.cpp:1312
#38 0xb60c1e8a in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x99b0fb8, receiver=0x9b8ba48, event=0xbfff2bd4) at kernel/qcoreapplication.cpp:828
#39 0xb65d1034 in QApplicationPrivate::notify_helper (this=0x99b0fb8, receiver=0x9b8ba48, e=0xbfff2bd4) at kernel/qapplication.cpp:4420
#40 0xb65d9cca in QApplication::notify (this=0xbfff47ac, receiver=0x9b8ba48, e=0xbfff2bd4) at kernel/qapplication.cpp:4006
#41 0xb7198521 in KApplication::notify (this=0xbfff47ac, receiver=0x9b8ba48, event=0xbfff2bd4) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#42 0xb60c20d5 in QCoreApplication::notifyInternal (this=0xbfff47ac, receiver=0x9b8ba48, event=0xbfff2bd4) at kernel/qcoreapplication.cpp:732
#43 0xb65d4d32 in sendSpontaneousEvent (receiver=0x9b8ba48, event=0xbfff2bd4, alienWidget=0x0, nativeWidget=0x9b8ba48, buttonDown=0xb6f8cc20, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#44 QApplicationPrivate::sendMouseEvent (receiver=0x9b8ba48, event=0xbfff2bd4, alienWidget=0x0, nativeWidget=0x9b8ba48, buttonDown=0xb6f8cc20, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#45 0xb6669e02 in QETWidget::translateMouseEvent (this=0x9b8ba48, event=0xbfff3040) at kernel/qapplication_x11.cpp:4438
#46 0xb6668e32 in QApplication::x11ProcessEvent (this=0xbfff47ac, event=0xbfff3040) at kernel/qapplication_x11.cpp:3442
#47 0xb6695c23 in x11EventSourceDispatch (s=0x99b3fe8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0xb57192d8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#49 0xb571ccee in ?? () from /usr/lib/libglib-2.0.so.0
#50 0xb571ceaa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#51 0xb60f2116 in QEventDispatcherGlib::processEvents (this=0x999b2f8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#52 0xb66954ec in QGuiEventDispatcherGlib::processEvents (this=0x999b2f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0xb60c0baf in QEventLoop::processEvents (this=0x9ba44b8, flags=) at kernel/qeventloop.cpp:149
#54 0xb60c0fd5 in QEventLoop::exec (this=0x9ba44b8, flags=...) at kernel/qeventloop.cpp:201
#55 0xb667c522 in QDragManager::drag (this=0x9c21290, o=0x9b83d00) at kernel/qdnd_x11.cpp:1981
#56 0xb65e94a9 in QDrag::exec (this=0x9b83d00, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#57 0xb6baf313 in QAbstractItemView::startDrag (this=0x9b600f8, supportedActions=...) at itemviews/qabstractitemview.cpp:3439
#58 0xb6bacdb5 in QAbstractItemView::mouseMoveEvent (this=0x9b600f8, event=0xbfff3f74) at itemviews/qabstractitemview.cpp:1700
#59 0xb6bf63e6 in QTreeView::mouseMoveEvent (this=0x9b600f8, event=0xbfff3f74) at itemviews/qtreeview.cpp:1902
#60 0xb6631b88 in QWidget::event (this=0x9b600f8, event=0xbfff3f74) at kernel/qwidget.cpp:8185
#61 0xb6a54c1a in QFrame::event (this=0x9b600f8, e=0xbfff3f74) at widgets/qframe.cpp:557
#62 0xb6af2387 in QAbstractScrollArea::viewportEvent (this=0x2494, e=0x6) at widgets/qabstractscrollarea.cpp:1043
#63 0xb6bb1b25 in QAbstractItemView::viewportEvent (this=0x9b600f8, event=0xbfff3f74) at itemviews/qabstractitemview.cpp:1619
#64 0xb6bf6cb4 in QTreeView::viewportEvent (this=0x9b600f8, event=0xbfff3f74) at itemviews/qtreeview.cpp:1256
#65 0xb6af4cc6 in viewportEvent (this=0x9b60ce8, o=0x9b5ff60, e=0xbfff3f74) at widgets/qabstractscrollarea_p.h:100
#66 QAbstractScrollAreaFilter::eventFilter (this=0x9b60ce8, o=0x9b5ff60, e=0xbfff3f74) at widgets/qabstractscrollarea_p.h:116
#67 0xb60c1d7e in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x99b0fb8, receiver=0x9b5ff60, event=0xbfff3f74) at kernel/qcoreapplication.cpp:847
#68 0xb65d109f in QApplicationPrivate::notify_helper (this=0x99b0fb8, receiver=0x9b5ff60, e=0xbfff3f74) at kernel/qapplication.cpp:4441
#69 0xb65d9cca in QApplication::notify (this=0xbfff47ac, receiver=0x9b5ff60, e=0xbfff3f74) at kernel/qapplication.cpp:4006
#70 0xb7198521 in KApplication::notify (this=0xbfff47ac, receiver=0x9b5ff60, event=0xbfff3f74) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#71 0xb60c20d5 in QCoreApplication::notifyInternal (this=0xbfff47ac, receiver=0x9b5ff60, event=0xbfff3f74) at kernel/qcoreapplication.cpp:732
#72 0xb65d4d32 in sendSpontaneousEvent (receiver=0x9b5ff60, event=0xbfff3f74, alienWidget=0x9b5ff60, nativeWidget=0x9bf1b38, buttonDown=0xb6f8cc20, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#73 QApplicationPrivate::sendMouseEvent (receiver=0x9b5ff60, event=0xbfff3f74, alienWidget=0x9b5ff60, nativeWidget=0x9bf1b38, buttonDown=0xb6f8cc20, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#74 0xb6669e02 in QETWidget::translateMouseEvent (this=0x9bf1b38, event=0xbfff43e0) at kernel/qapplication_x11.cpp:4438
#75 0xb6668e32 in QApplication::x11ProcessEvent (this=0xbfff47ac, event=0xbfff43e0) at kernel/qapplication_x11.cpp:3442
#76 0xb6695c23 in x11EventSourceDispatch (s=0x99b3fe8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#77 0xb57192d8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#78 0xb571ccee in ?? () from /usr/lib/libglib-2.0.so.0
#79 0xb571ceaa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#80 0xb60f2116 in QEventDispatcherGlib::processEvents (this=0x999b2f8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#81 0xb66954ec in QGuiEventDispatcherGlib::processEvents (this=0x999b2f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0xb60c0baf in QEventLoop::processEvents (this=0xbfff46d4, flags=) at kernel/qeventloop.cpp:149
#83 0xb60c0fd5 in QEventLoop::exec (this=0xbfff46d4, flags=...) at kernel/qeventloop.cpp:201
#84 0xb60c39e2 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#85 0xb65cf834 in QApplication::exec () at kernel/qapplication.cpp:3719
#86 0xb77ee010 in kdemain (argc=6, argv=0xbfff4a84) at /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0/keditbookmarks/main.cpp:212
#87 0x080486bb in main (argc=6, argv=0xbfff4a84) at /var/tmp/portage/kde-base/keditbookmarks-4.6.0/work/keditbookmarks-4.6.0_build/keditbookmarks/keditbookmarks_dummy.cpp:3

Reported using DrKonqi
Comment 1 Tommi Tervo 2011-02-22 16:37:32 UTC

*** This bug has been marked as a duplicate of bug 245349 ***