Bug 245349 - KEditBookmarks crash when moving a group of bookmarks
Summary: KEditBookmarks crash when moving a group of bookmarks
Status: RESOLVED DUPLICATE of bug 287038
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 266852 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-21 20:25 UTC by Mickaël
Modified: 2013-07-07 18:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mickaël 2010-07-21 20:25:56 UTC
Application: keditbookmarks (4.4.5 (KDE 4.4.5))
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
I recently imported my bookmarks from Firefox, and they are placed into a folder named "Personnal Bar", so I have only this folder (and another folder named "unclassed bookmarks") in my bookmarks bar in Konqueror.
I also tried to move them outside the folder to make them visible... crash.
For this I selected the first bookmark, pressed Maj and clicked the last one of the "Personnal Bar". Then I dragged them and dropped outside the folder and KEditBookmarks crashed.

The crash can be reproduced every time.

 -- Backtrace:
Application: Éditeur de signet (keditbookmarks), signal: Aborted
[KCrash Handler]
#5  0x00007f65c6a9a565 in raise () from /lib/libc.so.6
#6  0x00007f65c6a9b9e6 in abort () from /lib/libc.so.6
#7  0x00007f65c503135f in qt_message_output(QtMsgType, char const*) () from /usr/lib/libQtCore.so.4
#8  0x00007f65c50314ed in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f65c5031685 in qFatal(char const*, ...) () from /usr/lib/libQtCore.so.4
#10 0x00007f65c6dec00a in CreateCommand::redo (this=0x1cfe020) at /var/abs/local/kdebase/src/kdebase-4.4.5/apps/keditbookmarks/commands.cpp:190
#11 0x00007f65c6decbf2 in MoveCommand::redo (this=0x1981aa0) at /var/abs/local/kdebase/src/kdebase-4.4.5/apps/keditbookmarks/commands.cpp:413
#12 0x00007f65c4b52f59 in QUndoCommand::redo() () from /usr/lib/libQtGui.so.4
#13 0x00007f65c4b54543 in QUndoStack::push(QUndoCommand*) () from /usr/lib/libQtGui.so.4
#14 0x00007f65c6de6ac2 in CmdHistory::addCommand (this=0x16a90a0, cmd=0x1b8bcb0) at /var/abs/local/kdebase/src/kdebase-4.4.5/apps/keditbookmarks/commandhistory.cpp:88
#15 0x00007f65c6dfb63f in KBookmarkModel::dropMimeData (this=<value optimized out>, data=<value optimized out>, action=<value optimized out>, row=<value optimized out>, column=1909689760, 
    parent=<value optimized out>) at /var/abs/local/kdebase/src/kdebase-4.4.5/apps/keditbookmarks/bookmarkmodel.cpp:360
#16 0x00007f65c6dfc46a in BookmarkFolderViewFilterModel::dropMimeData (this=<value optimized out>, data=0x1754400, action=Qt::MoveAction, row=-1, column=-1, parent=...)
    at /var/abs/local/kdebase/src/kdebase-4.4.5/apps/keditbookmarks/bookmarklistview.cpp:232
#17 0x00007f65c4a139ee in QAbstractItemView::dropEvent(QDropEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007f65c45685e1 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#19 0x00007f65c4900e66 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x00007f65c4a0d403 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00007f65c4a51852 in QTreeView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#22 0x00007f65c511fec7 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x00007f65c4518821 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0x00007f65c451cbab in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#25 0x00007f65c5d2e096 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#26 0x00007f65c511fd3c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0x00007f65c459d55f in ?? () from /usr/lib/libQtGui.so.4
#28 0x00007f65c459ff22 in ?? () from /usr/lib/libQtGui.so.4
#29 0x00007f65c45a1370 in ?? () from /usr/lib/libQtGui.so.4
#30 0x00007f65c511fe0b in QCoreApplicationPrivate::sendThroughApplicationEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#31 0x00007f65c45187c6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#32 0x00007f65c451d1ba in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#33 0x00007f65c5d2e096 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#34 0x00007f65c511fd3c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#35 0x00007f65c45197a5 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#36 0x00007f65c45943c8 in ?? () from /usr/lib/libQtGui.so.4
#37 0x00007f65c4592dc9 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#38 0x00007f65c45b86b2 in ?? () from /usr/lib/libQtGui.so.4
#39 0x00007f65c0ca8b33 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0x00007f65c0ca9310 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#41 0x00007f65c0ca95ad in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0x00007f65c514882f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#43 0x00007f65c45b837e in ?? () from /usr/lib/libQtGui.so.4
#44 0x00007f65c511f122 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0x00007f65c511f35c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#46 0x00007f65c45a10a8 in ?? () from /usr/lib/libQtGui.so.4
#47 0x00007f65c45291a8 in QDrag::exec(QFlags<Qt::DropAction>, Qt::DropAction) () from /usr/lib/libQtGui.so.4
#48 0x00007f65c4a1875e in QAbstractItemView::startDrag(QFlags<Qt::DropAction>) () from /usr/lib/libQtGui.so.4
#49 0x00007f65c4a14a81 in QAbstractItemView::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#50 0x00007f65c45682c6 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#51 0x00007f65c4900e66 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#52 0x00007f65c4a0d403 in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#53 0x00007f65c4a51852 in QTreeView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#54 0x00007f65c511fec7 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#55 0x00007f65c4518821 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#56 0x00007f65c451d1ba in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#57 0x00007f65c5d2e096 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#58 0x00007f65c511fd3c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#59 0x00007f65c45197a5 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#60 0x00007f65c45943c8 in ?? () from /usr/lib/libQtGui.so.4
#61 0x00007f65c4592dc9 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#62 0x00007f65c45b86b2 in ?? () from /usr/lib/libQtGui.so.4
#63 0x00007f65c0ca8b33 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#64 0x00007f65c0ca9310 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#65 0x00007f65c0ca95ad in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#66 0x00007f65c514882f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#67 0x00007f65c45b837e in ?? () from /usr/lib/libQtGui.so.4
#68 0x00007f65c511f122 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#69 0x00007f65c511f35c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#70 0x00007f65c512376b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#71 0x00007f65c6de1529 in kdemain (argc=1, argv=0x7fff71d3cf10) at /var/abs/local/kdebase/src/kdebase-4.4.5/apps/keditbookmarks/main.cpp:204
#72 0x00007f65c6a86c4d in __libc_start_main () from /lib/libc.so.6
#73 0x00000000004005d9 in _start ()

Reported using DrKonqi
Comment 1 Tommi Tervo 2011-02-22 16:37:32 UTC
*** Bug 266852 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2013-07-07 18:12:51 UTC
This should be fixed with KDE 4.10.4, otherwise please reopen.

*** This bug has been marked as a duplicate of bug 287038 ***