Bug 266726 - another random plasma crash
Summary: another random plasma crash
Status: RESOLVED DUPLICATE of bug 268301
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-taskbar (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-20 14:11 UTC by Marc Schiffbauer
Modified: 2011-04-10 22:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer 2011-02-20 14:11:57 UTC
Version:           unspecified
OS:                Linux

Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

I was doing nothing special. I just entered password to unlick screensaver, then wanted to switch the desktop

-- Backtrace:
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7feb1d1e27c0 (LWP 3611))]

Thread 2 (Thread 0x7feb0090a700 (LWP 3612)):
#0  0x00007feb19adcf6d in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0x00007feb10e86741 in g_main_context_prepare (context=0x151dfa0, priority=0x7feb00909bac) at gmain.c:2467
#2  0x00007feb10e87639 in g_main_context_iterate (context=0x151dfa0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2760
#3  0x00007feb10e87cdd in g_main_context_iteration (context=0x151dfa0, may_block=1) at gmain.c:2843
#4  0x00007feb19e886a6 in QEventDispatcherGlib::processEvents (this=0x145f790, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007feb19e5b342 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007feb19e5b724 in QEventLoop::exec (this=0x7feb00909cc0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007feb19d67f2d in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007feb19e3b538 in QInotifyFileSystemWatcherEngine::run (this=0x151abb0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007feb19d6aebe in QThreadPrivate::start (arg=0x151abb0) at thread/qthread_unix.cpp:285
#10 0x00007feb14f4bae3 in ?? () from //usr/lib64/opengl/nvidia/lib/libGL.so.1
#11 0x00007feb19ad8e1c in start_thread () from /lib/libpthread.so.0
#12 0x00007feb1cae36ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7feb1d1e27c0 (LWP 3611)):
[KCrash Handler]
#6  0x00007feb04250de7 in TaskItemLayout::layoutItems (this=0x12f0170) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999/plasma/desktop/applets/tasks/taskitemlayout.cpp:347
#7  0x00007feb04251328 in TaskItemLayout::remove (this=0x12f0170, item=0x24e9e70) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999/plasma/desktop/applets/tasks/taskitemlayout.cpp:163
#8  0x00007feb0425144e in TaskItemLayout::removeTaskItem (this=0x12f0170, item=0x24e9e70) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999/plasma/desktop/applets/tasks/taskitemlayout.cpp:113
#9  0x00007feb0425a87b in TaskGroupItem::itemRemoved (this=0x14323d0, groupableItem=0x23a05d0) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999/plasma/desktop/applets/tasks/taskgroupitem.cpp:555
#10 0x00007feb0425e0a1 in TaskGroupItem::reload (this=0x14323d0) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999/plasma/desktop/applets/tasks/taskgroupitem.cpp:344
#11 0x00007feb0425e377 in TaskGroupItem::setGroup (this=0x14323d0, group=0x2496260) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999/plasma/desktop/applets/tasks/taskgroupitem.cpp:379
#12 0x00007feb0424ddac in Tasks::qt_metacall (this=0x10d82a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc907dac0) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999_build/plasma/desktop/applets/tasks/tasks.moc:99
#13 0x00007feb19e7424f in QMetaObject::activate (sender=0x141c620, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3272
#14 0x00007feb0448c73b in TaskManager::GroupManagerPrivate::actuallyReloadTasks (this=0x141cc20) at /var/tmp/portage/kde-base/libtaskmanager-4.6.9999/work/libtaskmanager-4.6.9999/libs/taskmanager/groupmanager.cpp:191
#15 0x00007feb0448dba9 in TaskManager::GroupManager::qt_metacall (this=0x141c620, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x7fffc907dce0) at /var/tmp/portage/kde-base/libtaskmanager-4.6.9999/work/libtaskmanager-4.6.9999_build/libs/taskmanager/groupmanager.moc:117
#16 0x00007feb19e7424f in QMetaObject::activate (sender=0x141cc78, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3272
#17 0x00007feb19e6e009 in QObject::event (this=0x141cc78, e=0x0) at kernel/qobject.cpp:1175
#18 0x00007feb18fe64ac in QApplicationPrivate::notify_helper (this=0xc75420, receiver=0x141cc78, e=0x7fffc907e420) at kernel/qapplication.cpp:4445
#19 0x00007feb18feb8ed in QApplication::notify (this=0xc3a900, receiver=0x141cc78, e=0x7fffc907e420) at kernel/qapplication.cpp:4324
#20 0x00007feb1ab2b3b6 in KApplication::notify (this=0xc3a900, receiver=0x141cc78, event=0x7fffc907e420) at /var/tmp/portage/kde-base/kdelibs-4.6.9999/work/kdelibs-4.6.9999/kdeui/kernel/kapplication.cpp:311
#21 0x00007feb19e5c5eb in QCoreApplication::notifyInternal (this=0xc3a900, receiver=0x141cc78, event=0x7fffc907e420) at kernel/qcoreapplication.cpp:732
#22 0x00007feb19e8b72a in sendEvent (this=0xc78cb0) at kernel/qcoreapplication.h:215
#23 QTimerInfoList::activateTimers (this=0xc78cb0) at kernel/qeventdispatcher_unix.cpp:603
#24 0x00007feb19e88964 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#25 0x00007feb10e87262 in g_main_dispatch (context=0xc77d20) at gmain.c:2149
#26 g_main_context_dispatch (context=0xc77d20) at gmain.c:2702
#27 0x00007feb10e87a40 in g_main_context_iterate (context=0xc77d20, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#28 0x00007feb10e87cdd in g_main_context_iteration (context=0xc77d20, may_block=1) at gmain.c:2843
#29 0x00007feb19e88653 in QEventDispatcherGlib::processEvents (this=0xbb8c20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#30 0x00007feb19097dae in QGuiEventDispatcherGlib::processEvents (this=0x2e80d50, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007feb19e5b342 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#32 0x00007feb19e5b724 in QEventLoop::exec (this=0x7fffc907e6b0, flags=) at kernel/qeventloop.cpp:201
#33 0x00007feb19e5f79b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#34 0x00007feb1cde4bf8 in kdemain (argc=1, argv=0x7fffc907eaa8) at /var/tmp/portage/kde-base/plasma-workspace-4.6.9999/work/plasma-workspace-4.6.9999/plasma/desktop/shell/main.cpp:118
#35 0x00007feb1ca1aebd in __libc_start_main () from /lib/libc.so.6
#36 0x00000000004007a9 in _start ()

This bug may be a duplicate of or related to bug 264079.

Possible duplicates by query: bug 264079, bug 252383, bug 232960, bug 230414, bug 228671.

An https://bugs.kde.org berichten

Reproducible: Didn't try
Comment 1 Beat Wolf 2011-02-22 10:22:15 UTC

*** This bug has been marked as a duplicate of bug 264079 ***
Comment 2 Dario Andres 2011-04-10 22:53:13 UTC

*** This bug has been marked as a duplicate of bug 268301 ***