Bug 266416 - KWin crash when turning off the screensaver.
Summary: KWin crash when turning off the screensaver.
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-16 03:10 UTC by Brian Pritchett
Modified: 2011-02-16 15:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Pritchett 2011-02-16 03:10:38 UTC
Application: kwin (4.6.00 (4.6.0) "release 381")
KDE Platform Version: 4.6.00 (4.6.0) "release 381"
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

KWin sometimes crashes when turning off the screensaver. I have plasmoids on the screensaver.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ffdd06be760 (LWP 10318))]

Thread 2 (Thread 0x7ffdb7cc7710 (LWP 10327)):
#0  0x00007ffdcbf8439c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ffdced9e634 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7ffdcf0c0180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007ffdced9e669 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7ffdcf0ce254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007ffdcbf7fa4f in start_thread () from /lib64/libpthread.so.0
#4  0x00007ffdcff3e82d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffdd06be760 (LWP 10318)):
[KCrash Handler]
#6  0x00007ffdb86efbf0 in ?? () from /usr/lib64/dri/i965_dri.so
#7  0x00007ffdb86e4dc4 in ?? () from /usr/lib64/dri/i965_dri.so
#8  0x00007ffdb86e6dca in ?? () from /usr/lib64/dri/i965_dri.so
#9  0x00007ffdd02996e5 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#10 0x00007ffdd0290e56 in KWin::Scene::paintGenericScreen (this=0x6bdb00, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#11 0x00007ffdd028dfaa in KWin::Scene::finalPaintScreen (this=0x6bdb00, mask=32, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#12 0x00007ffdd02ab2af in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#13 0x00007ffdb7dd2cbb in KWin::StartupFeedbackEffect::paintScreen (this=0x1062470, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#15 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#16 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#17 0x00007ffdb7d78f4f in KWin::LogoutEffect::paintScreen (this=0x1049220, mask=32, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#18 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#19 0x00007ffdb7d94ab2 in KWin::ShadowEffect::paintScreen (this=0xffc4b0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#20 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#21 0x00007ffdb7d7d9e2 in KWin::PresentWindowsEffect::paintScreen (this=0x1002960, mask=32, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#22 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#23 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#24 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#25 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#26 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#27 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#28 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#29 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#30 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#31 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#32 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#33 0x00007ffdb7d642f3 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#35 0x00007ffdb7d9b28d in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/slide/slide.cpp:86
#36 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#37 0x00007ffdb7d5ce72 in KWin::BoxSwitchEffect::paintScreen (this=0x108dc30, mask=32, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#39 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#40 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#41 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#42 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#43 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#44 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#45 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#46 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#47 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#48 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#49 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#50 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#51 0x00007ffdce37bf7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#52 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#53 0x00007ffdb7da4a9f in KWin::ZoomEffect::paintScreen (this=0x106cad0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/zoom/zoom.cpp:341
#54 0x00007ffdd02ab33c in KWin::EffectsHandlerImpl::paintScreen (this=0xf8b9c0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#55 0x00007ffdd02905d5 in KWin::Scene::paintScreen (this=0x6bdb00, mask=0x7fffb9fd547c, region=0x7fffb9fd5570) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#56 0x00007ffdd02a3529 in KWin::SceneOpenGL::paint (this=0x6bdb00, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#57 0x00007ffdd028b787 in KWin::Workspace::performCompositing (this=0x7a7e30) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:448
#58 0x00007ffdcc30d999 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#59 0x00007ffdcb49acd4 in QApplicationPrivate::notify_helper (this=0x6355a0, receiver=0x7a7e30, e=0x7fffb9fd5db0) at kernel/qapplication.cpp:4445
#60 0x00007ffdcb4a31ca in QApplication::notify (this=<value optimized out>, receiver=0x7a7e30, e=0x7fffb9fd5db0) at kernel/qapplication.cpp:4324
#61 0x00007ffdcf9b2ec6 in KApplication::notify (this=0x7fffb9fd6290, receiver=0x7a7e30, event=0x7fffb9fd5db0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#62 0x00007ffdcc2f9e2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#63 0x00007ffdcc327658 in ?? () from /usr/lib64/libQtCore.so.4
#64 0x00007ffdcc327d40 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#65 0x00007ffdcb540ccc in QEventDispatcherX11::processEvents (this=0x612380, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#66 0x00007ffdcc2f9262 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#67 0x00007ffdcc2f9475 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#68 0x00007ffdcc2fd8db in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#69 0x00007ffdd0229caa in kdemain (argc=<value optimized out>, argv=0x7fffb9fd62f0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#70 0x00007ffdcfe8cb7d in __libc_start_main () from /lib64/libc.so.6
#71 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 266303, bug 266132, bug 265960, bug 264493, bug 264258.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-02-16 15:06:12 UTC

*** This bug has been marked as a duplicate of bug 252817 ***