Bug 266264 - Sidebar does not automatically resize to avoid horizontal scrollbar
Summary: Sidebar does not automatically resize to avoid horizontal scrollbar
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Plugin-DImg-RAW (show other bugs)
Version: 2.0.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-14 06:03 UTC by RussianNeuroMancer
Modified: 2015-05-14 20:30 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments
Screenshot of the Russian version of batch raw converter (36.93 KB, image/jpeg)
2011-02-14 06:03 UTC, RussianNeuroMancer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RussianNeuroMancer 2011-02-14 06:03:39 UTC
Created attachment 57234 [details]
Screenshot of the Russian version of batch raw converter

Version:           1.8.0 (using KDE 4.6.0) 
OS:                Linux

Please check attached screenshot.

Reproducible: Didn't try



Expected Results:  
Conversion options should fit to converter window.

OS: Linux (x86_64) release 2.6.35-25-generic
Compiler: cc
Comment 1 caulier.gilles 2011-02-14 07:25:25 UTC
There is nothing to do in GUI. Strings from libkdcraw must be optimized...

Gilles Caulier
Comment 2 Alexander Potashev 2011-05-17 11:26:36 UTC
(In reply to comment #1)
> There is nothing to do in GUI. Strings from libkdcraw must be optimized...

Gilles, there are 2 problems that can be fixed in KipiPlugins+libkdcraw:
1. Even if you use RAW batch converter in English, the _horizontal_ scrollbar _always_ appears when there is no enough _vertical_ space. Shall I create a new bug report for this?
2. Layouting can be improved: https://git.reviewboard.kde.org/r/101375/ , https://git.reviewboard.kde.org/r/101376/

After applying those patches the width of the panel with Russian localization becomes 2 pixels narrower (though it may depend on the fonts used) than without those patched and with English language.

The bottleneck for Russian translation is now "T(K):" translated as "Temperature (K):" in messages/kdegraphics/libkdcraw.po.
Comment 3 caulier.gilles 2011-05-17 12:55:19 UTC
Git commit 492e0c7c75a2bbb4869a699b604fc044c2b6cfe9 by Gilles Caulier.
Committed on 17/05/2011 at 12:54.
Pushed by cgilles into branch 'master'.

improve settings layout
CCBUGS: 266264

M  +2    -2    common/libkipiplugins/widgets/savesettingswidget.cpp     

http://commits.kde.org/kipi-plugins/492e0c7c75a2bbb4869a699b604fc044c2b6cfe9
Comment 4 caulier.gilles 2011-05-17 12:55:27 UTC
Git commit 665fc7f54d9025183a21e85bcd2b72309173784f by Gilles Caulier.
Committed on 17/05/2011 at 12:53.
Pushed by cgilles into branch 'master'.

improve layout in settings widget
BUGS: 266264

M  +5    -5    libkdcraw/dcrawsettingswidget.cpp     

http://commits.kde.org/libkdcraw/665fc7f54d9025183a21e85bcd2b72309173784f
Comment 5 Alexander Potashev 2011-05-17 13:03:14 UTC
The bug is still not fixed since the horizontal scrollbar appears when it shouldn't.
Comment 6 caulier.gilles 2011-05-17 13:08:56 UTC
It's due probably to a bug in Qt4 QScrollArea which do not handle properly the width of content to host.

Gilles Caulier
Comment 8 Alexander Potashev 2011-05-17 13:29:11 UTC
If the problem can be fixed in QScrollArea::sizeHint (though, I'm not 100% sure about that), then it also can be hack-fixed by reimplementing RExpanderBox::sizeHint.
Comment 9 caulier.gilles 2011-05-17 13:33:43 UTC
yes probably. Patch is welcome...
Gilles Caulier
Comment 10 caulier.gilles 2011-11-03 12:19:17 UTC
Alexander,

Are you able to provide a patch for solution explained in #8 ?

Gilles Caulier
Comment 11 Alexander Potashev 2011-11-08 20:10:24 UTC
(In reply to comment #10)
> Are you able to provide a patch for solution explained in #8 ?

Gilles,

I did some debugging last week, and figured out that sizeHint for the right-side panel is called only once, i.e. nobody cares to all it again after the batch converter window or the contents of the QScrollArea change their sizes.

My guess is that we should call QScrollArea::widget()->adjustSize(); from time to time (I don't mean to call it every 100ms ;), adjustSize should probably be hooked to some signals or events).
Comment 12 caulier.gilles 2014-08-29 13:18:26 UTC
*** Bug 255757 has been marked as a duplicate of this bug. ***
Comment 13 caulier.gilles 2015-05-12 13:41:53 UTC
Maik,

Another file where changes must be minimal to fix it as explained in comment #8

Gilles
Comment 14 Maik Qualmann 2015-05-12 19:21:15 UTC
Gilles,

the batch RAW converter no longer exists. The German translation is also longer than the English. I can not notice any problems in BQM or in the settings dialog.

Maik
Comment 15 caulier.gilles 2015-05-12 21:16:36 UTC
Maik, 

Originally, the problem have been reported from RAWConverter kipi tool dialog.

The widget where problem have been detected is RAW decoding settings. It also used in RAWImport tool of digiKam Image Editor.

Just turn one RAW loading file in Editor through RAWImport tool and look if dysfunction exist on right sidebar of editor where Raw decoding settings is plugged.

Gilles
Comment 16 Maik Qualmann 2015-05-14 20:16:07 UTC
No horizontal scroll bar in the editor with the RAW import tool. Tested with the German and Russian language setting and a bigger font.

Maik
Comment 17 caulier.gilles 2015-05-14 20:30:17 UTC
yes, me too. we can considerate this file as fixed now.

Gilles