Bug 266182 - Desktop is frozen during cube rotation with direct rendering
Summary: Desktop is frozen during cube rotation with direct rendering
Status: RESOLVED DUPLICATE of bug 261323
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 6 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 267754 269088 269708 269860 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-13 09:02 UTC by Tari László
Modified: 2011-04-24 17:27 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
output from nvidia-settings -q all (36.38 KB, text/plain)
2011-04-12 19:13 UTC, Graziano
Details
output of "nvidia-settings -q all > nvidiasettings.txt" (35.74 KB, text/plain)
2011-04-12 19:45 UTC, alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tari László 2011-02-13 09:02:44 UTC
Version:           1.0 (using KDE 4.6.0) 
OS:                Linux

NVIDIA driver 260.29 (tried with different versions with the same result)

Enable desktop effects, enable desktop cube (direct rendering is enabled by default). Press Ctrl+F11 to get desktop cube effect, and rotate the cube with the mouse. After press 'space'.
The desktop effects will be disabled after a while, you cant do anything, only mouse works. If you turn off 'Direct Rendering' on the 'Special' tab of the Desktop Effects Settings, everything works normally.

Reproducible: Always

Steps to Reproduce:
1. enable desktop effects
2. enable desktop cube effect
3. press CTRL+F11 and rotate the cube
4. press 'space' to get back the workspace

Actual Results:  
The desktop is unmanageable, mouse works, but not continuously, after a while the desktop effects will be disabled because of "slow animation" (bubble note)

Expected Results:  
Desktop effects with direct rendering

OS: Linux (x86_64) release 2.6.37-22-desktop
Compiler: gcc
Comment 1 Thomas Lübking 2011-02-13 20:02:17 UTC
Sounds a lot like bug #260248, comment #4
Comment 2 Tari László 2011-02-14 11:35:23 UTC
I tested it with intel based notebook and ati based (open source default video driver) and direct rendering is working correctly.
In this case it must be an nvidia related bug. Or not. I do not know. :o)
I will report this bug to nvidia.
Comment 3 RussianNeuroMancer 2011-02-15 07:02:18 UTC
This is still issue with 270 beta driver?
Comment 4 Tari László 2011-02-15 09:04:36 UTC
Yes, with 270 it is the same.
270 is buggy anyway, unusable with opensuse 11.4.
Comment 5 Richard Cox 2011-02-19 18:10:35 UTC
I can confirm this bug.  With nvida-drivers 260.19.21 or 260.19.29, on kde-4.4 this problem did not occur.  I only started seeing this after I upgraded to kde-4.6.  It could still be some kind of latent driver bug, but it is only triggered by this effect.  Also, this is always present in the dmesg output when this happens:


[  287.600832] NVRM: Xid (0000:01:00): 13, 0003 00000000 00008297 00001b0c 1000f010 00000040

I've tested on all 260 and 270 (up to the latest 270.26) nvidia-drivers and it happens on all of them.  It's a very easy bug to reproduce.
Comment 6 Thomas Lübking 2011-02-19 18:19:05 UTC
- are you on opensuse as well?
- try to set the scale method to NOT accurate.
Comment 7 Richard Cox 2011-02-19 18:33:50 UTC
No, not opensuse, sorry, I should have mentioned my system specs a bit:

I'm Gentoo, AMD64, kernel 2.6.37 (also tried with several 2.6.36 kernels as well).

I tried changing the scale method from Accurate to Smooth and Crisp.  No change in behavior.  Desktop remains generally unresponsive after attempting to zoom out the desktop cube(only mouse cursor moves) until KDE suspends composite (60 or so seconds).  Composite can then be re-enabled and the desktop seems fine.
Comment 8 Tari László 2011-02-20 22:22:52 UTC
I updated my system with factory packages, and this bug does not exist during desktop cube effect, but

I forgot to tell you this bug also happens at Flipping window switching effect.

Steps to Reproduce:
1. enable desktop effects
2. enable flipping windows switching effect on GENERAL tab
3. press Alt+Tab to switch opened windows
Comment 9 Thomas Lübking 2011-02-21 00:24:49 UTC
flipswitch issue is known - doesn't happen here either :-(
-> bug #261323

stupid question regarding comments #12 & #13 there and #5 here: what kind of gtk applications are you running? maybe some docker among them? (cairo-dock etc.)
Comment 10 Richard Cox 2011-02-21 01:04:19 UTC
No gtk dockers...about the only non-KDE things I always have running are Google Chromium and Thunderbird for mail.
Comment 11 Tari László 2011-02-21 20:14:01 UTC
I revoke Comment #8, I can reproduce this bug with Desktop Cube effect.
:o(
Comment 12 chihocki 2011-02-27 16:40:55 UTC
I confirm this bug (both desktop cube and flipping windows effects). It can be always reproduced on Arch Linux (64 bit).

System details:
Driver:                                 NVIDIA
Driver version:                         260.19.36
GPU class:                              G80/G90
OpenGL version:                         3.3
GLSL version:                           3.30
X server version:                       1.9.2
Linux kernel version:                   2.6.36
Direct rendering:                       yes
Comment 13 RussianNeuroMancer 2011-02-27 17:01:36 UTC
Tari, you already trying to contact with nVidia about this bug?
linux-bugs@nvidia.com (require attach with results of nvidia-bug-report.sh script).
Comment 15 Dan Mitchell 2011-03-05 07:52:37 UTC
I have the same problem.  I'm running gentoo linux with KDE 4.6.  I get the
same errors as Anish, and experience a "hard freeze" that requires me to turn
off my PSU to reboot.  I can reproduce it in about 30 seconds from boot, and is
definitely the cube causing the problem.  Nvidia-drivers default portage
emerge.  

Sometimes ctrl-alt-f1 can be done before a total system hang.
Comment 16 Martin Flöser 2011-03-06 08:21:42 UTC
*** Bug 267754 has been marked as a duplicate of this bug. ***
Comment 17 Ezio Vergine 2011-03-15 16:49:14 UTC
Same problem with kubuntu 10.10 kde 4.6.1 an nvidia driver ver. 270.29
Comment 18 vsed777 2011-03-15 20:03:05 UTC
I have the same problem with Gentoo amd64, KDE 4.6 and nvidia driver 270.18
Comment 19 Martin Flöser 2011-03-21 22:34:24 UTC
*** Bug 269088 has been marked as a duplicate of this bug. ***
Comment 20 Montblanc 2011-03-27 22:44:47 UTC
(In reply to comment #17)
> Same problem with kubuntu 10.10 kde 4.6.1 an nvidia driver ver. 270.29

Confirmed.
Comment 21 Martin Flöser 2011-03-29 17:47:17 UTC
*** Bug 269708 has been marked as a duplicate of this bug. ***
Comment 22 Sergei 2011-03-30 15:20:04 UTC
I can confirm the same behavior under FreeBSD 8.2 amd64.
Nvidia 8800 GTS 320mb
driver version either 253.* and 260.19.44 
KDE 4.6.1 (built from ports)
Repeatable: always

Everything was OK before I've upgraded from KDE 4.5.4 to 4.6.1. Error in dmesg:
NVRM: Xid (0007:00): 13, 0003 00000000 00005097 00001b0c 1000f010 00000040
Comment 23 Thomas Lübking 2011-04-01 14:45:03 UTC
*** Bug 269860 has been marked as a duplicate of this bug. ***
Comment 24 Mathias Panzenböck 2011-04-05 16:46:46 UTC
I can also confirm this.
GeForce 8800 GTS 512/PCI/SSE2
Drivers: 260.19.44

What does the direct rendering option do?
Comment 25 Mathias Panzenböck 2011-04-05 16:50:34 UTC
PS: I only experience this bug since Fedora (14, x86_64) updated to KDE 4.6.1. Under 4.5.x there was no problem (4.6.0 was skipped by Fedora; they said it was to buggy).
Comment 26 Joe Taylor 2011-04-05 17:49:08 UTC
I don't know, I took it off my system.

--- grosser.meister.morti@gmx.net wrote:

From: Mathias Panzenböck <grosser.meister.morti@gmx.net>
To: redwingsred@linuxwaves.com
Subject: [Bug 266182] Desktop is frozen during cube rotation with direct rendering
Date: Tue,  5 Apr 2011 16:46:49 +0200 (CEST)

https://bugs.kde.org/show_bug.cgi?id=266182


Mathias Panzenböck <grosser.meister.morti@gmx.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |grosser.meister.morti@gmx.n
                   |                            |et




--- Comment #24 from Mathias Panzenböck <grosser meister morti gmx net>  2011-04-05 16:46:46 ---
I can also confirm this.
GeForce 8800 GTS 512/PCI/SSE2
Drivers: 260.19.44

What does the direct rendering option do?
Comment 27 Thomas Lübking 2011-04-05 18:55:02 UTC
Direct vs. Indirect rendering controls whether the application speaks to OpenGL directly or via the X11 server.
It's also a requirement for vertical synchronization - did you check that setting?
Comment 28 Joe Taylor 2011-04-05 22:58:44 UTC
Xrender and OpenGL both FAIL with Vsync on or off, Desktop cube freeze up the computer no many what I do with the settings.

--- thomas.luebking@gmail.com wrote:

From: Thomas Lübking <thomas.luebking@gmail.com>
To: redwingsred@linuxwaves.com
Subject: [Bug 266182] Desktop is frozen during cube rotation with direct rendering
Date: Tue,  5 Apr 2011 18:55:04 +0200 (CEST)

https://bugs.kde.org/show_bug.cgi?id=266182





--- Comment #27 from Thomas Lübking <thomas luebking gmail com>  2011-04-05 18:55:02 ---
Direct vs. Indirect rendering controls whether the application speaks to OpenGL
directly or via the X11 server.
It's also a requirement for vertical synchronization - did you check that
setting?
Comment 29 Thilo-Alexander Ginkel 2011-04-05 23:08:05 UTC
Just an idea: Are all relevant changes in git?

If so, one could bisect to find the commit triggering the bug.
Comment 30 Thomas Lübking 2011-04-05 23:28:41 UTC
(In reply to comment #28)
> Xrender and OpenGL both FAIL with Vsync on or off, Desktop cube freeze up the
> computer no many what I do with the settings.
You can no way activate the desktop cube with XRender.
Are you using compiz instead of KWin?

(In reply to comment #29)
> Just an idea: Are all relevant changes in git?
Git and svn (the move to git was right after the 4.6 tagging) - the svn history should have survived the transformation.
The problem is that the issue is likely not in the cube code at all -> gonna be a hard bisect :-(
(and no: it does not happen here at all, no matter what i do - sorry)
Comment 31 Joe Taylor 2011-04-06 00:00:21 UTC
No, I'm sorry, I worded that wrong. No, it disabled my desktop effects when I tried to use Xrender. I think it's a driver issue to tell you the truth, some people aren't having problems with ATi card, but people with Nvidia are. (at least that's what I've read.) 

--- thomas.luebking@gmail.com wrote:

From: Thomas Lübking <thomas.luebking@gmail.com>
To: redwingsred@linuxwaves.com
Subject: [Bug 266182] Desktop is frozen during cube rotation with direct rendering
Date: Tue,  5 Apr 2011 23:28:45 +0200 (CEST)

https://bugs.kde.org/show_bug.cgi?id=266182





--- Comment #30 from Thomas Lübking <thomas luebking gmail com>  2011-04-05 23:28:41 ---
(In reply to comment #28)
> Xrender and OpenGL both FAIL with Vsync on or off, Desktop cube freeze up the
> computer no many what I do with the settings.
You can no way activate the desktop cube with XRender.
Are you using compiz instead of KWin?

(In reply to comment #29)
> Just an idea: Are all relevant changes in git?
Git and svn (the move to git was right after the 4.6 tagging) - the svn history
should have survived the transformation.
The problem is that the issue is likely not in the cube code at all -> gonna be
a hard bisect :-(
(and no: it does not happen here at all, no matter what i do - sorry)
Comment 32 Mathias Panzenböck 2011-04-06 01:28:46 UTC
> I think it's a driver issue to tell you the truth, some
> people aren't having problems with ATi card, but people with Nvidia are. (at
> least that's what I've read.) 

It did work without problems with the same nvidia driver and KDE 4.5.x. The hangs are only since I updated to KDE 4.6.1. Hmm, there was also a Xorg update in the same time frame. Maybe the bug could be there?

I use:
X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: x86-16 2.6.32-71.14.1.el6.x86_64 
Current Operating System: Linux panzi 2.6.35.11-83.fc14.x86_64 #1 SMP Mon Feb 7 07:06:44 UTC 2011 x86_64
Kernel command line: ro root=UUID=9efd92a6-35a6-4c65-8ffd-d6079cf3e33c rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=de rhgb quiet vga=0x31B nouveau.modeset=0
Build Date: 18 March 2011  12:22:54AM
Build ID: xorg-x11-server 1.9.5-1.fc14 
Current version of pixman: 0.18.4(In reply to comment #31)
Comment 33 Joe Taylor 2011-04-06 01:43:49 UTC
That could be, I'm just going to stick with 4.5.5 until it's fixed.
Pardus 2011 is an awesome KDE Distro, very fast and stable running on 4.5.5, but it also has the same problems all the rest have if you update top 4.6.x.
--- grosser.meister.morti@gmx.net wrote:

From: Mathias Panzenböck <grosser.meister.morti@gmx.net>
To: redwingsred@linuxwaves.com
Subject: [Bug 266182] Desktop is frozen during cube rotation with direct rendering
Date: Wed,  6 Apr 2011 01:28:49 +0200 (CEST)

https://bugs.kde.org/show_bug.cgi?id=266182





--- Comment #32 from Mathias Panzenböck <grosser meister morti gmx net>  2011-04-06 01:28:46 ---
> I think it's a driver issue to tell you the truth, some
> people aren't having problems with ATi card, but people with Nvidia are. (at
> least that's what I've read.) 

It did work without problems with the same nvidia driver and KDE 4.5.x. The
hangs are only since I updated to KDE 4.6.1. Hmm, there was also a Xorg update
in the same time frame. Maybe the bug could be there?

I use:
X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: x86-16 2.6.32-71.14.1.el6.x86_64 
Current Operating System: Linux panzi 2.6.35.11-83.fc14.x86_64 #1 SMP Mon Feb 7
07:06:44 UTC 2011 x86_64
Kernel command line: ro root=UUID=9efd92a6-35a6-4c65-8ffd-d6079cf3e33c
rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8
SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=de rhgb quiet vga=0x31B
nouveau.modeset=0
Build Date: 18 March 2011  12:22:54AM
Build ID: xorg-x11-server 1.9.5-1.fc14 
Current version of pixman: 0.18.4(In reply to comment #31)
Comment 34 alexander 2011-04-12 16:57:40 UTC
I have the same issue with openSUSE11.4 KDE4.6.2 64bit, nvidia 8400M GT and 260.19.44 drivers. 
Please, how could I solve?
Comment 35 Thomas Lübking 2011-04-12 18:25:04 UTC
according to OP by disabling "direct rendering" ("kcmshell4 kwincompositing" / advanced tab)
notice that this causes some performance.

can someone encountering this issue or bug #261323 please dump and attach his nvidia settings?
"nvidia-settings -q all > nvidiasettings.txt"
Comment 36 Graziano 2011-04-12 19:13:49 UTC
Created attachment 58855 [details]
output from nvidia-settings -q all
Comment 37 alexander 2011-04-12 19:45:17 UTC
Created attachment 58857 [details]
output of "nvidia-settings -q all > nvidiasettings.txt"

(In reply to comment #35)
> according to OP by disabling "direct rendering" ("kcmshell4 kwincompositing" /
> advanced tab)
> notice that this causes some performance.

Yes, by disabling "direct rendering" the problem there is no more, but blur doesn't work.
 
> can someone encountering this issue or bug #261323 please dump and attach his
> nvidia settings?
> "nvidia-settings -q all > nvidiasettings.txt"

I encounter bug #261323 too. I'm attaching my nvidiasettings,txt.
Comment 38 Thomas Lübking 2011-04-12 21:07:54 UTC
please run "nvidia-settings" and in "OpenGL Settings" disable "Allow flipping"

see bug #261323 comments #39 and up.
Comment 39 Graziano 2011-04-12 21:50:58 UTC
(In reply to comment #38)
> please run "nvidia-settings" and in "OpenGL Settings" disable "Allow flipping"
> 
> see bug #261323 comments #39 and up.

Yep, that helps here
Comment 40 Thomas Lübking 2011-04-12 21:57:42 UTC
claiming dupe status then.

*** This bug has been marked as a duplicate of bug 261323 ***
Comment 41 Graziano 2011-04-12 22:13:30 UTC
It seems that disabling Allow Flipping only helps temporarily. I've got the next freeze about 10 min. after having disabled it. I checked three times and I could reproduce (had to reboot the box...). It simply takes longer until the freeze comes.
Comment 42 alexander 2011-04-12 23:46:28 UTC
(In reply to comment #41)
> It seems that disabling Allow Flipping only helps temporarily. I've got the
> next freeze about 10 min. after having disabled it. I checked three times and I
> could reproduce (had to reboot the box...). It simply takes longer until the
> freeze comes.

Yes, I can confirm. In addition, when press space button and cube disappears the screen becomes black for a moment, like a black flash.
Comment 43 Richard Cox 2011-04-23 17:22:24 UTC
It's a real shame this bug was duped to an unrelated bug based on invalid test results.  The only difference that disabling Allow Flipping had for me was that the screen became black (just like the user above belatedly reported)...with only white borders around open windows...other than that, no difference at all in the behavior.
Comment 44 Thomas Lübking 2011-04-23 17:40:35 UTC
reopening, but it lilkely drains from the same source... (and is still unreproducable here...)
Comment 45 Richard Cox 2011-04-23 18:14:59 UTC
Here is some new information I just saw, btw.  It may (or may not) be significant.  I recently upgraded to the new 270.41.03 drivers.  Now, when I trigger this event, I get some more information from the drivers in dmesg:

"[11048.032050] NVRM: Xid (0000:01:00): 8, Channel 00000001
[11050.032031] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
[11052.032080] NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context"
Comment 46 Thomas Lübking 2011-04-23 20:47:36 UTC
can you try to move /usr/lib/libkwinnvidiahack* out of the way, ie rename them or move them somewhere the linker won't find them?
then restart "kwin --replace&" and see whether sth. changes.
Comment 47 Thomas Lübking 2011-04-23 21:18:35 UTC
ERRRR scratch that!!
kwin won't load w/o libnvidiahack anymore...
Comment 48 Martin Flöser 2011-04-24 17:25:47 UTC
further investigation shows it is the same issue

*** This bug has been marked as a duplicate of bug 261323 ***
Comment 49 Martin Flöser 2011-04-24 17:27:46 UTC
further investigation shows it is the same issue

*** This bug has been marked as a duplicate of bug 261323 ***