Bug 265880 - HUB : extend metadata configuration panel to improve metadata handling while importing from file to database (and vis-versa)
Summary: HUB : extend metadata configuration panel to improve metadata handling while ...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Hub (show other bugs)
Version: 4.2.0
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks: 244224
  Show dependency treegraph
 
Reported: 2011-02-09 14:50 UTC by oivanenko
Modified: 2016-03-02 12:42 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oivanenko 2011-02-09 14:50:10 UTC
Version:           1.2.0 (using KDE 4.4.2) 
OS:                Linux

digikam automatically imports IPTC-keywords as
tags when finds new images in albums

Reproducible: Always

Steps to Reproduce:
1. Place image that contain IPTC-keywords metadata into digikam registered album-directory.
2. Run digikam

Actual Results:  
digikam imports IPTC-keywords as tags

Expected Results:  
digikam does not imports IPTC-keywords as tags

Please make optional possibility to switch off this behaviour
Comment 1 Jason Riedy 2012-07-10 16:50:12 UTC
I now have the opposite problem with Debian's 4:2.6.0-1+b1.  The IPTC tags no longer are used as image tags, the headline isn't used, etc. I had relied on digikam mapping IPTC metadata into its metadata.  I see no option for enabling it...  An exiv2 interaction changed, maybe?
Comment 2 caulier.gilles 2012-07-10 17:41:18 UTC
IPTC metadata is deprecated now. XMP must be used instead. Why ? Because IPTC do not support UTF8 and has string sizes limited. XMP don't have these limits.

IPTC still used to stored some reduced tags info, but not full Tags path.

Gilles Caulier
Comment 3 Jason Riedy 2012-07-10 20:18:10 UTC
I have over 15 thousand images, some of which are on archival storage. You're telling me I have to reprocess *all* of them to continue using digikam?

Thanks, but no. I'll find something else.
Comment 4 caulier.gilles 2012-07-10 20:40:29 UTC
Go to Tools/Maintenance. There is an option to sync metadata with database. Just take a care about Metadata/setup before.

Gilles Caulier
Comment 5 Jason Riedy 2012-07-10 21:07:29 UTC
That doesn't do anything, as it doesn't import the IPTC tags, header, etc.  Digikam isn't in charge of the archives; it's a handy viewer for more complex slices.
Comment 6 caulier.gilles 2012-07-10 21:13:09 UTC
Tools/Maintenance will synchronize XMP metadata with digiKam database information. This include Tags path. There is a Digikam XMP namespace for that :

http://www.sno.phy.queensu.ca/~phil/exiftool/TagNames/XMP.html#digiKam

Gilles Caulier
Comment 7 Jason Riedy 2012-07-10 21:49:14 UTC
But what I have is IPTC metadata, not XMP metadata.  You're telling me I have to convert *all* my metadata even on archived files if I want to use digikam.
Comment 8 caulier.gilles 2012-07-11 04:20:55 UTC
yes, it is...
Comment 9 Jason Riedy 2012-07-11 04:35:25 UTC
Goodbye.
Comment 10 Marcel Wiesweg 2012-07-11 19:07:25 UTC
AFAIK, IPTC import is (of course) still possible. Though that's not the original request here.
Comment 11 Jason Riedy 2012-07-11 19:18:54 UTC
Import from the tags and headlines is not working now.  That's what the original reporter wanted, and the opposite of what I want...
Comment 12 Marcel Wiesweg 2012-09-16 15:31:04 UTC
Jason: A simple test shows me that reading IPTC keywords is working. If you have an image where this is not the case with a recent digikam/libkexiv2, please post if in a new bug report. The original report here is quite different.
Comment 13 Marcel Wiesweg 2012-09-29 11:33:11 UTC
I change the title to a more general wish: We allow to fine-grained configuration of which information is written to metadata. Add similar configuration to specify which fields are imported from metadata into the database.
Comment 14 km 2014-02-23 22:00:54 UTC
I agree, the auto-import of tags is sometimes very annoying. Here is another idea for controlling this behaviour: 
https://bugs.kde.org/show_bug.cgi?id=287510
Comment 15 caulier.gilles 2014-09-01 21:30:28 UTC
*** Bug 336164 has been marked as a duplicate of this bug. ***
Comment 16 caulier.gilles 2014-09-02 09:26:54 UTC
*** Bug 196484 has been marked as a duplicate of this bug. ***
Comment 17 caulier.gilles 2014-09-02 09:53:51 UTC
*** Bug 244224 has been marked as a duplicate of this bug. ***
Comment 18 caulier.gilles 2014-09-05 13:33:04 UTC
*** Bug 289300 has been marked as a duplicate of this bug. ***
Comment 19 Veaceslav Munteanu 2016-03-02 12:42:54 UTC
Digikam 5.0.0 have the extended panel, which will allow you to select in which order and what digiKam will read and write metadata.