Bug 287510 - Only import existing tags
Summary: Only import existing tags
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Tags-Engine (show other bugs)
Version: 2.3.0
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-25 06:47 UTC by Adam Porter
Modified: 2021-12-29 14:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Porter 2011-11-25 06:47:48 UTC
Version:           2.3.0 (using KDE 4.7.2) 
OS:                Linux

When I download new desktop wallpaper, I put it in Digikam.  Often the new wallpaper has IPTC keyword tags already, and these end up in my Digikam tag hierarchy.  This is quite annoying, since it pollutes my tag hierarchy with a bunch of tags I didn't make and don't want.

It would be nice if Digikam could ignore tags that don't already exist in the tag tree when reading tags from images.

Reproducible: Always



Expected Results:  
Expected results were not provided. In order to verify that the bug is fixed or that the feature is implemented as requested, please provide information on what the software should have done instead. This will make it easier to ensure that your report is fixed to your satisfaction.
Comment 1 Plasticbeach 2014-08-06 10:42:43 UTC
I believe this to be mostly the same as 
#196484

and I suggested a fundamental solution to many of these import related problems in #338048 but it seems to be to big to be focused very soon.
Comment 2 caulier.gilles 2014-08-06 19:50:05 UTC

*** This bug has been marked as a duplicate of bug 196484 ***
Comment 3 caulier.gilles 2021-12-29 14:09:40 UTC
Fixed with #196484