Bug 265734 - Mouse randomly acts weird: wrong focus, clicks don't work
Summary: Mouse randomly acts weird: wrong focus, clicks don't work
Status: RESOLVED NOT A BUG
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: 4.6
Platform: openSUSE RPMs Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 325152 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-07 22:52 UTC by Guido Schmidt
Modified: 2020-09-28 21:15 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Schmidt 2011-02-07 22:52:47 UTC
Version:           4.6 (using KDE 4.6.0) 
OS:                Linux

I use a Logitech Mediaplay-mouse and the current NVIDIA proprietary graphic-drivers and starting (I guess) in January while having KDE 4.5.5 installed I encountered some weird behavior:

- Buttons and mouse-over work in firefox only (might be not related to firefox,
  but that's what I use so often).
- Buttons and mouse-over work in the control-bar only.
- Buttons and mouse-over don't do anything anywhere.
- Buttons act on one specific location only. It's seems even though the mouse
  cursor moves visually, KDE (or X?) uses the same coordinates for the buttons. 
  - Once I could only move an arbitrary window by dragging with the left mouse 
    button no matter where (cursor changed to the according symbol). 
  - Another time a mouse click was always send to a button I clicked before.
  - And then there was a time where I first switched desktops by scrolling the
    mouse while over the desktop and then tried to scroll the contents of a 
    firefox-window but what I got was again switching desktops.
- I just discovered that when I'm stuck with firefox (like in the first item
  above) and when I left-click in a window that is partly covered by firefox,
  that window does not raise nor do the window decorations indicate a focus
  change, but from now on that window receives all mouse clicks (but not the
  keyboard events) and the mouse cursor changes according to the various parts
  of that window.

Mouse-movement is always working.

I think (but haven't tried often enough to be sure) that restarting the KDE-session helps.

Maybe this bug is related to bugs #257963, #254319 or #173606.

Reproducible: Sometimes




OS: Linux (x86_64) release 2.6.34.7-0.7-desktop
Compiler: gcc
Comment 1 Guido Schmidt 2011-02-08 01:15:11 UTC
I just found out the keyboard is affected too:

When the mouse acts weird in some way and I open the window-menu via Alt-F3 the menu appears, but I cannot select anything in it, neither with the mouse nor with the keyboard, not even ESC works to close it.

So at least part of this bug is related to the window-manager, right?
Comment 2 Till Schäfer 2011-02-09 00:47:58 UTC
I confirm the behaviour on my system. 

I am using Gentoo Linux with kde 4.6.0 and qt 4.7.1 with xorg-server 1.9.3.902. 

It seems that the focus is wrong. Sometimes the window below the current active window is receiving the mouse events. The keyboard events are handled by the active window. Sometimes all Windows are untouched and the mouse events "fall throug" to the desktop. i.e. scrolling in firefox results in changing the desktop (wich is the action for scrolling on the desktop)

This happens randomly. Mainly after opening a new window or application. 

i have noticed that kded4 daemon is also randomly generating 100% cpu. don't know if this is related to each other. kded4 can be only stopped with -9.
Comment 3 dsurber 2011-03-07 05:21:38 UTC
I'm seeing the same behavior. I'm running Kubuntu 10.10. I'm using a Logitech wireless mouse and Nvidia proprietary drivers. This just started a couple of days ago, so it is something that has just been pushed to kubuntu via automatic updates. When it started, the Input Method Switcher showed up in my Settings menu but reported than zenity was not installed. Installing zenity allowed im-switcher to work, but made no difference in the mouse event handling.

All movement events work.
button and wheel events within the window with focus work
button events in other windows are ignored.
xev reports all the expected events including button events in blurred windows.
Sometimes right mouse button events will kick something loose so the next left button event will get processed. 
Cursors mostly change as expected.
Occasionally top reports xorg consuming 100% of a very powerful cpu for several seconds just to do trivial window operations, like change focus.
Exact same hardware was working prior to recent, past few days, kubuntu automatic upgrade.
Also I had to enable legacy USB support sometime within the past week. Never had to do that before. May have happened at the same time as the mouse button issue.

I can get around with alt-tab, but a lot of stuff is difficult to accomplish. For example once the screen saver blanks the screen no events seem to get processed so it is impossible to un-blank the screen. For me this is a serious bug and if it isn't resolved very soon, at least with a work around, I'm going to have to do something really drastic to get a working system back.
Comment 4 dsurber 2011-03-07 05:49:50 UTC
I'm running KDE 4.5.1. I have an Intel i7 920, 6GB memory. Keyboard focus seems to follow alt-tab pretty well, but the ability to recognise mouse button events does not. If I click the right mouse button in the window that is recognising mouse button events then I can left click on a window and it will start recognising mouse button events, but not (or not necessarily) key events. At one point I noticed some weirdness with the cursor. It was showing the hand, not the arrow or I-beam as expected in FF. When I pointed to a tool bar button in FF the cursor started swapping back and forth between the arrow and the hand (I think it was very fast so very hard to tell exactly what it was doing). Once I get keyboard and mouse focus within a window I can use that window ok. Moving between windows is hard. Waking from the screen saver is impossible.
Comment 5 Guido Schmidt 2011-03-17 22:33:58 UTC
I'm now using OpenSUSE 11.4 with KDE 4.6.1 and NOUVEAU-graphics-driver. Bug is still alive.
Comment 6 dsurber 2011-03-19 20:21:28 UTC
I bought a new wired mouse (Razer DeathAdder ooooooh!) and it works fine. Seems my Logitech wireless mouse is not supported somehow. It used to work.
Comment 7 Till Schäfer 2011-04-06 11:48:08 UTC
This bug is still in kde 4.6.1 with intel graphics and synaptic touchpad or logitech mouse. I dont think it is related to the mouse type, because i can reproduce the same behaviour with no mouse attached. Why is this bug still unconfirmed? this bug is very annoying .. i have to restart (re-login) kde every few hours to fix it.
Comment 8 M Marziali 2011-04-15 20:33:37 UTC
I'm also experiencing this problem, but it's not KDE's. Actually, it seem Xorg is responsible. For instance, I tried with Xfce and the bug was still there. Then I've found this thread (https://bugs.launchpad.net/xorg-driver-synaptics/+bug/375905) in which several people describes the same problem with different desktops.
Comment 9 Till Schäfer 2011-04-15 20:43:56 UTC
For me i have found an error related to synaptics touchpad driver that causes the problem. If i disable the touchpad, the error disapears. It is reportet at freedesktop:

https://bugs.freedesktop.org/show_bug.cgi?id=26213 (see Comment 13)
Comment 10 RedFox 2013-01-04 07:04:51 UTC
I am experiencing this bug after upgrading to Kubuntu 12.10 which uses KDE 4.9.3. With the same hardware, I never had this problem before.

Has a fix really been found? I find it odd that I never had this bug before, but now have it on updated software, especially considering the age of this report.

The bug has been reported here, on Launchpad and on Freedesktop. Has the source of the problem really been found? Killing Kwin, Plasma-desktop or synaptiks did not fix the problem, so I'm guessing those are not the source of the problem.

https://bugs.launchpad.net/ubuntu/+bug/375905
https://bugs.freedesktop.org/show_bug.cgi?id=26213
Comment 11 Guido Schmidt 2013-01-04 19:39:07 UTC
This is no KDE-bug. It is reported to occur on other desktops too. Have a look at the above mentioned bug report on freedesktop.org.
Comment 12 Nate Graham 2020-09-28 21:15:19 UTC
*** Bug 325152 has been marked as a duplicate of this bug. ***