Bug 265560 - No available channels listed
Summary: No available channels listed
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: 3.7
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-06 00:42 UTC by Paul Elliott
Modified: 2011-12-13 22:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
picture showing no available channels (27.31 KB, image/png)
2011-02-06 00:42 UTC, Paul Elliott
Details
screenshot of channels visible from alsamixer (51.20 KB, image/png)
2011-02-06 00:46 UTC, Paul Elliott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Elliott 2011-02-06 00:42:56 UTC
Created attachment 56907 [details]
picture showing no available channels

Version:           3.7 (using KDE 4.5.1) 
OS:                Linux

no available channels corresponding to channels on device. I have both a SB Live! 5.1 and an HDA NVidia both have a "line in" input but none of these show as a visible or available channel. There for I can not alter the levels for these inputs.

Reproducible: Didn't try

Steps to Reproduce:
Bring up mixer window. Right click on SB Live!EMU10k1 Analog Stereo. Choose channels. Nothing corresponding to "Line In" appears.

Actual Results:  
No "Line IN"

Expected Results:  
Some way to alter the level for "Line in"

alsamixer clearly shows the "Line" channel or device or what do you call it.
Comment 1 Paul Elliott 2011-02-06 00:46:47 UTC
Created attachment 56908 [details]
screenshot of channels visible from alsamixer
Comment 2 Martin Koller 2011-02-12 12:12:43 UTC

*** This bug has been marked as a duplicate of bug 265733 ***
Comment 3 Christian Esken 2011-12-13 20:52:11 UTC
Your distribution or you have chose to use Pulseaudio. KMix follows this choice and displays the Pulseaudio controls instead of the ALSA controls. For controlling your soundcard hardware details there are two choices:
1) With Pulseaudio: Please use KMix's main menu "Setting -> Audio Setup" to get access to a detailed soundcard setup. This is still Pulseaudio, but you usually are able to control all relevant audio aspects.
2) Without Pulseaudio: If you want to see the ALSA-Controls then please deactivate Pulseaudio. For openSUSE this is in YaST -> Sound. For other distributions please refer to your Linux distribution documentation, Wiki or in appropriate internet forums. 

As this is not a KMix bug, I will close this bug report.
Comment 4 Christian Esken 2011-12-13 20:54:53 UTC
Pasted text in wrong Ticket. Sorry. Please ignore former comment.
Comment 5 Christian Esken 2011-12-13 20:56:36 UTC
No. It was correct (see http://bugsfiles.kde.org/attachment.cgi?id=56907=. Closing again.
Comment 6 Christian Esken 2011-12-13 22:39:42 UTC
The screenshot looks a bit strange. It seems to show soundcards. It likely will help if you upgrade to a more recent KDE version.

For further insight into this, please post the following information:

- Which sound backend is used. Please copy the output from
    KMix menu => Help => Hardware information

- The ouput of "amixer" (or "amixer -c 1" or any other number that corresponds to the affected soundcard).