Bug 265733 - Some channels missing in KMix after update to KDE 4.6
Summary: Some channels missing in KMix after update to KDE 4.6
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: HI normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-07 22:32 UTC by karl.r.ernst
Modified: 2011-12-22 13:15 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
amixer output of the affected soundcard (10.96 KB, text/plain)
2011-12-14 21:14 UTC, karl.r.ernst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karl.r.ernst 2011-02-07 22:32:40 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

Previously before the upgrade, everything worked fine. But after update to 4.6, some audio channels went missing in KMix. They can't be found in the channel configuration dialog either, but they still show up in alsamixer. Some channels are e.g. "Sigmatel 4-Speaker Stereo" or "SB Live Analog/Digital Output Jack"

Soundcard: Creative SB Live! 5.1
Soundsystem: alsa (as in no pulseaudio)

PS.: I cannot select 3.8 as application version, thats why I left it unspecified

Reproducible: Always
Comment 1 karl.r.ernst 2011-02-07 22:38:19 UTC
Actually, it seems like all the options in alsamixer which are only on/off toggleable and don't have a volume slider have disappeared, while those with a volume slider (even if they have a on/off option) are still there.
Comment 2 Martin Koller 2011-02-12 12:12:44 UTC
*** Bug 265560 has been marked as a duplicate of this bug. ***
Comment 3 Martin Koller 2011-02-12 12:13:00 UTC
*** Bug 255396 has been marked as a duplicate of this bug. ***
Comment 4 p92 2011-02-19 15:15:17 UTC
A nice ressource http://pulseaudio.org/wiki/KDE
Comment 5 Christian Esken 2011-08-17 19:42:26 UTC
The Observation from Karl seems to be correct. I can reproduce that. 
Thanks for reprorting. It needs to be fixed.
Comment 6 Christian Esken 2011-12-13 21:14:20 UTC
I have an idea what is wrong but need some information:

- Which sound backend is used. Please copy the output from
    KMix menu => Help => Hardware information

- The ouput of "amixer" (or "amixer -c 1" or any other number that corresponds to the affected soundcard).
Comment 7 Christian Esken 2011-12-13 21:20:37 UTC
SVN commit 1268585 by esken:

INital try to fix missing controls. Needs verification from affected users.
CCBUGS: 265733

 M  +15 -8     mixer_alsa9.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1268585
Comment 8 Christian Esken 2011-12-13 22:20:44 UTC
Please post hardware information (see Comment 6) and verify the fix (see Comment 7).
Comment 9 karl.r.ernst 2011-12-14 21:14:20 UTC
Created attachment 66759 [details]
amixer output of the affected soundcard
Comment 10 karl.r.ernst 2011-12-14 21:16:28 UTC
Help => Hardware information says:
supported driver: ALSA + OSS
used driver: ALSA

will try the patch probably on the weekend
Comment 11 Christian Esken 2011-12-14 23:31:10 UTC
I just noted that my patch is not sufficient, but I found a way to reproduce it. See the duplicate bug 257953. I'll mark this bug as duplicate.

*** This bug has been marked as a duplicate of bug 257953 ***
Comment 12 Christian Esken 2011-12-22 12:56:36 UTC
SVN commit 1270003 by esken:

Fix missing controls.

 M  +9 -13     backends/mixer_alsa9.cpp  
 M  +7 -5      gui/viewsliders.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1270003
Comment 13 Christian Esken 2011-12-22 12:56:50 UTC
SVN commit 1270004 by esken:

Fix missing controls.

 M  +2 -0      TestCases  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1270004
Comment 14 Christian Esken 2011-12-22 13:11:56 UTC
SVN commit 1270008 by esken:

Fix missing controls. Backport to branch 4.7


 M  +2 -2      viewsliders.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1270008
Comment 15 Christian Esken 2011-12-22 13:15:50 UTC
SVN commit 1270010 by esken:

Fix missing controls. Backport to branch 4.6


 M  +2 -2      viewsliders.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1270010