Bug 265554 - problem in colors between dgikam's theme and Gnome appearance
Summary: problem in colors between dgikam's theme and Gnome appearance
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Themes (show other bugs)
Version: 1.4.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-05 22:50 UTC by Julien
Modified: 2017-08-03 20:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments
digikam appearance with 'dessert' theme (181.73 KB, image/png)
2011-02-05 22:50 UTC, Julien
Details
digikam main window (369.79 KB, image/png)
2011-11-20 22:06 UTC, Julien
Details
digikam version window (57.06 KB, image/png)
2011-11-20 22:08 UTC, Julien
Details
albums list background color wrong (151.21 KB, image/png)
2013-01-30 08:34 UTC, moon300web
Details
my tags background color wrong (499.15 KB, image/png)
2013-01-30 08:39 UTC, moon300web
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien 2011-02-05 22:50:51 UTC
Created attachment 56903 [details]
digikam appearance with 'dessert' theme

Version:           1.4.0 (using KDE 4.5.1) 
OS:                Linux

When I select the theme 'ambiance' in gnome (running in ubuntu 10.10, not kubuntu...) and I want to select the 'dessert' digikam theme, there is a mismatch in colors for the background of the albums/tags tree on the left as well as the background of the information on the right side. See Attachment 1 [details].
I have edited the Dessert theme in /usr/share/kde4/apps/digikam/themes. It appears that whatever value I put in ListviewRegularColor and ListviewSelectedColor, it has no effect on the Digikam GUI. In fact I have searched in Gnome Appearance Preferences (in Systeme->Preferences->Apparence in my french Ubuntu) : the color used for the background of the album/tag tree is the same one as background of 'Zone de saisie'. If I change this color, all my windows have it...

It was not the case in a previous version, maybe in Ubuntu 10.04 or earlier.

I have now Ubuntu 10.10 on Gnome 2.32.0.

Reproducible: Always



Expected Results:  
there might be a bug in using the correct value of ListviewRegularColor and ListviewSelectedColor : if I change these values, I am expecting to see it on the digikam window.

If I use the default theme, there is still a non uniformity in the  rendered colors
Comment 1 caulier.gilles 2011-04-07 14:11:00 UTC
Git commit e55f3d748f461f2f1ac956995d644de658200a4a by Gilles Caulier.
Committed on 07/04/2011 at 14:11.
Pushed by cgilles into branch 'master'.

port digiKam theme engine to KDE color Theme engine.
Now, there is no mix between digiKam color engine and KDE theme used in background.
Benefits : we can donload new color theme scheme from KDE control center and apply it to digiKam as well,
independently of the rest of KDE.

To end users : I don't tested under Gnome. Please give me a feedback...

BUGS: 257803
BUGS: 250265
BUGS: 220068
BUGS: 241116
BUGS: 252700
BUGS: 168669
CCBUGS: 265554

M  +0    -1    data/CMakeLists.txt     
D  +0    -74   data/themes/Blue     
D  +0    -15   data/themes/CMakeLists.txt     
D  +0    -75   data/themes/Clean     
D  +0    -75   data/themes/DLR     
D  +0    -74   data/themes/Dark     
D  +0    -78   data/themes/DarkRoom     
D  +0    -63   data/themes/Dessert     
D  +0    -75   data/themes/Digikasa     
D  +0    -75   data/themes/Dreary     
D  +0    -63   data/themes/Gray     
D  +0    -75   data/themes/Marine     
D  +0    -75   data/themes/OrangeCrush     
D  +0    -62   data/themes/Rose     
D  +0    -75   data/themes/Sandy     
M  +13   -40   digikam/main/digikamapp.cpp     
M  +1    -3    digikam/main/digikamapp.h     
M  +0    -3    digikam/main/digikamapp_p.h     
M  +1    -5    libs/themeengine/theme.cpp     
M  +1    -4    libs/themeengine/theme.h     
M  +198  -1187 libs/themeengine/themeengine.cpp     
M  +16   -15   libs/themeengine/themeengine.h     
M  +6    -5    showfoto/main/showfoto.cpp     
M  +1    -29   utilities/cameragui/main/cameraui.cpp     
M  +0    -3    utilities/cameragui/main/cameraui.h     
M  +0    -3    utilities/cameragui/main/cameraui_p.h     
M  +1    -43   utilities/imageeditor/editor/editorwindow.cpp     
M  +0    -6    utilities/imageeditor/editor/editorwindow.h     
M  +0    -12   utilities/imageeditor/editor/imagewindow.cpp     
M  +0    -2    utilities/imageeditor/editor/imagewindow.h     
M  +1    -32   utilities/lighttable/lighttablewindow.cpp     
M  +0    -3    utilities/lighttable/lighttablewindow.h     
M  +0    -3    utilities/lighttable/lighttablewindow_p.h     
M  +1    -32   utilities/queuemanager/main/queuemgrwindow.cpp     
M  +0    -3    utilities/queuemanager/main/queuemgrwindow.h     
M  +0    -3    utilities/queuemanager/main/queuemgrwindow_p.h     

http://commits.kde.org/digikam/e55f3d748f461f2f1ac956995d644de658200a4a
Comment 2 caulier.gilles 2011-04-10 15:08:25 UTC
I checked under Gnome, and now digiKam (KDE) themes are fully compatible with this desktop...

Gilles Caulier
Comment 3 Julien 2011-11-20 22:06:52 UTC
Created attachment 65882 [details]
digikam main window
Comment 4 Julien 2011-11-20 22:08:34 UTC
Created attachment 65883 [details]
digikam version window

I now use Digikam Version 2.1.1
Utilisation de la plate-forme de développement de KDE 4.7.2 (4.7.2)

I upgraded Ubuntu to 11.10. Default theme Ambiance is installed.
I still have an issue having a correct color for the background of the albums lists as well as other selectable lists on the left of digikam. It is always 'white' whatever theme I select for digikam ; other colors of the theme are applied but not this one.

I attach two files showing the issue.
Comment 5 Julien 2011-11-20 22:10:58 UTC
The problem is not fixed under Gnome
Comment 6 Pierre Hanser 2011-11-21 06:31:49 UTC
under gnome + ubuntu 11.10,  you can tweak some colors with tool 'systemsettings'
may be you will find what you want in this tool. it was useful for me to tweak tooltips
background color
Comment 7 caulier.gilles 2011-11-21 07:22:55 UTC
WONTFIX => WORKFORME
Comment 8 caulier.gilles 2011-11-22 16:22:04 UTC
Git commit 007759d0a1d80d11c17a3cc005d80c803d0e9dfa by Gilles Caulier.
Committed on 22/11/2011 at 17:20.
Pushed by cgilles into branch 'master'.

apply patch #65930 from Rex Dieter
BUGS: 283572
BUGS: 265554

M  +4    -4    libs/widgets/common/ditemtooltip.cpp

http://commits.kde.org/digikam/007759d0a1d80d11c17a3cc005d80c803d0e9dfa
Comment 9 moon300web 2013-01-30 08:34:32 UTC
Created attachment 76802 [details]
albums list background color wrong
Comment 10 moon300web 2013-01-30 08:38:42 UTC
Digikam 2.9.0 running in gnome 3.6 (fedora 18).
The background of the Albums/Tags list is still not influenced by any theme.
Can anyone explain how to control the background color of the Albums list?
I tried via: gnome-tweak tool, systemsettings (KDE) and qt-config and the  theme setting in digikam itself.
It woudl already help if the theme setting in digikam would influence this color (also what one would expect).
Comment 11 moon300web 2013-01-30 08:39:41 UTC
Created attachment 76803 [details]
my tags background color wrong
Comment 12 Christoph Feck 2013-02-07 21:51:30 UTC
Please try switching GTK+ themes, it might be a bug with the theme you use. If the issue appears with all GTK+ themes, please report a new bug.
Comment 13 moon300web 2013-02-08 17:29:06 UTC
Indeed some GTK+ themes do influence the 'my tags' and 'albums list' background!

So to get a darkly themed digikam:
First choose a digikam theme inside digikam itself e.g. Obsidian Coast. Then make sure you choose a dark GTK+ theme in gnome-tweaktool, so that the Album/Tags background also becomes dark.
Not all GTK+ themes influence those colors.
Problem solved.

However - shouldn't the Obsidian Coast theme itself set these colors? I mean, currently the text in Albums/Tags becomes unreadable when your GTK+ theme is light and you choose Obsidian Coast (which has light text).
Comment 14 caulier.gilles 2016-05-30 18:57:13 UTC
Git commit 4837b2773846c7c32e947d3b1b8b706275731b95 by Gilles Caulier.
Committed on 30/05/2016 at 18:54.
Pushed by cgilles into branch 'master'.

Dispatch colors theme properly to widget style manager for main windows
Related: bug 172632, bug 241116, bug 146938, bug 240148, bug 252700, bug 168669, bug 179898, bug 220068
FIXED-IN: 5.0.0

M  +2    -1    libs/widgets/mainview/thememanager.cpp

http://commits.kde.org/digikam/4837b2773846c7c32e947d3b1b8b706275731b95