Bug 241116 - [Themes] Cannot change text colour in menu bar
Summary: [Themes] Cannot change text colour in menu bar
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Menus (show other bugs)
Version: 1.2.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-08 17:32 UTC by Claudio Piombetti
Modified: 2017-08-02 21:08 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments
Screenshot of Digikam's menu with unreadable text in Ubuntu 10.04 (24.54 KB, image/jpeg)
2010-06-08 17:32 UTC, Claudio Piombetti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Claudio Piombetti 2010-06-08 17:32:11 UTC
Created attachment 47816 [details]
Screenshot of Digikam's menu with unreadable text in Ubuntu 10.04

Version:           1.2.0 (using KDE 4.4.2) 
OS:                Linux

In Ubuntu 10.04 I have the same issue reported by Dicusar (on Windows) in ticket #240148: changing to a theme with a dark background (e.g. Dessert, DLR, Dark), the text in the menu bar at the top becomes unreadable (dark text on dark background), see attachment. I have tried to create a new theme with a lighter text colour for the menu, but TextRegularColor, TextSelectedColor, TextSpecialRegularColor and TextSpecialSelectedColor have no effect on that. How do we change it?

Reproducible: Always

Steps to Reproduce:
1) Launch Digikam
2) Select SETTINGS ->THEMES -> DLR
3) Try to read the text next to the icons for NEW, PROPERTIES, SEARCH, VIEW, EDIT, and any other on the same line of the menu.

Actual Results:  
The text alongside the icons is black on dark background, very hard to read (at least for me and, I guess, for the user who created #240148).

Expected Results:  
I'd expect to be able to change the colour of the menu's text by editing the available themes or by creating a new one. DigiKam's themes XML specifications should include an XML tag for this, e.g. TextMenuColor.

Side note: the theme editor mentioned at http://www.digikam.org/drupal/node/26 seems to have disappeared...
Comment 1 caulier.gilles 2010-06-08 17:36:21 UTC
You don't need theme editor in fact. theme are simple XML files.

I recommend to change KDE color scheme to see if problem come there. I cannot reproduce the problem on my system.

Gilles Caulier
Comment 2 Claudio Piombetti 2010-06-08 18:26:57 UTC
Gilles,
Thanks for the ultra-prompt reply. Not a life-or-death issue, slow down...  ;)    

(the tagging issue - #237452 - is a lot more serious, it's a show-stopper, at least for me). 

> I recommend to change KDE color scheme to see if problem come there. 

I appreciate your advice, but the only colour schemes that I appreciate have a dark background, and they all suffer from the same issue: dark text on dark background, which makes the text unreadable.

> I cannot reproduce the problem on my system.
But have you seen the screenshot and the other request on the same issue (#240148)? Can you read the text?


> You don't need theme editor in fact. theme are simple XML files.

I know these are XML files, and I have already edited them, but the DigiKam website says there's a theme editor, and instead there isn't, apparently.

However, working on the XML files does not fix the problem, since there seems to be no selector/tag to alter the colour of the menu text. Is there a way to change the colour of that text (indicated by the orange arrows in my screenshot)?
Comment 3 sylvainsjc 2010-08-28 12:33:18 UTC
rather annoying problem
Expecting a solution soon
regards
Comment 4 caulier.gilles 2011-04-07 14:11:00 UTC
Git commit e55f3d748f461f2f1ac956995d644de658200a4a by Gilles Caulier.
Committed on 07/04/2011 at 14:11.
Pushed by cgilles into branch 'master'.

port digiKam theme engine to KDE color Theme engine.
Now, there is no mix between digiKam color engine and KDE theme used in background.
Benefits : we can donload new color theme scheme from KDE control center and apply it to digiKam as well,
independently of the rest of KDE.

To end users : I don't tested under Gnome. Please give me a feedback...

BUGS: 257803
BUGS: 250265
BUGS: 220068
BUGS: 241116
BUGS: 252700
BUGS: 168669
CCBUGS: 265554

M  +0    -1    data/CMakeLists.txt     
D  +0    -74   data/themes/Blue     
D  +0    -15   data/themes/CMakeLists.txt     
D  +0    -75   data/themes/Clean     
D  +0    -75   data/themes/DLR     
D  +0    -74   data/themes/Dark     
D  +0    -78   data/themes/DarkRoom     
D  +0    -63   data/themes/Dessert     
D  +0    -75   data/themes/Digikasa     
D  +0    -75   data/themes/Dreary     
D  +0    -63   data/themes/Gray     
D  +0    -75   data/themes/Marine     
D  +0    -75   data/themes/OrangeCrush     
D  +0    -62   data/themes/Rose     
D  +0    -75   data/themes/Sandy     
M  +13   -40   digikam/main/digikamapp.cpp     
M  +1    -3    digikam/main/digikamapp.h     
M  +0    -3    digikam/main/digikamapp_p.h     
M  +1    -5    libs/themeengine/theme.cpp     
M  +1    -4    libs/themeengine/theme.h     
M  +198  -1187 libs/themeengine/themeengine.cpp     
M  +16   -15   libs/themeengine/themeengine.h     
M  +6    -5    showfoto/main/showfoto.cpp     
M  +1    -29   utilities/cameragui/main/cameraui.cpp     
M  +0    -3    utilities/cameragui/main/cameraui.h     
M  +0    -3    utilities/cameragui/main/cameraui_p.h     
M  +1    -43   utilities/imageeditor/editor/editorwindow.cpp     
M  +0    -6    utilities/imageeditor/editor/editorwindow.h     
M  +0    -12   utilities/imageeditor/editor/imagewindow.cpp     
M  +0    -2    utilities/imageeditor/editor/imagewindow.h     
M  +1    -32   utilities/lighttable/lighttablewindow.cpp     
M  +0    -3    utilities/lighttable/lighttablewindow.h     
M  +0    -3    utilities/lighttable/lighttablewindow_p.h     
M  +1    -32   utilities/queuemanager/main/queuemgrwindow.cpp     
M  +0    -3    utilities/queuemanager/main/queuemgrwindow.h     
M  +0    -3    utilities/queuemanager/main/queuemgrwindow_p.h     

http://commits.kde.org/digikam/e55f3d748f461f2f1ac956995d644de658200a4a
Comment 5 caulier.gilles 2016-05-30 18:57:13 UTC
Git commit 4837b2773846c7c32e947d3b1b8b706275731b95 by Gilles Caulier.
Committed on 30/05/2016 at 18:54.
Pushed by cgilles into branch 'master'.

Dispatch colors theme properly to widget style manager for main windows
Related: bug 172632, bug 146938, bug 265554, bug 240148, bug 252700, bug 168669, bug 179898, bug 220068
FIXED-IN: 5.0.0

M  +2    -1    libs/widgets/mainview/thememanager.cpp

http://commits.kde.org/digikam/4837b2773846c7c32e947d3b1b8b706275731b95