Bug 264485 - brightness OSD shows up on automatic brightness changes
Summary: brightness OSD shows up on automatic brightness changes
Status: RESOLVED DUPLICATE of bug 325643
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: powermanagement-kcm (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-27 14:57 UTC by Piotr Keplicz
Modified: 2013-11-17 15:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.2
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Keplicz 2011-01-27 14:57:47 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

After an upgrade to KDE 4.6.0 LCD brightness OSD slider shows up every time brightness changes, even after automatically generated events. It should pop only when a user changes brightness using powermanagement widget slider or hardware buttons.

Reproducible: Always

Steps to Reproduce:
1. Wait without touching mouse or keyboard until LCD dims automatically (after a time defined in the current power management profile).
2. Move a mouse or press any key to restore default LCD brightness.

Actual Results:  
Brightness OSD shows up.

Expected Results:  
Brightness OSD doesn't show up as the display was only temporarily dimmed.

In previous KDE versions (notably 4.5.x) this OSD never showed up on automatic brightness changes.
Comment 1 Dario Freddi 2011-01-29 14:15:14 UTC
You are right, accepting the bug
Comment 2 Frans Leerink 2011-04-17 00:09:47 UTC
Hello,

Laptop with openSUSE11.4 / KDE final.
In power mgt profile setting I have reduced display brightness.
The system allways asks for root password if it awake from sleep, since it want to
increase display brightness.
Is this related to this bug.

Regards, Frans
Comment 3 Dario Freddi 2011-09-30 19:05:48 UTC
Git commit 2cefe7543c4d5d4d26659e4d6b86b4d61b4b1b69 by Dario Freddi.
Committed on 30/09/2011 at 21:04.
Pushed by dafre into branch 'master'.

Move handling of the OSD widget from the applet to the daemon. This also allow us to control it properly

BUG: 264485

M  +1    -2    plasma/generic/applets/battery/CMakeLists.txt
M  +2    -29   plasma/generic/applets/battery/battery.cpp
M  +0    -4    plasma/generic/applets/battery/battery.h
M  +3    -0    powerdevil/daemon/CMakeLists.txt
M  +39   -1    powerdevil/daemon/actions/bundled/brightnesscontrol.cpp
M  +6    -0    powerdevil/daemon/actions/bundled/brightnesscontrol.h
R  +0    -0    powerdevil/daemon/brightnessosdwidget.cpp [from: plasma/generic/applets/battery/brightnessosdwidget.cpp - 100% similarity]
R  +0    -0    powerdevil/daemon/brightnessosdwidget.h [from: plasma/generic/applets/battery/brightnessosdwidget.h - 100% similarity]

http://commits.kde.org/kde-workspace/2cefe7543c4d5d4d26659e4d6b86b4d61b4b1b69
Comment 4 Dario Freddi 2011-09-30 19:06:39 UTC
Git commit 31cfdf029a58f51b183b7063acb7d233086bb489 by Dario Freddi.
Committed on 30/09/2011 at 21:04.
Pushed by dafre into branch 'KDE/4.7'.

Move handling of the OSD widget from the applet to the daemon. This also allow us to control it properly

BUG: 264485
FIXED-IN: 4.7.2

M  +1    -2    plasma/generic/applets/battery/CMakeLists.txt
M  +2    -29   plasma/generic/applets/battery/battery.cpp
M  +0    -4    plasma/generic/applets/battery/battery.h
M  +3    -0    powerdevil/daemon/CMakeLists.txt
M  +39   -1    powerdevil/daemon/actions/bundled/brightnesscontrol.cpp
M  +6    -0    powerdevil/daemon/actions/bundled/brightnesscontrol.h
R  +0    -0    powerdevil/daemon/brightnessosdwidget.cpp [from: plasma/generic/applets/battery/brightnessosdwidget.cpp - 100% similarity]
R  +0    -0    powerdevil/daemon/brightnessosdwidget.h [from: plasma/generic/applets/battery/brightnessosdwidget.h - 100% similarity]

http://commits.kde.org/kde-workspace/31cfdf029a58f51b183b7063acb7d233086bb489
Comment 5 Danilo Luvizotto 2013-04-07 07:13:48 UTC
This is behavior in KDE 4.10.
Comment 6 Vitalii 2013-10-30 11:05:47 UTC
Also same in KDE 4.11
Comment 7 Christoph Feck 2013-11-17 15:41:53 UTC
It was once fixed, but the bug reappeared. It is now tracked at bug 325643.
Comment 8 Christoph Feck 2013-11-17 15:43:26 UTC

*** This bug has been marked as a duplicate of bug 325643 ***