Bug 262062 - Plasma crashes when clicking update notification on fresh install
Summary: Plasma crashes when clicking update notification on fresh install
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-04 12:35 UTC by cdc204
Modified: 2011-01-29 14:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.22 KB, text/plain)
2011-01-29 14:24 UTC, chiro79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cdc204 2011-01-04 12:35:54 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Totally fresh install of Kubuntu 10.10 on Dell Inspiron 1545, no settings changed except wireless just set up. Update notification came up for the first time and tooltip suggested it was doing the equivalent of apt-get update. Clicked on the icon in the tray and plasma crashed. When it came back up the icon had changed to the "x packages need updating" version (I wonder if I clicked right on the change, when it had finished updating package lists but not yet announced updates) and when I clicked on it this time there was no crash.

The crash does not seem to be reproducible.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7829720 (LWP 1591))]

Thread 2 (Thread 0xae9b9b70 (LWP 1596)):
#0  0x072d8e36 in clock_gettime () from /lib/librt.so.1
#1  0x01efb50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x01fd26e5 in QTimerInfoList::updateCurrentTime (this=0xa791f64) at kernel/qeventdispatcher_unix.cpp:339
#4  0x01fd272a in QTimerInfoList::timerWait (this=0xa791f64, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x01fd07a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae9b90ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x01fd083d in timerSourcePrepare (source=0x0, timeout=0x72dcff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x04525e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x04526279 in ?? () from /lib/libglib-2.0.so.0
#9  0x04526848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x01fd059f in QEventDispatcherGlib::processEvents (this=0xa7904f0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x01fa0609 in QEventLoop::processEvents (this=0xae9b9280, flags=) at kernel/qeventloop.cpp:149
#12 0x01fa0a8a in QEventLoop::exec (this=0xae9b9280, flags=...) at kernel/qeventloop.cpp:201
#13 0x01e9cb7e in QThread::exec (this=0xa791a38) at thread/qthread.cpp:490
#14 0x01f7f35b in QInotifyFileSystemWatcherEngine::run (this=0xa791a38) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x01e9fdf9 in QThreadPrivate::start (arg=0xa791a38) at thread/qthread_unix.cpp:266
#16 0x00564cc9 in start_thread () from /lib/libpthread.so.0
#17 0x002426ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7829720 (LWP 1591)):
[KCrash Handler]
#7  0x04e883aa in KJob::isAutoDelete (this=0xaf05dd0) at ../../kdecore/jobs/kjob.cpp:353
#8  0x00a845a7 in Plasma::ServiceJob::setResult (this=0xaf05dd0, result=...) at ../../plasma/servicejob.cpp:80
#9  0x060c9d6d in StatusNotifierItemJob::contextMenuReady (this=0xaf05dd0, menu=0xb4a6760) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0x060c9ded in StatusNotifierItemJob::qt_metacall (this=0xaf05dd0, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfebd818) at ./statusnotifieritemjob.moc:75
#11 0x01fa78ca in QMetaObject::metacall (object=0xaf05dd0, cl=34429368, idx=27, argv=0xbfebd818) at kernel/qmetaobject.cpp:237
#12 0x01fba6ad in QMetaObject::activate (sender=0xb04c628, m=0x60d0c40, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#13 0x060c30a3 in StatusNotifierItemSource::contextMenuReady (this=0xb04c628, _t1=0xb4a6760) at ./statusnotifieritemsource.moc:109
#14 0x060c32b1 in StatusNotifierItemSource::contextMenuReady (this=0xb04c628) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#15 0x060c8803 in StatusNotifierItemSource::qt_metacall (this=0xb04c628, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfebd93c) at ./statusnotifieritemsource.moc:90
#16 0x01fa78ca in QMetaObject::metacall (object=0xb04c628, cl=34429368, idx=11, argv=0xbfebd93c) at kernel/qmetaobject.cpp:237
#17 0x01fba6ad in QMetaObject::activate (sender=0xb4c2fd8, m=0x3455d84, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#18 0x03440567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#19 0x03445cdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#20 0x03446f2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#21 0x01fa78ca in QMetaObject::metacall (object=0xb4c2fd8, cl=34429368, idx=12, argv=0xbfebdb7c) at kernel/qmetaobject.cpp:237
#22 0x01fba6ad in QMetaObject::activate (sender=0xb4a6760, m=0x1b23fe8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#23 0x01662ee7 in QMenu::aboutToShow (this=0xb4a6760) at .moc/release-shared/moc_qmenu.cpp:151
#24 0x0166a193 in QMenu::qt_metacall (this=0xb4a6760, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfebdccc) at .moc/release-shared/moc_qmenu.cpp:97
#25 0x01fa78ca in QMetaObject::metacall (object=0xb4a6760, cl=34429368, idx=27, argv=0xbfebdccc) at kernel/qmetaobject.cpp:237
#26 0x01fab352 in QMetaMethod::invoke (this=0xbfebde5c, object=0xb4a6760, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#27 0x01faca1f in QMetaObject::invokeMethod (obj=0xb4a6760, member=0x344c3e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#28 0x0344093e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#29 0x060c46ef in StatusNotifierItemSource::contextMenu (this=0xb04c628, x=1124, y=750) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#30 0x060cb33e in StatusNotifierItemJob::start (this=0xaf05dd0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#31 0x00a84423 in Plasma::ServiceJobPrivate::slotStart (this=0xb1831c8) at ../../plasma/servicejob.cpp:37
#32 0x00a844f4 in Plasma::ServiceJob::qt_metacall (this=0xaf05dd0, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xb38f8b8) at ./servicejob.moc:72
#33 0x060c9dca in StatusNotifierItemJob::qt_metacall (this=0xaf05dd0, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0xb38f8b8) at ./statusnotifieritemjob.moc:70
#34 0x01fa78ca in QMetaObject::metacall (object=0xaf05dd0, cl=34429368, idx=26, argv=0xb38f8b8) at kernel/qmetaobject.cpp:237
#35 0x01fb2df6 in QMetaCallEvent::placeMetaCall (this=0xb33d3f8, object=0xaf05dd0) at kernel/qobject.cpp:534
#36 0x01fb46a2 in QObject::event (this=0xaf05dd0, e=0x9fe1960) at kernel/qobject.cpp:1219
#37 0x0119efdc in QApplicationPrivate::notify_helper (this=0x9fbbb18, receiver=0xaf05dd0, e=0xb33d3f8) at kernel/qapplication.cpp:4396
#38 0x011a504e in QApplication::notify (this=0x9fb1850, receiver=0xaf05dd0, e=0xb33d3f8) at kernel/qapplication.cpp:3798
#39 0x00e9468a in KApplication::notify (this=0x9fb1850, receiver=0xaf05dd0, event=0xb33d3f8) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x01fa1b3b in QCoreApplication::notifyInternal (this=0x9fb1850, receiver=0xaf05dd0, event=0xb33d3f8) at kernel/qcoreapplication.cpp:732
#41 0x01fa4d8b in sendEvent (receiver=0x0, event_type=0, data=0x9f9b028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9f9b028) at kernel/qcoreapplication.cpp:1373
#43 0x01fa4f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#44 0x01fd0a74 in sendPostedEvents (s=0x9fbdf10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x9fbdf10) at kernel/qeventdispatcher_glib.cpp:277
#46 0x04522855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x04526668 in ?? () from /lib/libglib-2.0.so.0
#48 0x04526848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x01fd0565 in QEventDispatcherGlib::processEvents (this=0x9f9ace8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#50 0x01260be5 in QGuiEventDispatcherGlib::processEvents (this=0x9f9ace8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x01fa0609 in QEventLoop::processEvents (this=0xbfebec34, flags=) at kernel/qeventloop.cpp:149
#52 0x01fa0a8a in QEventLoop::exec (this=0xbfebec34, flags=...) at kernel/qeventloop.cpp:201
#53 0x01fa500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#54 0x0119de07 in QApplication::exec () at kernel/qapplication.cpp:3672
#55 0x0064186e in kdemain (argc=1, argv=0xbfebee44) at ../../../../plasma/desktop/shell/main.cpp:118
#56 0x080485bb in main (argc=1, argv=0xbfebee44) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 241562.

Possible duplicates by query: bug 260710, bug 259530, bug 258612, bug 258303, bug 257791.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-01-05 00:53:14 UTC

*** This bug has been marked as a duplicate of bug 241562 ***
Comment 2 chiro79 2011-01-29 14:24:10 UTC
Created attachment 56616 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:

I was clicking on update button on the dock.

-- Backtrace (Reduced):
#7  0xb6a9e3aa in KJob::isAutoDelete (this=0x92b3a48) at ../../kdecore/jobs/kjob.cpp:353
#8  0xb75c85a7 in Plasma::ServiceJob::setResult (this=0x92b3a48, result=...) at ../../plasma/servicejob.cpp:80
#9  0xa9f89d6d in StatusNotifierItemJob::contextMenuReady (this=0x92b3a48, menu=0x9a69b10) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#10 0xa9f89ded in StatusNotifierItemJob::qt_metacall (this=0x92b3a48, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfa89968) at ./statusnotifieritemjob.moc:75
[...]
[...]
#13 0xa9f830a3 in StatusNotifierItemSource::contextMenuReady (this=0x9cfb3a8, _t1=0x9a69b10) at ./statusnotifieritemsource.moc:109