Bug 263463 - 'Scan for new images' should work on just current folder
Summary: 'Scan for new images' should work on just current folder
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Database-Scan (show other bugs)
Version: 1.4.0
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-17 20:17 UTC by Obi-Wan
Modified: 2022-01-24 16:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Obi-Wan 2011-01-17 20:17:36 UTC
Version:           1.4.0 (using KDE 4.5.1) 
OS:                Linux

My photo library contains over 100,000 photos spread through over 1000 directories.  I frequently edit images in a different package while digikam is open, and before I can use the new images in digikam, I must either wait for digikam to recognize the updated version, or I must scan for new images.  Performing either of these operations on my entire collection takes forever.

It would be really great if there were options for this tool to operate
on just the current folder, which is generally all I really need to have done. 
This would dramatically improve the time required to manage my photos!

This feature was requested as part of bug 262720, but was not implemented as part of the solution to 262720.  Of the two features requested in 262720, this one would be by far the more beneficial to my workflow.

Reproducible: Always

Steps to Reproduce:
Scan a large collection for new images.

Actual Results:  
Go fix a cup of coffee.  When I return, the operation is done.

Expected Results:  
Stand up and stretch.  When I sit down, the operation is done.
Comment 1 Martin Klapetek 2011-01-17 20:25:57 UTC
Well I thought to file a bug report about digiKam not recognizing the changes immediately, not duplicating the same wish...sigh. Anyway, since it's here, would it help to improve the collection scanner to immediatelly recognize changes in files, if it doesn't already?

Gilles, Marcel?
Comment 2 Obi-Wan 2011-01-17 20:29:47 UTC
Detecting new images within a matter of seconds would certainly be acceptable.  As mentioned in the other bug, I sometimes have waited many minutes for it to detect a new image before giving up and rescanning my entire collection.
Comment 3 Marcel Wiesweg 2011-01-18 00:30:36 UTC
F5 triggers a rescan of the current album.

For automatic change detection, we rely on
a) KDirWatch for file detection on operating system level.
There have been undocumented changes in the way the API is supposed to be used between KDE versions, it's sometimes a problem. I've also seen problems here and there
b) KIO notification, if any files are copied or moved by KDE technologies. Within this scope, this works reliable afaik
Comment 4 Obi-Wan 2011-01-18 00:53:39 UTC
No, F5 does not trigger a scan for new files.  At least not in 1.4.0, which is what I've got installed.  That was suggested in the previous bug report, too.  F5 does a "refresh," which is something different.

I don't use KDE as a general environment, but I do use a few KDE apps.  The photo editing software I'm most frequently using concurrently with digikam is LightZone, a commercial package that pays homage to no specific windowing environment.  However, I've noticed the same failure to recognize new files in a reasonable amount of time even when creating them from the shell with the PBM toolkit.
Comment 5 caulier.gilles 2011-12-15 09:49:49 UTC

*** This bug has been marked as a duplicate of bug 262720 ***
Comment 6 caulier.gilles 2022-01-24 16:14:27 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=262720