Bug 262720 - SCAN : 'scan for new images' should work on just current Album
Summary: SCAN : 'scan for new images' should work on just current Album
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 1.4.0
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-10 02:50 UTC by Obi-Wan
Modified: 2017-07-25 10:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Obi-Wan 2011-01-10 02:50:28 UTC
Version:           1.4.0 (using KDE 4.5.1) 
OS:                Linux

My photo library contains over 100,000 photos spread through over 1000 directories.  I frequently edit images in a different package while digikam is open, and before I can use the new images in digikam, I must either wait for digikam to recognize the updated version, or I must scan for new images or update the thumbnails (depending on what I just did).  Performing either of these operations on my entire collection takes forever.

It would be really great if there were options for these two tools to operate on just the current folder, which is generally all I really need to have done.  This would dramatically improve the time required to manage my photos!

Reproducible: Always

Steps to Reproduce:
Scan a large collection for new images, or rebuild thumbnails.

Actual Results:  
Go out to eat.  When I return, the operation is done.

Expected Results:  
Stand up and stretch.  When I sit down, the operation is done.
Comment 1 caulier.gilles 2011-01-10 07:14:14 UTC
Please, try with last 1.7.0 release...

Gilles Caulier
Comment 2 Obi-Wan 2011-01-10 17:16:58 UTC
Is this feature known to be added to the 1.7.0 release, or are you merely curious?  Ubuntu 10.10 ships with 1.4.0 by default.  I'd rather not deviate from the default packages unless I know it'll fix my problem?
Comment 3 Martin Klapetek 2011-01-10 17:46:17 UTC
Actually, no. I've stumbled just on that same problem today with the 2.0 branch. Would be great to have this feature and shouldn't be that hard to implement. I'll check when I get home.
Comment 4 caulier.gilles 2011-01-10 18:08:20 UTC
To rebuild thumbs from current album, just press F5... no ?

Gilles Caulier
Comment 5 Obi-Wan 2011-01-10 18:13:10 UTC
F5 does a "refresh" (whatever that is), but it neither scans for new images nor rebuilds thumbnails.
Comment 6 Martin Klapetek 2011-01-17 14:16:29 UTC
SVN commit 1215067 by mklapetek:

Initial support for rebuilding thumbnails only in current album

CCBUG:262720

 M  +14 -1     digikam/digikamapp.cpp  
 M  +1 -0      digikam/digikamapp.h  
 M  +2 -0      digikam/digikamapp_p.h  
 M  +2 -1      digikam/digikamui.rc  
 M  +31 -1     utilities/batch/batchthumbsgenerator.cpp  
 M  +1 -0      utilities/batch/batchthumbsgenerator.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1215067
Comment 7 Martin Klapetek 2011-01-17 19:02:05 UTC
SVN commit 1215117 by mklapetek:

Add a context-menu entry to album folders sidebar for rebuilding images in selected album

FEATURE:262720

 M  +11 -1     albumselectiontreeview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1215117
Comment 8 caulier.gilles 2011-01-17 19:04:06 UTC
Martin,

Can this feature can be backported to trunk easily, or do you prefer to let's it in GoSC 2010 branch for the moment ?

Gilles Caulier
Comment 9 Martin Klapetek 2011-01-17 19:06:23 UTC
I believe it could be backported, these aren't big changes and these parts should be mostly the same as the trunk. I'll try to apply the patch and commit to trunk if there will be no problems.
Comment 10 Obi-Wan 2011-01-17 19:08:58 UTC
Can similar per-album functionality be added to the "scan for new images" operation?  I actually need that worse than the "rebuild thumbnails" operation, although both will come in handy.
Comment 11 Martin Klapetek 2011-01-17 19:16:13 UTC
Probably, but I find it quite useless - scan for new images is done on every digiKam start and it should also dynamically detect new images and add them to your collections. If this does not work, please file a separate bug report. I'm closing this wish now as the rebuild thumbs feature has been implemented.
Comment 12 Obi-Wan 2011-01-17 20:21:44 UTC
So you're suggesting that I close and restart digikam every time I use some other application to add an image to an album?  Dynamic detection happens only every so often, and I sometimes have waited many minutes for it to detect a new image before giving up and rescanning my entire collection.

This feature has been re-requested in bug 263463.
Comment 13 caulier.gilles 2011-01-17 20:39:09 UTC
No. digiKam use KDirWatch API from KDELibs. If something changes, digiKam database will be triggered and changes must be registered in metadata.


Gilles Caulier
Comment 14 caulier.gilles 2011-12-15 09:32:42 UTC
Obi,

This file still valid using digiKam 2.x serie ?

Gilles Caulier
Comment 15 caulier.gilles 2011-12-15 09:49:49 UTC
*** Bug 263463 has been marked as a duplicate of this bug. ***
Comment 16 caulier.gilles 2014-08-07 12:12:21 UTC
Git commit ff3578174a8bbcb0121d56cd2eccaca29ed0a8f2 by Gilles Caulier.
Committed on 07/08/2014 at 12:08.
Pushed by cgilles into branch 'master'.

Remove dupplicate action to Rebuild thumbs.
Refresh current album action now rebuild thumbs and scan for new items in current album.
FIXED-IN: 4.3.0

M  +12   -2    digikam/album/albumselectiontreeview.cpp
M  +1    -23   digikam/main/digikamapp.cpp
M  +1    -2    digikam/main/digikamapp.h
M  +0    -2    digikam/main/digikamapp_p.h
M  +2    -3    digikam/main/digikamui.rc
M  +23   -7    digikam/views/digikamview.cpp
M  +10   -7    digikam/views/digikamview.h
M  +4    -3    utilities/maintenance/newitemsfinder.cpp
M  +6    -5    utilities/maintenance/newitemsfinder.h

http://commits.kde.org/digikam/ff3578174a8bbcb0121d56cd2eccaca29ed0a8f2