Bug 262732 - plasmoid "news" display nothing after boot.
Summary: plasmoid "news" display nothing after boot.
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Network Management
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-10 09:23 UTC by jajaX
Modified: 2018-09-04 16:22 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
a screen of plasma containment-desktop "news" after boot (12.86 KB, image/jpeg)
2011-01-10 10:27 UTC, jajaX
Details
widget "news" after login (4.29 KB, image/jpeg)
2011-12-21 12:22 UTC, jajaX
Details
widget "rssnow" after login (8.56 KB, image/jpeg)
2011-12-21 12:23 UTC, jajaX
Details
Create log.txt file (553 bytes, application/x-shellscript)
2012-01-03 04:40 UTC, Lamarque V. Souza
Details
log files (451 bytes, text/plain)
2012-01-03 08:34 UTC, jajaX
Details
log file frome 4.8 rc2 (470 bytes, text/plain)
2012-01-09 18:08 UTC, jajaX
Details
xessions-error from 4.8 rc2 zipped (403.87 KB, application/zip)
2012-01-09 18:13 UTC, jajaX
Details
log file after 2 hours (472 bytes, text/plain)
2012-01-09 21:39 UTC, jajaX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jajaX 2011-01-10 09:23:20 UTC
Version:           unspecified (using KDE 4.5.95) 
OS:                Linux

Hi (sorry for my bad english !)

I have got this problem since long time.

after boot, internet connection online, plasma containment-desktop "news" display nothing. I can see the message the rss are recovered but I see nothing. but I have got no text in plasma containment-desktop.
I must increase (or reduce) time delay for the rss's flux.

No problem with "rssnow".

Reproducible: Always

Steps to Reproduce:
plasma containment-desktop "news" with 4 rss's flux.
boot on kde with "news" on the desktop.



OS: Linux (i686) release 2.6.35-24-generic
Compiler: cc
kubuntu 10.10 (32 bit) with KDE SC 4.6 RC2.
Comment 1 jajaX 2011-01-10 10:27:08 UTC
Created attachment 55815 [details]
a screen of plasma containment-desktop "news" after boot

translation :

recovery of the incoming stream has failed
Comment 2 Marco Martin 2011-01-10 12:46:52 UTC
editing title to be more understandable of what actually is about: the news plasmoid
Comment 3 jajaX 2011-01-10 16:28:37 UTC
done ;)
Comment 4 Anne-Marie Mahfouf 2011-12-20 14:09:34 UTC
Do you reproduce this ona more recent KDE version such as 4.7.x? Thanks in advance
Comment 5 jajaX 2011-12-21 12:21:19 UTC
Hi !

problem is back under kubuntu 11.10 and KDE SC 4.7.4 (from ppa)

see attachments
Comment 6 jajaX 2011-12-21 12:22:29 UTC
Created attachment 66972 [details]
widget "news" after login
Comment 7 jajaX 2011-12-21 12:23:04 UTC
Created attachment 66973 [details]
widget "rssnow" after login
Comment 8 Anne-Marie Mahfouf 2011-12-21 13:05:15 UTC
What do you mean "after login"?
The applets show nothing whatever the time you leave them on the desktop? After 30 minutes?

Those applets are coded to ping the internet at the refresh time that is set (30 minutes as default, you can change this in Settings). The assessment on whether there is an internet connection or not is done by the Solid library. So I would assume that Solid fails in your case.

Please answer the question above about the 30 minutes and we'll then investigate further. If you could come to IRC, freenode network and #plasma channel that would help to find the problem more quickly, thanks.
Comment 9 jajaX 2011-12-27 21:52:08 UTC
after 30 mn, it's ok.
Comment 10 Anne-Marie Mahfouf 2011-12-29 15:22:51 UTC
There is nothing to do about this bug: it's about NetworkManager and backends and I experiment this bug as well. I spent 2 hours trying to see what exactly happens with the Solid and NetworkManager applet developer. The code in the applets is correct, there is nothing that can be improved.
Comment 11 Lamarque V. Souza 2011-12-29 19:19:55 UTC
There are a lot of things that could lead to this problem and since I cannot reproduce this problem I need to ask several questions to have a clue on where the problem may be.

Annma, after our talk I did some tests with NetworkManager and Wicd and the Solid::Networking::notifier()'s statusChanged signal is emited by both as long as kded4 does not restarts during an open KDE session or you do not change the backend (NetworkManager, Wicd, etc).

When the networkstatus module finds a backend (NetworkManager or Wicd) it listens only for that backend appear/disappear status. If you change the backend you need to restart kded4, which is easier done by logging out and in. I have also noticed that just restarting kde4 causes another problem: the networkstatus module works but Solid::Networking::notifier() does not. Logging out and in re-establishes the connection between Solid::Networking::notifier() and the networkstatus module. That is another problem that needs to solved, but I am not sure if that is the problem jajaX has.

When this problem happen can you check if kded4 have restarted? You can check that by using the ps command:

[lamarque@evolucao ~]$ ps auxw | grep kded4
lamarque 21459  0.0  0.9 534712 36964 ?        Sl   16:23   0:01 kded4

if it has not restarted there will be no '--nocrashhandler' parameter, like in the line above. When it restarts the line above will change to something like this:

lamarque 27591 11.4  0.8 506096 32716 ?        Sl   17:08   0:00 /usr/bin/kded4 --nocrashhandler

Since jajaX has not mentioned any drkonq dialog, probably kded4 is not restarting, but I want to make sure of that. Just notice that kde4 shows a crash dialog only on the first crash, after that it will show no more dialog because of the '--nocrashhandler' parameter I mentioned earlier.

I also need to know network backend jajaX's computer uses: NetworkManager (version too), Wicd, or any other.
Comment 12 Lamarque V. Souza 2011-12-29 21:41:21 UTC
Git commit cb5f5b9188a50bd7ebcb8276d6b4ca473c8929d4 by Lamarque V. Souza.
Committed on 29/12/2011 at 22:34.
Pushed by lvsouza into branch 'KDE/4.8'.

Re-establishes connection with networkstatus module when kded restarts.
The OrgKdeSolidNetworkingClientInterface object becomes invalid when
kded exits and should be recreated on every kded restart.

M  +11   -8    solid/solid/networking.cpp

http://commits.kde.org/kdelibs/cb5f5b9188a50bd7ebcb8276d6b4ca473c8929d4
Comment 13 jajaX 2012-01-02 16:50:42 UTC
hi !

first, happy new year ;)

and, sorry for my bad english !

for my problem.

I try to explain it better.

I use somes widgets on my kde desktop :

- cwp
- rssnow
- news

after kde start =>

- "cwp" display information in this memory cache and refresh then after few seconds. informations reload after my time settings very vell.

- "rssnow" make same thing since kde sc 4.7.0 or 4.7.1, but the problem come back : it display nothing after kde start ans refresh information just after 30 mn.

- "news", it's same thing for this widget. kde sc starts. "news" display nothing or only the message to the top (in french for me) "4 flux rss reçus" (4 received flows rss). refresh only after 30 mn too.
Comment 14 jajaX 2012-01-02 16:51:44 UTC
I forget to says :

Now, I test KDE SC 4.8 RC1 and same problem.
Comment 15 Lamarque V. Souza 2012-01-03 04:40:01 UTC
Created attachment 67368 [details]
Create log.txt file

Both "news" and "rssnow" plasmoids uses the rss dataengine, it is not by accident they share the same symptoms.

I need the information I requested in my last post: the output of the command 'ps auxw | grep kded4' and which backend you use (NetworkManager, Wicd, etc).

Please, download the attached script, launch the konsole porgram, give execution permission to the script (chmod 755 test.sh), and execute it in konsole. Keep the script running for 30 minutes until the "rss" plasmoid updates. Then closes the script and send me file log.txt that the script will create.
Comment 16 jajaX 2012-01-03 08:34:06 UTC
Created attachment 67371 [details]
log files
Comment 17 jajaX 2012-01-03 08:34:23 UTC
done !
Comment 18 Lamarque V. Souza 2012-01-03 17:14:08 UTC
Hmmm nothing new here. Let's try another thing: execute the script again, then disconnect your network, then re-connect your network, close the script and send me the log.txt and the ~/.xsession-errors. I need both files.
Comment 19 jajaX 2012-01-09 17:55:19 UTC
hi ! 

log.txt and ".xsession-errors" from KDE SC 4.8 .RC2

rssnow works after startup, not "news".
Comment 20 Lamarque V. Souza 2012-01-09 18:07:07 UTC
I think you forgot to attach the logs.
Comment 21 jajaX 2012-01-09 18:08:37 UTC
Created attachment 67623 [details]
log file frome 4.8 rc2
Comment 22 jajaX 2012-01-09 18:11:49 UTC
I can't send xessions-error because it's too big :(
Comment 23 jajaX 2012-01-09 18:13:20 UTC
Created attachment 67624 [details]
xessions-error from 4.8 rc2 zipped
Comment 24 jajaX 2012-01-09 18:13:40 UTC
it's ok now sorry ;)
Comment 25 Lamarque V. Souza 2012-01-09 18:36:32 UTC
Curious, although log.txt does show a statusChaged signal what happens in .xsession-errors indicates the rssnow plasmoid received the signal and tried to reload the feeds.

I think the tentative fix for bug #273342 I commited some hours ago can help here too. #273342 is about the Comic plasmoid, but all Comic plasmoid, Rssnow and News  uses KIO to download date. Right after the networkstatus module send the "Connected" signal KIO is not able to downloading date showing a message "not connected". I added a delay of 2 seconds in the statusChanged signal, that was enough to fix the problem here, let's hope it is enough for everybody.

The fix is going to be in KDE SC 4.8.0 final, you can wait until there to try it  or recompile kde-runtime yourself.
Comment 26 jajaX 2012-01-09 21:39:15 UTC
yes,sorry I launch test.sh only 2 mn...

new log.txt file after 2 hours to launch

(sorry again for my bad english)
Comment 27 jajaX 2012-01-09 21:39:49 UTC
Created attachment 67627 [details]
log file after 2 hours
Comment 28 Lamarque V. Souza 2012-01-09 21:51:23 UTC
(In reply to comment #26)
> yes,sorry I launch test.sh only 2 mn...
> 
> new log.txt file after 2 hours to launch

Same result. There must be something preventing the script from getting the signal, but it seems it is indeed being received.
 
> (sorry again for my bad english)

No problem, I can understand you quite well :-)
Comment 29 Sebastian Trueg 2012-01-27 13:20:48 UTC
Git commit e95f3be9062f98263e35329ec2ed87b27933d2e9 by Sebastian Trueg, on behalf of Lamarque V. Souza.
Committed on 29/12/2011 at 22:34.
Pushed by trueg into branch 'KDE/4.8'.

Re-establishes connection with networkstatus module when kded restarts.
The OrgKdeSolidNetworkingClientInterface object becomes invalid when
kded exits and should be recreated on every kded restart.

M  +11   -8    solid/solid/networking.cpp

http://commits.kde.org/kdelibs/e95f3be9062f98263e35329ec2ed87b27933d2e9
Comment 30 Lamarque V. Souza 2012-02-04 02:23:25 UTC
Is this problem still happening with KDE SC 4.8.0?
Comment 31 jajaX 2012-02-04 13:52:13 UTC
yes, the problem is the same.

I must always refresh manualy after kde sc starts.
Comment 32 Andrew Crouthamel 2018-09-04 16:22:44 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years and I will be closing this bug. Please test again with the latest version and file a new bug in plasma-nm. Thank you!