Bug 262562 - tags should be assigned in a textbox, not with a menu
Summary: tags should be assigned in a textbox, not with a menu
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Usability-Menus (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-08 19:02 UTC by Alex
Modified: 2019-08-13 16:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2011-01-08 19:02:59 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

if i want to assign a tag to an image, i get a menu, which is bigger than my two monitors and still not displaying all available tags from my large image database.

Reproducible: Always

Steps to Reproduce:
1) import many images with tags
2) try to assign a tag to an image
3) get a huge menu, not even displaying all tags

optional:
4) try to assing three tags. you will need to open the menu three times, searching the correct tags

Actual Results:  
huge menus, many clicks

Expected Results:  
a simple textbox, where i can enter tags seperated by comma
Comment 1 caulier.gilles 2011-01-08 20:04:23 UTC

*** This bug has been marked as a duplicate of bug 182664 ***
Comment 2 caulier.gilles 2019-08-13 12:01:00 UTC
Fixed with bug #182664
Comment 3 Alex 2019-08-13 15:53:49 UTC
> Fixed with bug #182664
Looking at the screenshots linked in bug #182664, the main issue (having a flat tag input field) is not fixed, yet.

The resolution of bug #182664 seems to be, that only recent tags and a "add new tag" button is shown. But for adding many tags, this is tedious.

I would really prefer as UI like for example the firefox bookmark dialog, in which you just enter a comma separated list of tags.

Some hybrid option (e.g. converting the typed tag into an ui element after hitting comma like some websites manage adding tags) would be okay as well. But adding five tags should not make it necessary to open a "new tag" dialog five times.
Comment 4 caulier.gilles 2019-08-13 16:22:47 UTC
"I would really prefer as UI like for example the firefox bookmark dialog, in
which you just enter a comma separated list of tags."

This way is already implemented. On top of tags tree-view, there is a text field where you can enter the list of tags to use for the current item selection.

https://imgur.com/3oJXlV9

For ex : "/Travel,/Travel/City,/Travel/City/Paris,/Travel/City/London"
Each tags listed here will be applied to items. If tags do not exist, there are automatically created in database.

Gilles Caulier
Comment 5 Alex 2019-08-13 16:25:21 UTC
Okay, when this works now like this, its fine.

I think there was another bug for this when using dolphin and tagging things for nepomuk, what had a complicated ui, maybe I am mixing this up a bit.

Now I am looking forward to the next release :-).