Bug 182664 - tag menu its bigger than screen
Summary: tag menu its bigger than screen
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Menus (show other bugs)
Version: 0.9.5
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-01 04:43 UTC by Ricardson Williams
Modified: 2017-08-02 21:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments
Only show recent assigned tags list to "Assign Tag" context menu entry (3.70 KB, patch)
2011-01-17 15:54 UTC, caulier.gilles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardson Williams 2009-02-01 04:43:38 UTC
Version:            (using KDE 3.5.10)
OS:                Linux
Installed from:    Slackware Packages

I have tag hierarchies when adding tags via the right-click menu(assign tag), Digikam pops the menu and I cannot see all the tags.. also the columm tags its too large. I have more than 200 tags, to solv the problem I have to setup virtual scream to "see" all tags, I use the tag option a lot...
My laptop its setup to 1440x900 and virtual to 1900x900
Comment 1 Ricardson Williams 2009-02-01 04:45:02 UTC
The tag menu cannot fit in the scream.

Comment 2 Ricardson Williams 2009-02-01 04:54:10 UTC
I use Digikam-0.9.5-beta3.
Comment 3 caulier.gilles 2009-07-27 13:20:58 UTC
Richard,

Why do you have closed this file ? It still valid...

Gilles Caulier
Comment 4 Ricardson Williams 2009-07-27 14:15:14 UTC
(In reply to comment #3)
> Richard,
> 
> Why do you have closed this file ? It still valid...
> 
> Gilles Caulier

Because I did'nt use anymore, I use CAPTION/TAGs.
Comment 5 caulier.gilles 2009-07-28 06:41:57 UTC
This file cannot be closed as well.

Problem still exist, and something must be done.

Possible solutions :

- Remove entries from contextual menu (Assign Tags and Remove Tags options). Use Captions & Tags instead.
- For Remove tags option, let's as well because it's generally a short list of tags. For Assign Tags option only show most used tags from Database in menu, and add an option named "More Tags..." to switch on Caption and Tags side bar and give focus to Tags tree view.

Marcel, Andi ?

Gilles Caulier
Comment 6 Ricardson Williams 2009-07-28 08:16:01 UTC
(In reply to comment #5)
> This file cannot be closed as well.
> 
> Problem still exist, and something must be done.
> 
> Possible solutions :
> 
> - Remove entries from contextual menu (Assign Tags and Remove Tags options).
> Use Captions & Tags instead.
> - For Remove tags option, let's as well because it's generally a short list of
> tags. For Assign Tags option only show most used tags from Database in menu,
> and add an option named "More Tags..." to switch on Caption and Tags side bar
> and give focus to Tags tree view.
> 
> Marcel, Andi ?
> 
> Gilles Caulier

Maybe remove the option Assign/Remove Tag and leave the job for CAPTION/TAGs, 
also Assign/Remove Tag option only possible to insert one tag per operation, when I use CAPTION/Tags I can insert multiple tags at a time.
Comment 7 Andi Clemens 2009-07-28 10:48:34 UTC
(In reply to comment #5)
> - For Remove tags option, let's as well because it's generally a short list of
> tags. For Assign Tags option only show most used tags from Database in menu,
> and add an option named "More Tags..." to switch on Caption and Tags side bar
> and give focus to Tags tree view.

In general the idea is good, but what happens if you never used tags before? Will this menu be empty?

Ricardson is right as well, in this menu you can only assign one tag a time, you need to constantly re-open the context menu, if you want to assign more tags.
So I would (in the end) think it is better to remove these context menu entries completely.

I said it before, but I guess we should really take a look at how F-Spot tags images. I like the approach very much, it is super fast, no need to move the mouse and scroll through a big tag list (and maybe even expand tag trees). You just type while viewing the images.
Comment 8 caulier.gilles 2009-07-28 10:52:01 UTC
Andi,

Can you take a screenshot or a small video demo ?

Gilles
Comment 9 Andi Clemens 2009-07-28 11:05:46 UTC
Yes, but not now. I will be away in an hour for the rest of the day, I can take a video in the evening though.
Comment 10 caulier.gilles 2011-01-08 20:04:23 UTC
*** Bug 262562 has been marked as a duplicate of this bug. ***
Comment 11 Alex 2011-01-08 21:30:01 UTC
i would prefer at flat textbox for tags: [tag1,_tag2,_tag3________], where they can be edited inline (best: in gallery view). i think its too complicated to use menus, when you want to tag a large collection of different images. the fewer clicks, the better the solution. how about a list of tags (abbreviated) under the gallery-image, and on click the list is replaces by a textbox with comma seperated tags?
Comment 12 caulier.gilles 2011-01-17 15:54:59 UTC
Created attachment 56127 [details]
Only show recent assigned tags list to "Assign Tag" context menu entry

This patch only show recent assigned tags list to "Assign Tag" context menu entry.

If no recent tags have been assigned, context menu is just with a context message :

http://www.flickr.com/photos/digikam/5363939878/sizes/o/in/photostream/

If there are recent assigned tags, the list is displayed :

http://www.flickr.com/photos/digikam/5363939962/sizes/o/in/photostream/

To compare, this is the current behavior, displaying whole tags list, bloating screen and unsuitable in this case :

http://www.flickr.com/photos/digikam/5363327779/sizes/o/in/photostream/

Gilles Caulier
Comment 13 caulier.gilles 2011-01-18 13:25:16 UTC
SVN commit 1215355 by cgilles:

Into context pop-up menu, "Assign Tag" action will show recently assigned tags list instead the whole tags list which can 
bloat entire screen if tags collection is huge.
A new option named "More Tags" can be used to switch on tags tree view from sidebar and give focus to tags list as well.
BUGS: 182664


 M  +5 -2      digikam/albumwidgetstack.cpp  
 M  +2 -2      digikam/albumwidgetstack.h  
 M  +7 -3      digikam/contextmenuhelper.cpp  
 M  +4 -2      digikam/contextmenuhelper.h  
 M  +5 -3      digikam/digikamimageview.cpp  
 M  +3 -2      digikam/digikamimageview.h  
 M  +6 -3      digikam/digikamview.cpp  
 M  +3 -3      digikam/digikamview.h  
 M  +6 -3      digikam/imagepreviewview.cpp  
 M  +4 -3      digikam/imagepreviewview.h  
 M  +68 -10    digikam/tagspopupmenu.cpp  
 M  +5 -3      digikam/tagspopupmenu.h  
 M  +12 -6     libs/imageproperties/imagedescedittab.cpp  
 M  +4 -3      libs/imageproperties/imagedescedittab.h  
 M  +10 -4     libs/imageproperties/imagepropertiessidebardb.cpp  
 M  +5 -3      libs/imageproperties/imagepropertiessidebardb.h  
 M  +5 -2      utilities/imageeditor/editor/imagewindow.cpp  
 M  +4 -1      utilities/lighttable/lighttablepreview.cpp  
 M  +2 -2      utilities/lighttable/lighttablepreview.h  
 M  +7 -1      utilities/lighttable/lighttableview.cpp  
 M  +4 -1      utilities/lighttable/lighttableview.h  
 M  +7 -1      utilities/lighttable/lighttablewindow.cpp  
 M  +1 -1      utilities/lighttable/lighttablewindow.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1215355