Bug 262271 - Akregator fetched feeds with incorrect content (overlapping with each other) with dates in future.
Summary: Akregator fetched feeds with incorrect content (overlapping with each other) ...
Status: RESOLVED DUPLICATE of bug 256034
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 5.8.3
Platform: Compiled Sources Linux
: NOR major with 60 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-06 04:04 UTC by Chirag Anand
Modified: 2019-04-07 02:03 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Akregator weird timing (82.07 KB, image/png)
2011-01-06 04:04 UTC, Chirag Anand
Details
Akregator dates from a sci-fi! (17.90 KB, image/png)
2014-01-02 15:10 UTC, NMD
Details
screencaps (93.70 KB, image/png)
2016-07-29 17:56 UTC, Patrice Grundmann
Details
Recent akregator date mess (48.66 KB, image/png)
2018-09-10 07:31 UTC, rob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chirag Anand 2011-01-06 04:04:09 UTC
Created attachment 55634 [details]
Akregator weird timing

Version:           1.6.2 (using KDE 4.4.3) 
OS:                Linux

It is probably because of a bad internet connection but it fetched feeds with incorrect content (that too only a few words). The feed dates are in future (year 2028 etc.). 

Reproducible: Didn't try




OS: Linux (i686) release 2.6.35bfs
Compiler: gcc
Comment 1 Frank Osterfeld 2011-03-21 21:56:26 UTC
Do you have an example feed?
Comment 2 NMD 2014-01-02 15:09:44 UTC
I can confirm having a problem with feeds appearing with dates in future - I'll attach a screenshot. I'm not sure what the original submitter meant about incorrect content, though some of the feeds that I have this problem with appear to be blank.  

Could this be a problem with the feeds themselves? In which case Akregator could ignore dates in the future as clearly incorrect?
Comment 3 NMD 2014-01-02 15:10:36 UTC
Created attachment 84414 [details]
Akregator dates from a sci-fi!
Comment 4 Frank Osterfeld 2014-01-02 20:35:29 UTC
Could you provide the feed URL of the feed(s) where you see this?

Also, what do you mean with "feeds appear to be blank"? The single items with the invalid dates, or the whole feed?
Comment 5 NMD 2014-01-03 15:47:52 UTC
I've emailed you the addresses of those feeds. It's particular items from the feed that appear to be blank.
Comment 6 Patrice Grundmann 2016-07-29 17:32:51 UTC
The problem still exist in Akregator Version 5.1.3 !
Comment 7 Patrice Grundmann 2016-07-29 17:56:54 UTC
Created attachment 100376 [details]
screencaps

http://www.agence-csv.com/feed/
Comment 8 jajaX 2016-07-29 23:29:49 UTC
Hi !

same problem for me !

always on kubuntu 14.04 with KDE 4.14.13 !
Comment 9 Rewarp 2017-03-22 05:23:41 UTC
I have feeds being pulled from the year 2106!

http://i.imgur.com/6CGI1VV.png

Here the feed for the podcast The Bugle from which the problem originates, though knowing the host, they will probably find this to be the basis of a pun run.

URL of the episode to confirm that it is indeed, not from the future:

http://bugle.prx.org/2013/12/bugle-253-lenin-in-a-dress/?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+thebuglefeed+%28The+Bugle%29
Comment 10 Angus Mackenzie 2017-05-02 07:22:51 UTC
I can confirm this is present in Debian Unstable - I deleted all future dated entries yesterday and this morning I have 11 dated 07/02/2106 06:28 - these had already been downloaded and read from the Planet Debian feed - Kontact 5.2.3, Plasma 5.8.6.

Coincidentally the last such entry is entitled "Silent Data Corruption Is Real"
Comment 11 Rewarp 2017-07-18 14:58:19 UTC
The problem has gotten much worse for me on openSUSE Tumbleweed.

Nearly half of my feed is now populated by wrongly dated feeds (all dated to 0702/2106 14:38), and they are usually new items.

This would be a minor inconvenience if it were not for the fact every time I am highlighting one of those items it bounces the article to the bottom of the feed of 2106, which means I have to scroll even more to get to the next newest item.

I can back up the feed, so I am okay with just resetting akregator. How do I do so?
Comment 12 Rewarp 2017-08-25 07:52:44 UTC
I noticed another funny behaviour. The wrong dates often appear on new feed items without dates, when akregator is restarted.
Comment 13 Cruz Enrique 2017-10-15 08:59:30 UTC
I can confirm the behaviour explained by #11 and #12. Its start happening after installing kde frameworks and I have not seen it happening with kde4.
Comment 14 rob 2018-09-10 07:24:22 UTC
Same here on stable Gentoo with Metakit archive activated:

Akregator 5.8.3
Plasma 5.12.5
Frameworks 5.46.0
Qt
Comment 16 rob 2018-09-10 07:31:18 UTC
Created attachment 114874 [details]
Recent akregator date mess
Comment 17 Massimiliano 2018-10-22 21:31:18 UTC
The bug is still present in Akregator 5.7.3 on Kubuntu 18.04 + backports repositories.
Comment 18 brazzmonkey 2018-11-07 10:28:21 UTC
Similar date issue here: latest articles are dated 7 feb. 2106.
Kubuntu 18.04 with Kontact 5.7.3
Comment 19 John Scott 2019-04-07 02:03:22 UTC

*** This bug has been marked as a duplicate of bug 256034 ***