Bug 256034 - Feed content is displayed with date 07.02.2106 07:28
Summary: Feed content is displayed with date 07.02.2106 07:28
Status: CONFIRMED
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 5.7.3
Platform: Neon Linux
: NOR normal with 160 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 262271 317344 357281 375448 386699 403428 410396 416780 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-04 11:24 UTC by Janet
Modified: 2020-01-26 13:49 UTC (History)
31 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
example from packman list (153.69 KB, image/png)
2017-09-16 16:08 UTC, Holger
Details
bugged feed (879.51 KB, application/rss+xml)
2018-08-28 16:44 UTC, aeris
Details
Bad date on some entries (42.74 KB, image/png)
2018-08-28 16:45 UTC, aeris
Details
Broken entries after refresh from bugged feed (44.83 KB, image/png)
2018-08-28 16:45 UTC, aeris
Details
attachment-32761-0.html (1.38 KB, text/html)
2019-01-20 20:45 UTC, Ninetto
Details
Invalid date test feed (331 bytes, application/xml)
2019-04-13 09:42 UTC, Patrick
Details
attachment-10021-0.html (1004 bytes, text/html)
2019-07-27 12:27 UTC, Ninetto
Details
bad date 01/01/1970 00:00 (661.72 KB, image/png)
2019-12-30 09:39 UTC, Philippe ROUBACH
Details
no date (675.59 KB, image/png)
2019-12-30 09:40 UTC, Philippe ROUBACH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Janet 2010-11-04 11:24:56 UTC
Version:           1.6.5 (using KDE 4.5.2) 
OS:                Linux

It's now the second time that this happend: I added a new feed and all retrieved content is displayed with the date and time 07.02.2106 07:28.

The first time this happend with last.fm recently played tracks and loved tracks, I added those two feeds about 10 month ago. As I had not used it before also the older tracks were fetched.

This time it happend with wakoopa reviews' feed. Same as for last.fm: as intended older content of 2009 was fetched first. And that content is shown with the mentioned date and time of 2106.

It seems to concern older content, written in 2009 and January 2010. Content written since February 2010 is displayed with the correct date and time. So it seems to affect only feeds that act like a kind of archive, provided something in this archive is in the time frame 2009 - 2010/01 and it's fetched in 2010.



Reproducible: Sometimes




OS: Linux (i686) release 2.6.36-0.slh.3-aptosid-686
Compiler: cc
Comment 1 Christophe Giboudeaux 2010-12-01 14:20:31 UTC
I can't reproduce the issue with the wakoopa feed.

what's the last.fm feed url ?
Comment 2 Christophe Giboudeaux 2010-12-11 00:05:42 UTC
Changing this bug status.Please reopen it whether you see this issue again.
Comment 3 Janet 2011-04-06 15:51:42 UTC
I have re-open this because it has happend again. This time I added my facebook links as feed in akregator. It fetches the lastest entries with the correct date and time, then fetches the older ones that were created weeks and months ago - and those older ones a stored with the date 2106-02-07 and the time 07:28. That's with akregator of KDE SC 4.5.x

Today I have updated to KDE SC 4.6.1 and added the feed for my facebook friends' links in akregator (1.6.6). It fetched the entries of the last three days right after I created the source. Those are shown with the correct date and time (today, yesterday, Monday + time). Then I used F5 to refresh the feed and the older entries were fetched. In this version they are all displayed with no date at all and the time 00:59.
Comment 4 dmatt 2012-01-21 11:56:30 UTC
I have seen this issue repeated with Kubuntu 11.04 and 11.10. I noticed it only happens during initial feed fetching (and not consistently for all feeds) after fresh install. I always press "Fetch all feeds" button. This might be similar situation to adding few new feeds at once and consistent with bug reported.

I did fresh install of Kubuntu 11.10 64bit with subsequent update 2 days ago (so Akregator from KDE 4.7.3 is concerned). Examples of feeds behaviour:
http://www.kde.org/dotkdeorg.rdf - 9 items fetched, all with wrong date 2106-02-07 07:28
http://planetkde.org/rss20.xml - 21 items fetched with same wrong date
http://pim.planetkde.org/rss20.xml - all fetched correctly

I usually delete wrong items afterwards as they are always first and hide new items.

I try to investigate it in more detail with next install I have planned.
Comment 5 dmatt 2012-06-27 08:29:09 UTC
Happened to me again in Akregator 4.8.3 in Kubuntu 12.04  with few feeds including Planet KDE after I imported links in opml file from previous Akregator install before first "Fetch all feeds".
Comment 6 dmatt 2013-11-02 23:28:42 UTC
The bug is still present in 4.11.2 and is easily reproducible. I always trigger this bug in a new Kubuntu installation by simply importing *.opml with my usual set of feeds, some of which are duplicates to Akregator (or Kubuntu) default set.

Steps to reproduce:
1. Add feed, which is duplicate of the feed already included in Akregator or add new feed twice to different folders. 
2. Fetch all feeds. New Items in one copy of the feed have all information correct. New Items in second copy of feed might have 00:59 or 01:00 information instead of correct date.  After Akregator is restarted date information for affected items changes to 07.02.2106 07:28. 

When the duplicate feed is removed, new items are fetched with correct dates, but the older ones with wrong date stay wrong.
Comment 7 dmatt 2013-11-02 23:44:31 UTC
Actually, after akregator is restarted, both copies of feed show the date 07.02.2106 07:28 in affected items.
Comment 8 Janet 2013-11-03 19:40:37 UTC
I am not aware of having duplicate feeds... It happend to me with unique feeds. But - maybe - it happens when feeds come from the same source, like last.fm recently played tracks and loved tracks: two different feeds, but same origin...
Comment 9 Christoph Feck 2013-12-28 14:13:18 UTC
*** Bug 317344 has been marked as a duplicate of this bug. ***
Comment 10 Marc González Majoral 2016-02-25 20:45:09 UTC
More than 5 years, not bad.

Still happening in KDE 5, Akregator 5.0.3. 

07-02-2016 has passed.
Comment 11 Yuriy Vidineev 2016-04-25 10:12:33 UTC
I also have such bug from time to time (Kubuntu 16.04) but can't reproduce
Comment 12 Mark Fraser 2017-01-07 20:11:24 UTC
Yes, I am still seeing this bug with Kontact 5.2.3 in Kubuntu 16.04.
Comment 13 Buoidin 2017-01-14 12:33:31 UTC
This bug is still present in Akregator 16.04.3-2 and is really annoying. I'm 
using Akregator in Debian Stretch with Kontact 16.04.3-2 and Plasma 5.

The bug seems to appear randomly but I also see it when the following happens. 
First Akregator fetches new articles from feeds and it saves some of them 
without date and time. So usually I don't see these articles because they are 
put at the bottom of the list. Then, when Kontact is restarted, Akregator shows 
these articles whit the date 07/02/06 07:28 at the top of the list.

This bug really undermines the usability of the program because it messes the 
chronological order of the articles.
Comment 14 Christoph Feck 2017-01-25 01:58:24 UTC
*** Bug 375448 has been marked as a duplicate of this bug. ***
Comment 15 Mark Fraser 2017-06-24 16:03:06 UTC
I'm running Akregator 16.12.3 and this is still happening.
Comment 16 Dennis Brünig 2017-08-12 23:48:22 UTC
Version 17.04.3

It happened after a crash. For some items the feeds had the 2106 date.
Comment 17 Pal Körössy 2017-08-20 05:59:05 UTC
Same here with Akregator 17.04.3 with OpenSUSE Tumbleweeed.
Comment 18 Philippe ROUBACH 2017-08-20 06:27:06 UTC
kde app 17.08

also some time some contents has no date.
Comment 19 Laurent Montel 2017-08-20 11:44:44 UTC
> also some time some contents has no date.

We need a test case for this one.
Perhaps it's a parsing error.
Comment 20 Pal Körössy 2017-09-11 17:41:52 UTC
After deleting ~/.local/share/akregator folder, Akregator was working fine for one day. Now I got items with wrong date again, so I moved back to the backup folder.
What is necessary for you from my side to reproduce the issue?
Comment 21 Holger 2017-09-16 16:08:01 UTC
Created attachment 107877 [details]
example from packman list

I can confirm this issue as well, feeds appear suddenly with date 09.02.06 07:28.
Yesterday is configured akregator completely new (deleting ~/.local/share/akregator/ and ~/.config/akregatorrc). It worked without any issues for some hours. Then akregator crashed (don't remember exactly the error message, but something with a xml file) After the crash, my feeds were gone, I had to import them again from a opml file. Again it worked for a couple of hours. And now this strange feed date apears again.
Comment 22 Marc González Majoral 2017-10-25 13:47:39 UTC
So, after updating to 5.5.3, akregator has been a mess, and I noticed something that maybe could help with this issue.

A weird bug happened to me causing that, after updating all feeds, all new articles appeared with no date on them (empty column). After a reboot, all the articles I tried to read with an empty date now appear as 07.02.2106 07:28.

The conclusion is that apparently, if there's a problem with setting the date when getting/reading a new article (which seems it should never happen, why not just set the current date then?), for some reason it gets the 07.02.2106 one (that seems like a maximum possible integer value for a timestamp or something, don't you think?).

Hope it helps, this has to be one of the longest running bugs in kdepim, and still unconfirmed for some reason.
Comment 23 Marc González Majoral 2017-10-25 13:48:39 UTC
*** This bug has been confirmed by popular vote. ***
Comment 24 Pal Körössy 2017-10-25 16:53:40 UTC
For me the problem was present on OpenSUSE Tumbleweed. It gone after reverting back to stable version Leap 42.3 (Akregator 17.04-2-2.1). I deleted the items with wrong date and  I haven't experienced any problem for a month.
It was probably caused by some incorrect package versions.
Comment 25 Daniel 2018-02-10 03:26:23 UTC
I also noticed this after a crash (#390192).
Comment 26 Daniel 2018-02-10 23:41:54 UTC
The problem here may be that QDateTime can return -1 for invalid dates. Cast to a 32-bit unsigned int, -1 is 4294967295, and interpreted as a timestamp that's exactly 2106-02-07 07:28. The code doesn’t handle this case, as far as I can tell.

Notably, I’ve had this happen with completely valid feeds with correct time zone and ISO time strings. I’m not sure what the root cause is. The same feeds will work if I delete all Akregator settings and import it anew.
Comment 27 Philippe ROUBACH 2018-02-11 13:05:25 UTC
(In reply to Laurent Montel from comment #19)
> > also some time some contents has no date.
> 
> We need a test case for this one.
> Perhaps it's a parsing error.

what do you need ?
how to get what you need ?
Comment 28 Mike Eichler 2018-03-27 08:30:51 UTC
There are  a few articles with that date stuck at the top of article list in akregator.
Comment 29 aeris 2018-08-28 16:44:23 UTC
Created attachment 114662 [details]
bugged feed

Dump of http://blog.xebia.fr/feed
Comment 30 aeris 2018-08-28 16:45:12 UTC
Created attachment 114663 [details]
Bad date on some entries
Comment 31 aeris 2018-08-28 16:45:42 UTC
Created attachment 114664 [details]
Broken entries after refresh from bugged feed
Comment 32 aeris 2018-08-28 16:47:34 UTC
Same trouble here
Enclosed to this ticker a feed which generate bugged entries after a "refresh feed" action.
Seem broken entries matches the one with the bugged date, only the 5 last entries are correctly displayed.
Comment 33 Martin Koller 2018-09-13 06:44:50 UTC
I see lots of them from http://planet.qt-project.org/rss20.xml
and I have the feeling it is the same problem coming from kio-http
which stores the same date/time when doing
kioclient5 copy 'https://www.kde.org/aether/media/patrons/google.svg' file:///tmp/google.svg

stat google.svg shows
Modify: 2106-02-07 07:28:15.000000000 +0100

Also described here https://bugs.kde.org/show_bug.cgi?id=374420
but there it says it's not related to Akregator

Also possible dup: https://bugs.kde.org/show_bug.cgi?id=262271#c10
Comment 34 Philippe ROUBACH 2018-12-25 06:00:55 UTC
Here I found an explanation
 https://nwrickert2.wordpress.com/2017/09/12/reviewing-akregator-again/

I confirm the procedure to reproduce phenomenon.

The explanation is : if an article is older than the delay to keep the article akregator set date to "no date". This "no date" is read at next launch as 07/02/2106.

Please I know it is not easy to find someone to fix this bug but now this bug is 8 years old.
Comment 35 Christophe Giboudeaux 2019-01-07 10:59:02 UTC
*** Bug 386699 has been marked as a duplicate of this bug. ***
Comment 36 Christophe Giboudeaux 2019-01-20 17:44:29 UTC
*** Bug 403428 has been marked as a duplicate of this bug. ***
Comment 37 Ninetto 2019-01-20 20:45:40 UTC
Created attachment 117578 [details]
attachment-32761-0.html

Grazie, ma ripeto come vengono datati alcuni feed 07/02/06.
Lo avete corretto perchè avviene ciò?
Grazie.

Il giorno dom 20 gen 2019 alle ore 18:44 Christophe Giboudeaux <
bugzilla_noreply@kde.org> ha scritto:

> https://bugs.kde.org/show_bug.cgi?id=256034
>
> Christophe Giboudeaux <christophe@krop.fr> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |ninoriggio53@gmail.com
>
> --- Comment #36 from Christophe Giboudeaux <christophe@krop.fr> ---
> *** Bug 403428 has been marked as a duplicate of this bug. ***
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 38 brazzmonkey 2019-03-19 13:27:58 UTC
bug 262271 looks similar to me. Either way, it's an old bug that basically ruins user experience : browsing and reading feeds should be a easy task, only basic functionalities are needed.
With akregator this simple task turns into a daily fight to get a chronological list of articles. Ultimately that defeats the purpose of feed reader.
Comment 39 John Scott 2019-04-07 02:03:22 UTC
*** Bug 262271 has been marked as a duplicate of this bug. ***
Comment 40 John Scott 2019-04-07 02:14:06 UTC
*** Bug 357281 has been marked as a duplicate of this bug. ***
Comment 41 Ninetto 2019-04-07 08:20:30 UTC
Capita anche se cancello una fonte con i feed di quella data, vengono ricaricati tutti i feed vecchi quando lo riaggiungo alle fonti.
Comment 42 Patrick 2019-04-13 09:42:14 UTC
Created attachment 119395 [details]
Invalid date test feed

This is what happens (Akregator 5.10.3):
In Akregator::Feed::appendArticles fetched items are processed. All items are stored in the feed's archive. Only new items which have a publication date newer than the expiration date, will be appended to the feed's article list. The next time the feed is fetched, all items which were processed earlier but were not added to the article list and haven't changed since then, will be processes as new items. That's when the problems start on these two lines:
 Article mya(*it, this);
 mya.offsetPubDate(nudge);

The (private) constructor of Article creates an object with an invalid publication date (the default QDateTime constructor) because the item was already stored in the feed's archive and it hasn't changed. On the next line the publication date is updated, but based on the invalid publication date. This causes the invalid date to be written to the feed's archive.

It's easy to reproduce with the attached feed:
1. Add the feed to Akregator.
2. Fetch the feed.

The article first appears as a blank line, but after restarting Akregator the invalid is shown.
Comment 43 Dave 2019-07-26 08:23:17 UTC
This bug is still present in 5.11.3.
I can confirm that the test feed posted in the previous comment does trigger the bug.
Comment 44 Philippe ROUBACH 2019-07-26 16:46:02 UTC
opensuse Argon 15.1
kde app 19.04.3
plasma 5.16.3
kde framework 5.60.0
qt 5.13.0

problem still there
Comment 45 Ninetto 2019-07-27 12:27:24 UTC
Created attachment 121772 [details]
attachment-10021-0.html

Non c'è verso il difetto della data vecchia persiste sempre, data e orario,
per tute le fonti rss.

Il giorno ven 26 lug 2019 alle ore 18:46 Philippe ROUBACH <
bugzilla_noreply@kde.org> ha scritto:

> https://bugs.kde.org/show_bug.cgi?id=256034
>
> --- Comment #44 from Philippe ROUBACH <philippe.roubach@free.fr> ---
> opensuse Argon 15.1
> kde app 19.04.3
> plasma 5.16.3
> kde framework 5.60.0
> qt 5.13.0
>
> problem still there
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 46 Wolfgang Bauer 2019-07-30 15:36:32 UTC
*** Bug 410396 has been marked as a duplicate of this bug. ***
Comment 47 Scott 2019-12-11 04:39:41 UTC
same thing here on Debian 10
Akregator - Version 5.9.3

I completely wiped out my Akregator settings (including ~/.cache/akregator), imported an .opml file.

I added a duplicate for one of the feeds, and the "date" showed up as year 2106.

I looked again in the the feeds that were set and noticed a feed was a duplicate.

I am testing the duplicate rss feed issue with this one, 
http://planet.kernel.org/rss20.xml


The datestamp for the first copy of this feed is correct, but if a copy of this feed is used, all the datestamps for the second feed become 2106 for the year.
Comment 48 Philippe ROUBACH 2019-12-30 09:39:49 UTC
Created attachment 124781 [details]
bad date 01/01/1970 00:00
Comment 49 Philippe ROUBACH 2019-12-30 09:40:38 UTC
Created attachment 124782 [details]
no date
Comment 50 Christophe Giboudeaux 2020-01-26 13:09:53 UTC
*** Bug 416780 has been marked as a duplicate of this bug. ***
Comment 51 Philippe ROUBACH 2020-01-26 13:49:48 UTC
opensuse Argon 15.1
kde app 19.12.1
plasma 5.17.5
kde framework 5.66.0
qt 5.14.0

It seems last version of kde environment solves mainly the problem.

i saved the list of feeds
i deleted all data about akregator:

~/.config/akregatorrc
~/.local/akregator/

i launched akregator and restored feeds and settings.

Since this time no more date problem even in case of a kontact crash or an akregator crash.

It remains: for a few feeds sometime some fields are blank.