Bug 261740 - Crash when adding album folders using settings dialogue
Summary: Crash when adding album folders using settings dialogue
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-Engine (show other bugs)
Version: 1.4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-31 17:41 UTC by stefan.wolmarans
Modified: 2017-08-10 11:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stefan.wolmarans 2010-12-31 17:41:11 UTC
Application: digikam (1.4.0)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
From the menu Settings/Configure Digikam
In Collections -> Add Collection
Added some folders, with videos and general document folders containing pictures.
It crashed at some point while scanning folders.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb789d740 (LWP 4351))]

Thread 7 (Thread 0xb7664b70 (LWP 4352)):
#0  0x007843a1 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0x034efffd in g_main_context_query () from /lib/libglib-2.0.so.0
#2  0x034f52c4 in ?? () from /lib/libglib-2.0.so.0
#3  0x034f5ba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x030a16b4 in ?? () from /usr/lib/libgio-2.0.so.0
#5  0x0351c48f in ?? () from /lib/libglib-2.0.so.0
#6  0x00781cc9 in start_thread () from /lib/libpthread.so.0
#7  0x017c469e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xb31feb70 (LWP 4420)):
#0  0x00b79416 in __kernel_vsyscall ()
#1  0x007864dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x05f679c7 in wait (this=0x9622a78, mutex=0x9622a74, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x9622a78, mutex=0x9622a74, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0x0654a2d2 in Digikam::ParkingThread::run (this=0x9622a68) at /build/buildd/digikam-1.4.0/libs/threads/threadmanager.cpp:101
#5  0x05f66df9 in QThreadPrivate::start (arg=0x9622a68) at thread/qthread_unix.cpp:266
#6  0x00781cc9 in start_thread () from /lib/libpthread.so.0
#7  0x017c469e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb29fdb70 (LWP 4421)):
#0  0x01e67e36 in clock_gettime () from /lib/librt.so.1
#1  0x05fc250b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x060996e5 in QTimerInfoList::updateCurrentTime (this=0x96970a4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0609972a in QTimerInfoList::timerWait (this=0x96970a4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x060977a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb29fd0ec) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0609783d in timerSourcePrepare (source=0x0, timeout=0x1e6bff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x034f4e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x034f5279 in ?? () from /lib/libglib-2.0.so.0
#9  0x034f5848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0609759f in QEventDispatcherGlib::processEvents (this=0x9696d58, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x06067609 in QEventLoop::processEvents (this=0xb29fd2c0, flags=) at kernel/qeventloop.cpp:149
#12 0x06067a8a in QEventLoop::exec (this=0xb29fd2c0, flags=...) at kernel/qeventloop.cpp:201
#13 0x05f63b7e in QThread::exec (this=0x9692ba0) at thread/qthread.cpp:490
#14 0x05f66df9 in QThreadPrivate::start (arg=0x9692ba0) at thread/qthread_unix.cpp:266
#15 0x00781cc9 in start_thread () from /lib/libpthread.so.0
#16 0x017c469e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb21fcb70 (LWP 4422)):
#0  0x00b79416 in __kernel_vsyscall ()
#1  0x017b5df6 in poll () from /lib/libc.so.6
#2  0x03502a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x034f543c in ?? () from /lib/libglib-2.0.so.0
#4  0x034f5848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0609759f in QEventDispatcherGlib::processEvents (this=0x96931a8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x06067609 in QEventLoop::processEvents (this=0xb21fc2c0, flags=) at kernel/qeventloop.cpp:149
#7  0x06067a8a in QEventLoop::exec (this=0xb21fc2c0, flags=...) at kernel/qeventloop.cpp:201
#8  0x05f63b7e in QThread::exec (this=0x9695940) at thread/qthread.cpp:490
#9  0x05f66df9 in QThreadPrivate::start (arg=0x9695940) at thread/qthread_unix.cpp:266
#10 0x00781cc9 in start_thread () from /lib/libpthread.so.0
#11 0x017c469e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xab373b70 (LWP 4437)):
#0  0x00b79416 in __kernel_vsyscall ()
#1  0x00786884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x07e77b3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xa9f66b70 (LWP 4439)):
#0  0x00b79416 in __kernel_vsyscall ()
#1  0x017b5df6 in poll () from /lib/libc.so.6
#2  0x03502a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x034f543c in ?? () from /lib/libglib-2.0.so.0
#4  0x034f5848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0609759f in QEventDispatcherGlib::processEvents (this=0x9b59098, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x06067609 in QEventLoop::processEvents (this=0xa9f66250, flags=) at kernel/qeventloop.cpp:149
#7  0x06067a8a in QEventLoop::exec (this=0xa9f66250, flags=...) at kernel/qeventloop.cpp:201
#8  0x05f63b7e in QThread::exec (this=0x974b7d8) at thread/qthread.cpp:490
#9  0x04b5581a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x05f66df9 in QThreadPrivate::start (arg=0x974b7d8) at thread/qthread_unix.cpp:266
#11 0x00781cc9 in start_thread () from /lib/libpthread.so.0
#12 0x017c469e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb789d740 (LWP 4351)):
[KCrash Handler]
#7  0x08ecf2e2 in KDirWatch::contains (this=0x0, _path=...) at ../../kdecore/io/kdirwatch.cpp:1830
#8  0x0827a2a3 in Digikam::AlbumManager::addAlbumRoot (this=0x94a4428, location=...) at /build/buildd/digikam-1.4.0/digikam/albummanager.cpp:1131
#9  0x08283d09 in Digikam::AlbumManager::slotCollectionLocationStatusChanged (this=0x94a4428, location=..., oldStatus=0) at /build/buildd/digikam-1.4.0/digikam/albummanager.cpp:1102
#10 0x08285d57 in Digikam::AlbumManager::qt_metacall (this=0x94a4428, _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0xbfe98804) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/albummanager.moc:185
#11 0x0606e8ca in QMetaObject::metacall (object=0x94a4428, cl=3219752961, idx=33, argv=0xbfe98804) at kernel/qmetaobject.cpp:237
#12 0x060816ad in QMetaObject::activate (sender=0x9525be8, m=0x937264, local_signal_index=0, argv=0xbfe9869c) at kernel/qobject.cpp:3280
#13 0x00821799 in Digikam::CollectionManager::locationStatusChanged (this=0x9525be8, _t1=..., _t2=0) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/collectionmanager.moc:108
#14 0x0082851d in Digikam::CollectionManager::updateLocations (this=0x9525be8) at /build/buildd/digikam-1.4.0/libs/database/collectionmanager.cpp:1376
#15 0x008291cd in Digikam::CollectionManager::slotAlbumRootChange (this=0x9525be8, changeset=...) at /build/buildd/digikam-1.4.0/libs/database/collectionmanager.cpp:1406
#16 0x00829635 in Digikam::CollectionManager::qt_metacall (this=0x9525be8, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfe98b38) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/collectionmanager.moc:95
#17 0x0606e8ca in QMetaObject::metacall (object=0x9525be8, cl=3219752961, idx=10, argv=0xbfe98b38) at kernel/qmetaobject.cpp:237
#18 0x060816ad in QMetaObject::activate (sender=0x952c518, m=0x9372c4, local_signal_index=5, argv=0xbfe9869c) at kernel/qobject.cpp:3280
#19 0x00831163 in Digikam::DatabaseWatch::albumRootChange (this=0x952c518, _t1=...) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/moc_databasewatch.cpp:185
#20 0x008311d8 in Digikam::DatabaseWatch::slotAlbumRootChangeDBus (this=0x952c518, databaseIdentifier=..., applicationIdentifier=..., changeset=...) at /build/buildd/digikam-1.4.0/libs/database/databasewatch.cpp:334
#21 0x00831aeb in Digikam::DatabaseWatch::qt_metacall (this=0x952c518, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xbfe98cbc) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/moc_databasewatch.cpp:137
#22 0x01d549dc in QDBusConnectionPrivate::deliverCall (this=0x94aa1d8, object=0x952c518, msg=..., metaTypes=..., slotIdx=23) at qdbusintegrator.cpp:919
#23 0x01d601f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xbb8aad0, object=0x952c518) at qdbusintegrator_p.h:103
#24 0x0607b6a2 in QObject::event (this=0x952c518, e=0x0) at kernel/qobject.cpp:1219
#25 0x02229fdc in QApplicationPrivate::notify_helper (this=0x935f190, receiver=0x952c518, e=0xbb8aad0) at kernel/qapplication.cpp:4396
#26 0x0223004e in QApplication::notify (this=0xbfe995fc, receiver=0x952c518, e=0xbb8aad0) at kernel/qapplication.cpp:3798
#27 0x013e768a in KApplication::notify (this=0xbfe995fc, receiver=0x952c518, event=0xbb8aad0) at ../../kdeui/kernel/kapplication.cpp:310
#28 0x06068b3b in QCoreApplication::notifyInternal (this=0xbfe995fc, receiver=0x952c518, event=0xbb8aad0) at kernel/qcoreapplication.cpp:732
#29 0x0606bd8b in sendEvent (receiver=0x0, event_type=0, data=0x93322b8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x93322b8) at kernel/qcoreapplication.cpp:1373
#31 0x0606bf4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#32 0x06097a74 in sendPostedEvents (s=0x9361700) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x9361700) at kernel/qeventdispatcher_glib.cpp:277
#34 0x034f1855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x034f5668 in ?? () from /lib/libglib-2.0.so.0
#36 0x034f5848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x06097565 in QEventDispatcherGlib::processEvents (this=0x9331d68, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#38 0x022ebbe5 in QGuiEventDispatcherGlib::processEvents (this=0x9331d68, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x06067609 in QEventLoop::processEvents (this=0xbfe994e4, flags=) at kernel/qeventloop.cpp:149
#40 0x06067a8a in QEventLoop::exec (this=0xbfe994e4, flags=...) at kernel/qeventloop.cpp:201
#41 0x0606c00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x02228e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#43 0x083c06b3 in main (argc=5, argv=0xbfe99a64) at /build/buildd/digikam-1.4.0/digikam/main.cpp:195

This bug may be a duplicate of or related to bug 255054.

Possible duplicates by query: bug 261228, bug 258002, bug 255054.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-12-31 18:55:50 UTC

*** This bug has been marked as a duplicate of bug 255054 ***
Comment 2 caulier.gilles 2011-02-17 06:28:44 UTC
*** Bug 266506 has been marked as a duplicate of this bug. ***
Comment 3 caulier.gilles 2017-08-10 11:47:36 UTC
Since digiKam 5.0.0, KDirWatch was been replaced by QFileSytemWatcher. It will
not reproducible.

Gilles Caulier