Bug 258002 - Crash while attempting to open another directory in my albums
Summary: Crash while attempting to open another directory in my albums
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-Engine (show other bugs)
Version: 1.4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-26 18:21 UTC by Ken Jarvis
Modified: 2017-08-10 11:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Jarvis 2010-11-26 18:21:48 UTC
Application: digikam (1.4.0)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

While digiKam was open, I accessed my backup drive and clicked on the pictures directory under "my albums".  Once I clicked, the crash reporter came up.  This happened previosly while atempting to open another picture while I had one picute in view.

The crash can be reproduced some of the time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb6558740 (LWP 1790))]

Thread 7 (Thread 0xb62f4b70 (LWP 1791)):
#0  0x00c087a1 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0x07019636 in g_main_context_acquire () from /lib/libglib-2.0.so.0
#2  0x0701b1ee in ?? () from /lib/libglib-2.0.so.0
#3  0x0701bba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x09ab29c4 in ?? () from /usr/lib/libgio-2.0.so.0
#5  0x0704248f in ?? () from /lib/libglib-2.0.so.0
#6  0x00c04cc9 in start_thread () from /lib/libpthread.so.0
#7  0x051b969e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xb2307b70 (LWP 1796)):
#0  0x00c1d416 in __kernel_vsyscall ()
#1  0x00c094dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x05b309c7 in wait (this=0xa6832b8, mutex=0xa6832b4, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0xa6832b8, mutex=0xa6832b4, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0x03bbc2d2 in Digikam::ParkingThread::run (this=0xa6832a8) at /build/buildd/digikam-1.4.0/libs/threads/threadmanager.cpp:101
#5  0x05b2fdf9 in QThreadPrivate::start (arg=0xa6832a8) at thread/qthread_unix.cpp:266
#6  0x00c04cc9 in start_thread () from /lib/libpthread.so.0
#7  0x051b969e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb1b06b70 (LWP 1797)):
#0  0x00c0889b in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0x0701ae58 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x0701b279 in ?? () from /lib/libglib-2.0.so.0
#3  0x0701b848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x05c6059f in QEventDispatcherGlib::processEvents (this=0xa6a38d0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x05c30609 in QEventLoop::processEvents (this=0xb1b062c0, flags=) at kernel/qeventloop.cpp:149
#6  0x05c30a8a in QEventLoop::exec (this=0xb1b062c0, flags=...) at kernel/qeventloop.cpp:201
#7  0x05b2cb7e in QThread::exec (this=0xa6637e0) at thread/qthread.cpp:490
#8  0x05b2fdf9 in QThreadPrivate::start (arg=0xa6637e0) at thread/qthread_unix.cpp:266
#9  0x00c04cc9 in start_thread () from /lib/libpthread.so.0
#10 0x051b969e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb1305b70 (LWP 1798)):
#0  0x05c60a31 in socketNotifierSourceCheck (source=0xa686e80) at kernel/qeventdispatcher_glib.cpp:99
#1  0x0701ab39 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x0701b45e in ?? () from /lib/libglib-2.0.so.0
#3  0x0701b848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x05c6059f in QEventDispatcherGlib::processEvents (this=0xa664bb8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x05c30609 in QEventLoop::processEvents (this=0xb13052c0, flags=) at kernel/qeventloop.cpp:149
#6  0x05c30a8a in QEventLoop::exec (this=0xb13052c0, flags=...) at kernel/qeventloop.cpp:201
#7  0x05b2cb7e in QThread::exec (this=0xa662ac8) at thread/qthread.cpp:490
#8  0x05b2fdf9 in QThreadPrivate::start (arg=0xa662ac8) at thread/qthread_unix.cpp:266
#9  0x00c04cc9 in start_thread () from /lib/libpthread.so.0
#10 0x051b969e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xaac7fb70 (LWP 1799)):
#0  0x00c1d416 in __kernel_vsyscall ()
#1  0x00c09884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x09609b3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xa9872b70 (LWP 1801)):
#0  0x00c1d416 in __kernel_vsyscall ()
#1  0x051aadf6 in poll () from /lib/libc.so.6
#2  0x07028a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x0701b43c in ?? () from /lib/libglib-2.0.so.0
#4  0x0701b848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x05c6059f in QEventDispatcherGlib::processEvents (this=0xab7ac88, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x05c30609 in QEventLoop::processEvents (this=0xa9872250, flags=) at kernel/qeventloop.cpp:149
#7  0x05c30a8a in QEventLoop::exec (this=0xa9872250, flags=...) at kernel/qeventloop.cpp:201
#8  0x05b2cb7e in QThread::exec (this=0xab7a890) at thread/qthread.cpp:490
#9  0x0383581a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x05b2fdf9 in QThreadPrivate::start (arg=0xab7a890) at thread/qthread_unix.cpp:266
#11 0x00c04cc9 in start_thread () from /lib/libpthread.so.0
#12 0x051b969e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb6558740 (LWP 1790)):
[KCrash Handler]
#7  0x09c0c2e2 in KDirWatch::contains (this=0x0, _path=...) at ../../kdecore/io/kdirwatch.cpp:1830
#8  0x0827a2a3 in Digikam::AlbumManager::addAlbumRoot (this=0xa4f4868, location=...) at /build/buildd/digikam-1.4.0/digikam/albummanager.cpp:1131
#9  0x08283d09 in Digikam::AlbumManager::slotCollectionLocationStatusChanged (this=0xa4f4868, location=..., oldStatus=3) at /build/buildd/digikam-1.4.0/digikam/albummanager.cpp:1102
#10 0x08285d57 in Digikam::AlbumManager::qt_metacall (this=0xa4f4868, _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0xbfa76944) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/albummanager.moc:185
#11 0x05c378ca in QMetaObject::metacall (object=0xa4f4868, cl=3215419649, idx=33, argv=0xbfa76944) at kernel/qmetaobject.cpp:237
#12 0x05c4a6ad in QMetaObject::activate (sender=0xa546cf0, m=0x49c264, local_signal_index=0, argv=0xbfa767dc) at kernel/qobject.cpp:3280
#13 0x00386799 in Digikam::CollectionManager::locationStatusChanged (this=0xa546cf0, _t1=..., _t2=3) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/collectionmanager.moc:108
#14 0x0038d51d in Digikam::CollectionManager::updateLocations (this=0xa546cf0) at /build/buildd/digikam-1.4.0/libs/database/collectionmanager.cpp:1376
#15 0x0038e47d in Digikam::CollectionManager::accessibilityChanged (this=0xa546cf0, accessible=true, udi=...) at /build/buildd/digikam-1.4.0/libs/database/collectionmanager.cpp:1273
#16 0x0038e6ff in Digikam::CollectionManager::qt_metacall (this=0xa546cf0, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfa76c14) at /build/buildd/digikam-1.4.0/obj-i686-linux-gnu/digikam/collectionmanager.moc:94
#17 0x05c378ca in QMetaObject::metacall (object=0xa546cf0, cl=3215419649, idx=9, argv=0xbfa76c14) at kernel/qmetaobject.cpp:237
#18 0x05c4a6ad in QMetaObject::activate (sender=0xa577c48, m=0x84cff38, local_signal_index=0, argv=0xbfa767dc) at kernel/qobject.cpp:3280
#19 0x00cb729f in Solid::StorageAccess::accessibilityChanged (this=0xa577c48, _t1=true, _t2=...) at ./storageaccess.moc:127
#20 0x00cb7667 in Solid::StorageAccess::qt_metacall (this=0xa577c48, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa76d74) at ./storageaccess.moc:87
#21 0x05c378ca in QMetaObject::metacall (object=0xa577c48, cl=3215419649, idx=4, argv=0xbfa76d74) at kernel/qmetaobject.cpp:237
#22 0x05c4a6ad in QMetaObject::activate (sender=0xa56ad80, m=0xd1c240, local_signal_index=0, argv=0xbfa767dc) at kernel/qobject.cpp:3280
#23 0x00cfed7f in Solid::Backends::Hal::StorageAccess::accessibilityChanged (this=0xa56ad80, _t1=true, _t2=...) at ./backends/hal/halstorageaccess.moc:140
#24 0x00d00092 in Solid::Backends::Hal::StorageAccess::slotPropertyChanged (this=0xa56ad80, changes=...) at ../../../solid/solid/backends/hal/halstorageaccess.cpp:168
#25 0x00d0402d in Solid::Backends::Hal::StorageAccess::qt_metacall (this=0xa56ad80, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfa76f48) at ./backends/hal/halstorageaccess.moc:119
#26 0x05c378ca in QMetaObject::metacall (object=0xa56ad80, cl=3215419649, idx=11, argv=0xbfa76f48) at kernel/qmetaobject.cpp:237
#27 0x05c4a6ad in QMetaObject::activate (sender=0xa5a0130, m=0xd1b620, local_signal_index=0, argv=0xbfa767dc) at kernel/qobject.cpp:3280
#28 0x00cec093 in Solid::Backends::Hal::HalDevice::propertyChanged (this=0xa5a0130, _t1=...) at ./backends/hal/haldevice.moc:99
#29 0x00cecb93 in Solid::Backends::Hal::HalDevice::slotPropertyModified (this=0xa5a0130, changes=...) at ../../../solid/solid/backends/hal/haldevice.cpp:544
#30 0x00cecdee in Solid::Backends::Hal::HalDevice::qt_metacall (this=0xa5a0130, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfa7718c) at ./backends/hal/haldevice.moc:86
#31 0x035149dc in QDBusConnectionPrivate::deliverCall (this=0xa547c08, object=0xa5a0130, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:919
#32 0x035201f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xc45a2c8, object=0xa5a0130) at qdbusintegrator_p.h:103
#33 0x05c446a2 in QObject::event (this=0xa5a0130, e=0x0) at kernel/qobject.cpp:1219
#34 0x013cffdc in QApplicationPrivate::notify_helper (this=0xa3f2190, receiver=0xa5a0130, e=0xc45a2c8) at kernel/qapplication.cpp:4396
#35 0x013d604e in QApplication::notify (this=0xbfa77acc, receiver=0xa5a0130, e=0xc45a2c8) at kernel/qapplication.cpp:3798
#36 0x02c0f68a in KApplication::notify (this=0xbfa77acc, receiver=0xa5a0130, event=0xc45a2c8) at ../../kdeui/kernel/kapplication.cpp:310
#37 0x05c31b3b in QCoreApplication::notifyInternal (this=0xbfa77acc, receiver=0xa5a0130, event=0xc45a2c8) at kernel/qcoreapplication.cpp:732
#38 0x05c34d8b in sendEvent (receiver=0x0, event_type=0, data=0xa3c52b8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xa3c52b8) at kernel/qcoreapplication.cpp:1373
#40 0x05c34f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#41 0x05c60a74 in sendPostedEvents (s=0xa3f3d90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=0xa3f3d90) at kernel/qeventdispatcher_glib.cpp:277
#43 0x07017855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0x0701b668 in ?? () from /lib/libglib-2.0.so.0
#45 0x0701b848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0x05c60565 in QEventDispatcherGlib::processEvents (this=0xa3c4d68, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#47 0x01491be5 in QGuiEventDispatcherGlib::processEvents (this=0xa3c4d68, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x05c30609 in QEventLoop::processEvents (this=0xbfa779b4, flags=) at kernel/qeventloop.cpp:149
#49 0x05c30a8a in QEventLoop::exec (this=0xbfa779b4, flags=...) at kernel/qeventloop.cpp:201
#50 0x05c3500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#51 0x013cee07 in QApplication::exec () at kernel/qapplication.cpp:3672
#52 0x083c06b3 in main (argc=5, argv=0xbfa77f34) at /build/buildd/digikam-1.4.0/digikam/main.cpp:195

This bug may be a duplicate of or related to bug 255054.

Possible duplicates by query: bug 255054.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-11-26 18:45:16 UTC

*** This bug has been marked as a duplicate of bug 255054 ***
Comment 2 caulier.gilles 2010-11-26 18:46:24 UTC
As you can see in #255054, it's fixed in 1.6.0. Please update and confirm

Gilles Caulier
Comment 3 Ken Jarvis 2010-11-28 21:21:15 UTC
Having problems compiling the new digikam 1.6.0.  I have ubuntu 10.10 on
an HP a1253w system and it won't install properly. I am fairly new to
linux and tried the instruction on digikam.org, ubuntu.org, and
opensource.  If possible could you give me some instruction to compiling
and installing.

thanks,
Comment 4 Martin Klapetek 2010-11-28 21:50:14 UTC
With what exactly are you having problems?
Comment 5 Ken Jarvis 2010-11-29 04:24:52 UTC
I un-installed all components of Digikam 1.4.0 via synaptic package
manager. Un-installed the complete directory that I put the digikam
1.6.0 in and re-downloaded the tarball.  Following the direction on the
download screen, I used the commands suggested in terminal to get the
dependencies. Then proceeded to use cmake as suggested and it seamed to
build the program.  when I used the su command in terminal, it said
unable to authenticate.  Bypassing this I used "sudo make install" and I
think it installed it, however, it's not in my applications menu nor can
I find it in the usr/share or anywhere else.  Attached is a copy of the
all the files and directories that were found using the search
function.  

All I want to do is get the newest version as suggested by another to
fix the bugs in 1.4.0.  I want to start using digikam more for my
photography rather than Lightroom.  Digikam has more usable functions.

Thanks for helping.  Hope this is enough info.
Comment 6 Martin Klapetek 2010-11-30 16:08:26 UTC
In case of successful install, you should be able to at least find the executable in /usr/bin, or simply try typing digikam into terminal and press enter and see what happens. Also you forgot to attach the output, if you could provide one with the whole process, that would be more than great to help you ;)

Anyway, if the make command ended successfuly at 100%, it's all builded ok, then you just need to install it by using either "sudo make install" or by going through "su" and then "make install". If everything was compiled ok, the install should be the one thing to cause the smallest problems.
Comment 7 Ken Jarvis 2010-12-05 06:14:01 UTC
Martin, 

Sorry for the delay.  I have included a .txt file of the process I used
to make the program per your request.  When you have time to review the
document, let me know what I can do to make it work right.

Thanks for your help,
Comment 8 Martin Klapetek 2010-12-05 12:01:42 UTC
Uhm, seems like you forgot to attach that file :) But anyway, since this bug is closed and you're having problems not related to this bug, please contact me directly at martin dot klapetek at gmail dot com or if you're using irc, catch me up on #digikam on Freenode, I'm there by the name mck182 and I'll help you solve your issues there ;)
Comment 9 caulier.gilles 2017-08-10 11:49:27 UTC
Since digiKam 5.0.0, KDirWatch was been replaced by QFileSytemWatcher. It will
not reproducible.

Gilles Caulier