Bug 261359 - using device notification to mount usbpen results in 100% cpu usage
Summary: using device notification to mount usbpen results in 100% cpu usage
Status: RESOLVED DUPLICATE of bug 261463
Alias: None
Product: solid
Classification: Unclassified
Component: libsolid-fstab (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-27 12:09 UTC by Patrizio Bassi
Modified: 2013-07-28 22:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrizio Bassi 2010-12-27 12:09:49 UTC
Version:           unspecified (using KDE 4.5.90) 
OS:                Linux

after mounting via udisks an usbpen, the partition is correctly mounted the process kde4 will start to use 100% cpu

strace shows noting, just waiting for a semaphore

no way but killing the process to exit the issue

Reproducible: Always

Steps to Reproduce:
just plug in an usbpen
Comment 1 Jacopo De Simoi 2011-01-03 11:40:25 UTC
I can reproduce occasional instances of kded4 eating 100% cpu, but I can't find any correlation with mounting/unmounting an usbpen.

Can you confirm it happens most of the times you mount an usbpen with the device notifier?
If it is the case could you please try mounting the same usbpen with dolphin and see if it triggers the same problem?

Thanks
 __J
Comment 2 Jacopo De Simoi 2011-01-03 11:44:08 UTC
I can reproduce occasional instances of kded4 eating 100% cpu, but I can't find any correlation with mounting/unmounting an usbpen.

Can you confirm it happens most of the times you mount an usbpen with the device notifier?
If it is the case could you please try mounting the same usbpen with dolphin and see if it triggers the same problem?

Thanks
 __J
Comment 3 Lukáš Tinkl 2011-01-03 12:57:45 UTC
Perhaps related to #261200?
Comment 4 Patrizio Bassi 2011-01-03 13:51:51 UTC
i'm starting to think it's related to
https://bugs.kde.org/show_bug.cgi?id=261463

i will try to reproduce later: when dolphin is stuck as the bug reports, if the notificator tries to mount and raise a new dolphin instance it may enter this loop.
Comment 5 Jacopo De Simoi 2011-01-03 16:26:24 UTC
When it happens, would you mind attaching gdb to kded4 and see what's going on there?
thanks
Comment 6 Lukáš Tinkl 2011-01-03 20:55:55 UTC
It deadlocks in the fstab backend, investigating; I also got Dolphin hung up, as described in bug #261463
Comment 7 Alex Fiestas 2013-03-14 02:23:22 UTC
Any new on this? has anybody been able to reproduce this?
Comment 8 Alex Fiestas 2013-07-28 22:07:05 UTC
Duplicated bugs were fixed. Closing this one.

If it is not a duplicate and you still can reproduce it, please feel free to reopen !

*** This bug has been marked as a duplicate of bug 261463 ***