Bug 260656 - Make Outline dropdown menu get hidden somehow
Summary: Make Outline dropdown menu get hidden somehow
Status: RESOLVED DUPLICATE of bug 260657
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 4.1.60
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: 4.2.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-18 21:43 UTC by Alexey Chernov
Modified: 2010-12-20 09:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Chernov 2010-12-18 21:43:09 UTC
Version:           4.1.60 (using KDE 4.5.4) 
OS:                Linux

Outline menu is great feature but if I click on a string of it and menu dropped I can't hide it with mouse anymore without clicking on a document or on the 'Projects' dock. If I click on a document I lose previous cursor position. Clicking on 'Projects' dock is OK but I can't say it's so obvious. I can also press Esc on a keyboard but this is a little bit uncomfortable, too, because I have to move my hand from letter keys to Esc and return it.
I think there should be some option to close the menu. Most intuitive way is normal combobox list behavior - to click on a string again to hide the menu but it's editable and maybe it's not possible. But it's possible to put "V" sign at the right side like in normal comboboxes.

Reproducible: Always
Comment 1 Milian Wolff 2010-12-20 00:52:46 UTC
right, see 260657

*** This bug has been marked as a duplicate of bug 260657 ***
Comment 2 Milian Wolff 2010-12-20 00:53:05 UTC
btw pressing esc should close it as well
Comment 3 Alexey Chernov 2010-12-20 09:03:06 UTC
Thanks.
Yes, esc does also work.