Bug 260657 - Outline menu doesn't follow main window on its move
Summary: Outline menu doesn't follow main window on its move
Status: RESOLVED FIXED
Alias: None
Product: kdevplatform
Classification: Unclassified
Component: general (show other bugs)
Version: 0.9.94
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: 1.2.3
Assignee: kdevelop-bugs-null
URL:
Keywords:
: 260656 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-18 21:48 UTC by Alexey Chernov
Modified: 2012-12-24 01:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of the bug (151.89 KB, image/png)
2010-12-18 21:48 UTC, Alexey Chernov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Chernov 2010-12-18 21:48:09 UTC
Created attachment 55057 [details]
screenshot of the bug

Version:           4.1.60 (using KDE 4.5.4) 
OS:                Linux

Outline menu is displayed in the same place even if you move the main window from which it was opened (see the screenshot)

Reproducible: Always

Steps to Reproduce:
1. Click on the Outline string to open Outline menu.
2. Move the main KDevelop window.
3. Notice the Outline menu be displayed in the old place of screen.
Comment 1 Milian Wolff 2010-12-20 00:51:52 UTC
I'd say the dialog should hide as soon as someone clicks anywhere outside (even if the focus is not lost).
Comment 2 Milian Wolff 2010-12-20 00:52:46 UTC
*** Bug 260656 has been marked as a duplicate of this bug. ***
Comment 3 Alexey Chernov 2010-12-20 08:58:31 UTC
Thank you
Comment 4 Kevin Funk 2012-12-24 01:00:36 UTC
Git commit 13280ae4fcd5b5430fd289facfa6d2349d560fb2 by Kevin Funk.
Committed on 23/12/2012 at 16:05.
Pushed by kfunk into branch 'master'.

Close the outline menu in case the parent moves

Also works in case the outline toolbar is detached.
REVIEW: 107882

M  +13   -1    plugins/quickopen/quickopenplugin.cpp

http://commits.kde.org/kdevplatform/13280ae4fcd5b5430fd289facfa6d2349d560fb2