Bug 254043 - CD is listed twice in Dolphin. This can lead to crashes in some situations.
Summary: CD is listed twice in Dolphin. This can lead to crashes in some situations.
Status: RESOLVED WORKSFORME
Alias: None
Product: kfile
Classification: Unclassified
Component: kfileplacesview (show other bugs)
Version: 4.8.3
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords: triaged
: 260576 266738 284268 288988 297560 309112 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-13 10:58 UTC by Alvin
Modified: 2018-10-28 03:14 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.33 KB, text/plain)
2011-02-14 22:22 UTC, Kirk M
Details
New crash information added by DrKonqi (6.88 KB, text/plain)
2012-05-20 17:10 UTC, Mebuntu
Details
New crash information added by DrKonqi (5.31 KB, text/plain)
2012-05-27 08:59 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alvin 2010-10-13 10:58:06 UTC
Application: dolphin (1.5)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Eject a DVD with Dolphin

There are a lot of steps in order to reproduce this. There's probably an easier way:
- Insert a CD
- Leave the cd and reboot
- Now, you'll see the cd listed twice in the 'places' panel (probably another bug)
- Eject one of the cd entries (the other will stay)
- Insert another cd/dvd
- Eject that cd with Dolphin
- Eject the cd again with Dolphin. Now, it will crash and this backtrace can be made.

I think the core problem is that the cd is listed twice, hence the bug description.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0aaab58760 (LWP 5199))]

Thread 2 (Thread 0x7f0a97423710 (LWP 5206)):
#0  0x00007f0aaa4361e3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0aa2028009 in g_main_context_poll (context=0x1e55830, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:3093
#2  g_main_context_iterate (context=0x1e55830, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2775
#3  0x00007f0aa202845c in g_main_context_iteration (context=0x1e55830, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#4  0x00007f0aa686b1e6 in QEventDispatcherGlib::processEvents (this=0x1bb3f60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f0aa683da02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f0aa683ddec in QEventLoop::exec (this=0x7f0a97422db0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f0aa67482fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f0aa681d5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1b8e140) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f0aa674b27e in QThreadPrivate::start (arg=0x1b8e140) at thread/qthread_unix.cpp:266
#10 0x00007f0aa45b0971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f0aaa44292d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0aaab58760 (LWP 5199)):
[KCrash Handler]
#6  ref (this=0x7fff44f4cf50, n=...) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
#7  QDomNode::QDomNode (this=0x7fff44f4cf50, n=...) at dom/qdom.cpp:2040
#8  0x00007f0aaa112a8d in KBookmark (this=<value optimized out>) at ../../kio/bookmarks/kbookmark.h:35
#9  KFilePlacesItem::bookmark (this=<value optimized out>) at ../../kfile/kfileplacesitem.cpp:84
#10 0x00007f0aaa112d4f in KFilePlacesItem::isDevice (this=0x1e27bb0) at ../../kfile/kfileplacesitem.cpp:79
#11 0x00007f0aaa115e4b in KFilePlacesModel::deviceForIndex (this=0x1e27bc8, index=...) at ../../kfile/kfileplacesmodel.cpp:237
#12 0x00007f0aaa1191a1 in KFilePlacesModel::requestEject (this=0x19bd0e0, index=...) at ../../kfile/kfileplacesmodel.cpp:803
#13 0x00007f0aaa12187a in KFilePlacesView::contextMenuEvent (this=0x20688e0, event=0x7fff44f4e280) at ../../kfile/kfileplacesview.cpp:679
#14 0x00007f0aa74c5a54 in QWidget::event (this=0x20688e0, event=0x7fff44f4e280) at kernel/qwidget.cpp:8354
#15 0x00007f0aa78915e6 in QFrame::event (this=0x20688e0, e=0x7fff44f4e280) at widgets/qframe.cpp:557
#16 0x00007f0aa79caa8b in QAbstractItemView::viewportEvent (this=0x20688e0, event=0x7fff44f4e280) at itemviews/qabstractitemview.cpp:1619
#17 0x00007f0aa683e507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x206d8f0, event=0x7fff44f4e280) at kernel/qcoreapplication.cpp:847
#18 0x00007f0aa746ffac in QApplicationPrivate::notify_helper (this=0x1966a80, receiver=0x206d8f0, e=0x7fff44f4e280) at kernel/qapplication.cpp:4392
#19 0x00007f0aa7475cd1 in QApplication::notify (this=0x7fff44f4efc0, receiver=0x206d8f0, e=0x7fff44f4e280) at kernel/qapplication.cpp:4038
#20 0x00007f0aa81c34d6 in KApplication::notify (this=0x7fff44f4efc0, receiver=0x206d8f0, event=0x7fff44f4e280) at ../../kdeui/kernel/kapplication.cpp:310
#21 0x00007f0aa683ecdc in QCoreApplication::notifyInternal (this=0x7fff44f4efc0, receiver=0x206d8f0, event=0x7fff44f4e280) at kernel/qcoreapplication.cpp:732
#22 0x00007f0aa74f8392 in QETWidget::translateMouseEvent (this=<value optimized out>, event=<value optimized out>) at kernel/qapplication_x11.cpp:4408
#23 0x00007f0aa74f6c5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff44f4ebd0) at kernel/qapplication_x11.cpp:3536
#24 0x00007f0aa75230e2 in x11EventSourceDispatch (s=0x1964750, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#25 0x00007f0aa2024342 in g_main_dispatch (context=0x1963440) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#26 g_main_context_dispatch (context=0x1963440) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#27 0x00007f0aa20282a8 in g_main_context_iterate (context=0x1963440, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#28 0x00007f0aa202845c in g_main_context_iteration (context=0x1963440, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#29 0x00007f0aa686b193 in QEventDispatcherGlib::processEvents (this=0x195f920, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#30 0x00007f0aa7522a4e in QGuiEventDispatcherGlib::processEvents (this=0x7fff44f4cf50, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f0aa683da02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#32 0x00007f0aa683ddec in QEventLoop::exec (this=0x7fff44f4ef00, flags=) at kernel/qeventloop.cpp:201
#33 0x00007f0aa6841ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#34 0x00007f0aaa72890f in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/dolphin/src/main.cpp:98
#35 0x00007f0aaa37ad8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff44f4f4d8) at libc-start.c:226
#36 0x0000000000400659 in _start ()

Reported using DrKonqi
Comment 1 Kirk M 2011-02-14 22:22:14 UTC
Created attachment 57259 [details]
New crash information added by DrKonqi

dolphin (1.6) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:

In Dolphin, ejecting a CD by right clicking on the appropriate drive in the "Places" sidbar. Disk drive tray ejected and immediately retracted again without my intervention. It was at this point Dolphin crashed. Restarted Dolphin and repeated operation with success--no crash ocurred but disk drive tray still quickly retracted without my intervention. Had to grab for the CD before the tray closed. I have to manually eject the disk (via the "eject" button on the PC itself) before the tray will stay in the eject position so disk can be removed safely.

Running Linux Mint 10 KDE (RC) with KDE 4.6. Problem does not occur Linux Mint 10 (Gnome) nor does it occur with Linux Mint Debian Edition or Pardus 2011 with KDE 4.5.5.

-- Backtrace (Reduced):
#6  ref (this=0x7fff5f5fa360, n=...) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
#7  QDomNode::QDomNode (this=0x7fff5f5fa360, n=...) at dom/qdom.cpp:2040
#8  0x00007fb5c3084bfd in KBookmark (this=<value optimized out>) at ../../kio/bookmarks/kbookmark.h:35
#9  KFilePlacesItem::bookmark (this=<value optimized out>) at ../../kfile/kfileplacesitem.cpp:86
#10 0x00007fb5c3084c3f in KFilePlacesItem::isDevice (this=0x2415400) at ../../kfile/kfileplacesitem.cpp:81
Comment 2 Peter Penz 2011-12-18 13:20:33 UTC
*** Bug 266738 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2012-01-03 21:16:48 UTC
*** Bug 260576 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2012-01-03 21:18:09 UTC
*** Bug 284268 has been marked as a duplicate of this bug. ***
Comment 5 Dawit Alemayehu 2012-02-01 16:15:16 UTC
*** Bug 288988 has been marked as a duplicate of this bug. ***
Comment 6 Nicolás Alvarez 2012-04-06 02:50:06 UTC
*** Bug 297560 has been marked as a duplicate of this bug. ***
Comment 7 Ruslan Kabatsayev 2012-04-22 20:15:12 UTC
Just came across this report while searching the web for retracting the tray immediately after ejecting it. This behaviour is still present in KDE 4.8.2, though I don't reproduce any crash or listing the cdrom twice - just a problem with ejection.
Comment 8 Ruslan Kabatsayev 2012-04-22 20:18:33 UTC
Ah, yes, some additional info: if I issue "eject" command in the console, the tray opens correctly. This problem might be unrelated to original report and in fact this might be not dolphin's fault, but instead bug in underlying layer (udisks or something like this).
Comment 9 Mebuntu 2012-05-20 17:10:57 UTC
Created attachment 71249 [details]
New crash information added by DrKonqi

dolphin (2.0) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:

I was ejecting a cd, Dolphin ejects then closes the drawer quickly so you have to eject again, and that's when Dolphin crashes.

-- Backtrace (Reduced):
#7  QDomNode::QDomNode (this=0x7fff1f95dce0, n=...) at dom/qdom.cpp:2040
#8  0x00007ff7b2917b6d in KBookmark (this=0x7fff1f95dce0) at ../../kio/bookmarks/kbookmark.h:34
#9  KFilePlacesItem::bookmark (this=<optimized out>) at ../../kfile/kfileplacesitem.cpp:86
#10 0x00007ff7b2917ba9 in KFilePlacesItem::isDevice (this=0x1f06590) at ../../kfile/kfileplacesitem.cpp:81
#11 0x00007ff7b2919fb9 in KFilePlacesModel::deviceForIndex (this=<optimized out>, index=...) at ../../kfile/kfileplacesmodel.cpp:243
Comment 10 Dennis Schridde 2012-05-27 08:59:04 UTC
Created attachment 71394 [details]
New crash information added by DrKonqi

dolphin (2.0) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.2

- What I was doing when the application crashed:
I had a DVD in the drive, clicked "eject" in the r-click menu in Dolphin's places bar and the DVD was ejected and immediately pulled in again. The DVD item in the places bar remained during that time, so I r-clicked it immediately after realising that the DVD is pulled in again and selected "eject" a 2nd time. In that moment Dolphin crashed.

-- Backtrace (Reduced):
#6  0x0000003b2501354b in QDomNode::QDomNode(QDomNode const&) () from /usr/lib64/qt4/libQtXml.so.4
#7  0x0000003b312632cd in KBookmark (this=0x7fff00864c60) at /var/tmp/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kio/bookmarks/kbookmark.h:34
#8  KFilePlacesItem::bookmark (this=<optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kfile/kfileplacesitem.cpp:86
#9  0x0000003b31263309 in KFilePlacesItem::isDevice (this=0x1e50e70) at /var/tmp/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kfile/kfileplacesitem.cpp:81
#10 0x0000003b312656d9 in KFilePlacesModel::deviceForIndex (this=<optimized out>, index=...) at /var/tmp/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kfile/kfileplacesmodel.cpp:243
Comment 11 Myriam Schweingruber 2012-09-07 14:41:37 UTC
Confirmed by duplicates.
Comment 12 Frank Reininghaus 2012-10-30 17:30:42 UTC
*** Bug 309112 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2018-06-28 22:20:48 UTC
Is this still an issue with KDE Frameworks 5.47 and Dolphin 18.04.x?
Comment 14 Andrew Crouthamel 2018-09-28 03:12:01 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 15 Andrew Crouthamel 2018-10-28 03:14:34 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!