Bug 259975 - Unexplaned crash
Summary: Unexplaned crash
Status: RESOLVED DUPLICATE of bug 251117
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-15 18:00 UTC by Seanq
Modified: 2010-12-15 21:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Seanq 2010-12-15 18:00:13 UTC
Application: ktorrent (4.0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Ktorrent was seeding 3 torrents while the comp was idle overnight.
woke up with the crash report

this is the second occerance 

both ocations there were no other programs running and no unusual cercumstansis

my power options are set to never sleep and never spin down the hard disks
and computer is considered idle after 15 minutes
(running a desktop)

The crash can be reproduced some of the time.

-- Backtrace:
Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb9dced8760 (LWP 1937))]

Thread 8 (Thread 0x7fb9ce0c0700 (LWP 1938)):
#0  0x00007fb9d8a51203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb9d38ac009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fb9d38ac7b5 in g_main_loop_run () from /lib/libglib-2.0.so.0
#3  0x00007fb9ce7f70f4 in ?? () from /usr/lib/libgio-2.0.so.0
#4  0x00007fb9d38d17e4 in ?? () from /lib/libglib-2.0.so.0
#5  0x00007fb9da188971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007fb9d8a5d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fb9bbfff700 (LWP 1944)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007fb9d89f61dc in _L_lock_12347 () from /lib/libc.so.6
#2  0x00007fb9d89f4c78 in __libc_free (mem=0x7fb9d8cf5e40) at malloc.c:3736
#3  0x00007fb9d8a11dd9 in tzset_internal (always=<value optimized out>, explicit=<value optimized out>) at tzset.c:435
#4  0x00007fb9d8a120b0 in __tzset () at tzset.c:592
#5  0x00007fb9da4208e6 in QDateTime::currentDateTime () at tools/qdatetime.cpp:3116
#6  0x00007fb9dc9dff47 in bt::Log::Private::finishLine (this=0x1478da0) at ../../src/util/log.cpp:130
#7  0x00007fb9dc9def77 in endline (lg=...) at ../../src/util/log.cpp:159
#8  bt::endl (lg=...) at ../../src/util/log.cpp:222
#9  0x00007fb9dc9df12c in operator<< (type=<value optimized out>, msg=0x7fb9bc518128 "QSocketNotifier: Invalid socket 32 and type 'Read', disabling...") at ../../src/util/log.h:140
#10 bt::QtMessageOutput (type=<value optimized out>, msg=0x7fb9bc518128 "QSocketNotifier: Invalid socket 32 and type 'Read', disabling...") at ../../src/util/log.cpp:297
#11 0x00007fb9da40a80e in qt_message_output (msgType=QtWarningMsg, buf=0x80 <Address 0x80 out of bounds>) at global/qglobal.cpp:2205
#12 0x00007fb9da40aa42 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtWarningMsg, msg=0x7fb9da5cb0a8 "QSocketNotifier: Invalid socket %d and type '%s', disabling...", ap=0x7fb9bbffeaf0) at global/qglobal.cpp:2305
#13 0x00007fb9da40ad75 in qWarning (msg=0x80 <Address 0x80 out of bounds>) at global/qglobal.cpp:2387
#14 0x00007fb9da5335f6 in socketNotifierSourceCheck (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:90
#15 0x00007fb9d38ab66a in g_main_context_check () from /lib/libglib-2.0.so.0
#16 0x00007fb9d38ac023 in ?? () from /lib/libglib-2.0.so.0
#17 0x00007fb9d38ac45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#18 0x00007fb9da533193 in QEventDispatcherGlib::processEvents (this=0x14d4530, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#19 0x00007fb9da505a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#20 0x00007fb9da505dec in QEventLoop::exec (this=0x7fb9bbffedb0, flags=) at kernel/qeventloop.cpp:201
#21 0x00007fb9da4102fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#22 0x00007fb9dca8a15e in utp::UTPServerThread::run (this=0x14d54a0) at ../../src/utp/utpserverthread.cpp:44
#23 0x00007fb9da41327e in QThreadPrivate::start (arg=0x14d54a0) at thread/qthread_unix.cpp:266
#24 0x00007fb9da188971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#25 0x00007fb9d8a5d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#26 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fb9bb7fe700 (LWP 1945)):
#0  0x00007fb9d8a562c3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fb9dca51212 in dht::RPCServerThread::run (this=0x14e1350) at ../../src/dht/rpcserver.cpp:107
#2  0x00007fb9da41327e in QThreadPrivate::start (arg=0x14e1350) at thread/qthread_unix.cpp:266
#3  0x00007fb9da188971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007fb9d8a5d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fb9baffd700 (LWP 1948)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007fb9d89f61dc in _L_lock_12347 () from /lib/libc.so.6
#2  0x00007fb9d89f4c78 in __libc_free (mem=0x7fb9d8cf5e40) at malloc.c:3736
#3  0x00007fb9d38a7c3b in ?? () from /lib/libglib-2.0.so.0
#4  0x00007fb9da533d33 in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x153a2b0, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:369
#5  0x00007fb9da412ac4 in QThreadPrivate::finish (arg=<value optimized out>) at thread/qthread_unix.cpp:302
#6  0x00007fb9da413286 in ~__pthread_cleanup_class (arg=0x7fb9da838f40) at /usr/include/pthread.h:545
#7  QThreadPrivate::start (arg=0x7fb9da838f40) at thread/qthread_unix.cpp:271
#8  0x00007fb9da188971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007fb9d8a5d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fb9ba40f700 (LWP 1989)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb9da412533 in QMutexPrivate::wait (this=0x11cd2a0, timeout=-1) at thread/qmutex_unix.cpp:84
#2  0x00007fb9da40dee5 in QMutex::lock (this=0x6d9088) at thread/qmutex.cpp:167
#3  0x00007fb9dc9ee803 in net::DownloadThread::update (this=0x11cd320) at ../../src/net/downloadthread.cpp:51
#4  0x00007fb9dc9ef2c9 in net::NetworkThread::run (this=0x11cd320) at ../../src/net/networkthread.cpp:48
#5  0x00007fb9da41327e in QThreadPrivate::start (arg=0x11cd320) at thread/qthread_unix.cpp:266
#6  0x00007fb9da188971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007fb9d8a5d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb9b9c0e700 (LWP 1990)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007fb9d89f61dc in _L_lock_12347 () from /lib/libc.so.6
#2  0x00007fb9d89f4c78 in __libc_free (mem=0x7fb9d8cf5e40) at malloc.c:3736
#3  0x00007fb9dca07ce4 in deallocate (this=0x2551bc0, data=<value optimized out>, max_to_write=16393) at /usr/include/c++/4.4/ext/new_allocator.h:95
#4  _M_put_node (this=0x2551bc0, data=<value optimized out>, max_to_write=16393) at /usr/include/c++/4.4/bits/stl_list.h:320
#5  _M_erase (this=0x2551bc0, data=<value optimized out>, max_to_write=16393) at /usr/include/c++/4.4/bits/stl_list.h:1431
#6  pop_front (this=0x2551bc0, data=<value optimized out>, max_to_write=16393) at /usr/include/c++/4.4/bits/stl_list.h:906
#7  bt::PacketWriter::onReadyToWrite (this=0x2551bc0, data=<value optimized out>, max_to_write=16393) at ../../src/peer/packetwriter.cpp:259
#8  0x00007fb9dc9f4475 in mse::StreamSocket::onReadyToWrite (this=0x16de400, data=0x1a8eb50 "]_E\245\035{(f\001\020gS\a", max_to_write=39132128) at ../../src/mse/streamsocket.cpp:299
#9  0x00007fb9dc9e986a in net::BufferedSocket::writeBuffered (this=0x23f2390, max=0, now=1292408010232) at ../../src/net/bufferedsocket.cpp:198
#10 0x00007fb9dc9f039a in net::SocketGroup::processUnlimited (this=<value optimized out>, up=true, now=1292408010232) at ../../src/net/socketgroup.cpp:51
#11 0x00007fb9dc9f05c0 in net::SocketGroup::process (this=0x7fb9d8cf5e40, up=128, now=39132128, global_allowance=@0x7fb9b9c0dd8c) at ../../src/net/socketgroup.cpp:192
#12 0x00007fb9dc9ef22c in net::NetworkThread::doGroups (this=0x11cd990, num_ready=<value optimized out>, now=1292408010232, limit=<value optimized out>) at ../../src/net/networkthread.cpp:155
#13 0x00007fb9dc9edfd9 in net::UploadThread::update (this=0x11cd990) at ../../src/net/uploadthread.cpp:81
#14 0x00007fb9dc9ef2c9 in net::NetworkThread::run (this=0x11cd990) at ../../src/net/networkthread.cpp:48
#15 0x00007fb9da41327e in QThreadPrivate::start (arg=0x11cd990) at thread/qthread_unix.cpp:266
#16 0x00007fb9da188971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#17 0x00007fb9d8a5d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb9b8c0c700 (LWP 1991)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007fb9d89f61dc in _L_lock_12347 () from /lib/libc.so.6
#2  0x00007fb9d89f4c78 in __libc_free (mem=0x7fb9d8cf5e40) at malloc.c:3736
#3  0x00007fb9da517e8e in QObjectPrivate::cleanConnectionLists (this=0x1aab2d0) at kernel/qobject.cpp:383
#4  0x00007fb9da51ef03 in QMetaObject::activate (sender=0x1b7fe10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fb9b8c0bd90) at kernel/qobject.cpp:3316
#5  0x00007fb9dc9d44f2 in net::ReverseResolver::resolved (this=0x7fb9d8cf5e40, _t1=<value optimized out>) at moc_reverseresolver.cpp:84
#6  0x00007fb9dc9f1ffb in net::ReverseResolver::run (this=0x1b7fe10) at ../../src/net/reverseresolver.cpp:74
#7  0x00007fb9dc9f21dd in net::ReverseResolverThread::run (this=0x14aec90) at ../../src/net/reverseresolver.cpp:118
#8  0x00007fb9da41327e in QThreadPrivate::start (arg=0x14aec90) at thread/qthread_unix.cpp:266
#9  0x00007fb9da188971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007fb9d8a5d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb9dced8760 (LWP 1937)):
[KCrash Handler]
#6  _int_malloc (av=0x7fb9d8cf5e40, bytes=56) at malloc.c:4628
#7  0x00007fb9d89f338e in __libc_malloc (bytes=56) at malloc.c:3660
#8  0x00007fb9da4572d5 in QString::QString (this=0x7fff421b5de0, size=12) at tools/qstring.cpp:1065
#9  0x00007fb9da458ea2 in replaceArgEscapes (s=<value optimized out>, d=<value optimized out>, field_width=<value optimized out>, arg=..., larg=..., fillChar=...) at tools/qstring.cpp:6335
#10 0x00007fb9da464024 in QString::arg (this=0x7fff421b5df0, a=<value optimized out>, fieldWidth=0, base=<value optimized out>, fillChar=...) at tools/qstring.cpp:6696
#11 0x00007fb9dca01fd1 in arg (this=<value optimized out>, arr=<value optimized out>) at /usr/include/qt4/QtCore/qstring.h:748
#12 bt::PeerManager::pex (this=<value optimized out>, arr=<value optimized out>) at ../../src/peer/peermanager.cpp:625
#13 0x00007fb9dca09c7b in bt::UTPex::handlePacket (this=0x299a280, packet=<value optimized out>, size=<value optimized out>) at ../../src/peer/utpex.cpp:64
#14 0x00007fb9dc9fe245 in bt::Peer::packetReady (this=0x7fb9d8cf5ed8, packet=0x0, len=4051599484) at ../../src/peer/peer.cpp:360
#15 0x00007fb9dca09248 in bt::PacketReader::update (this=0x1d00f60) at ../../src/peer/packetreader.cpp:141
#16 0x00007fb9dc9fd0d5 in bt::Peer::update (this=0x2020e90) at ../../src/peer/peer.cpp:538
#17 0x00007fb9dca02995 in bt::PeerManager::update (this=0x161a0e0) at ../../src/peer/peermanager.cpp:144
#18 0x00007fb9dca348a4 in bt::TorrentControl::update (this=0x15def80) at ../../src/torrent/torrentcontrol.cpp:163
#19 0x00000000004289fb in kt::Core::update (this=0x7fb9bc003e90) at ../../ktorrent/core.cpp:1030
#20 0x0000000000431222 in kt::Core::qt_metacall (this=0x7fb9bc003e90, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff421b6320) at ./core.moc:167
#21 0x00007fb9da51eb27 in QMetaObject::activate (sender=0x7fb9bc003eb8, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x20) at kernel/qobject.cpp:3280
#22 0x00007fb9da5188f9 in QObject::event (this=0x7fb9bc003eb8, e=0x0) at kernel/qobject.cpp:1183
#23 0x00007fb9d9650fdc in QApplicationPrivate::notify_helper (this=0x11fa820, receiver=0x7fb9bc003eb8, e=0x7fff421b6a50) at kernel/qapplication.cpp:4396
#24 0x00007fb9d9656aed in QApplication::notify (this=0x7fff421b6d80, receiver=0x7fb9bc003eb8, e=0x7fff421b6a50) at kernel/qapplication.cpp:4277
#25 0x0000000000437d1a in kt::App::notify (this=0x7fb9d8cf5ed8, receiver=0x0, event=0xf17e807c) at ../../ktorrent/app.cpp:97
#26 0x00007fb9da506cdc in QCoreApplication::notifyInternal (this=0x7fff421b6d80, receiver=0x7fb9bc003eb8, event=0x7fff421b6a50) at kernel/qcoreapplication.cpp:732
#27 0x00007fb9da5366f2 in sendEvent (this=0x1201f30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QTimerInfoList::activateTimers (this=0x1201f30) at kernel/qeventdispatcher_unix.cpp:602
#29 0x00007fb9da5334c8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#30 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#31 0x00007fb9d38a8342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#32 0x00007fb9d38ac2a8 in ?? () from /lib/libglib-2.0.so.0
#33 0x00007fb9d38ac45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#34 0x00007fb9da533193 in QEventDispatcherGlib::processEvents (this=0x11cb320, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#35 0x00007fb9d9703a4e in QGuiEventDispatcherGlib::processEvents (this=0x7fb9d8cf5ed8, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007fb9da505a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#37 0x00007fb9da505dec in QEventLoop::exec (this=0x7fff421b6cf0, flags=) at kernel/qeventloop.cpp:201
#38 0x00007fb9da509ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#39 0x0000000000426a8b in main (argc=<value optimized out>, argv=<value optimized out>) at ../../ktorrent/main.cpp:176

Reported using DrKonqi
Comment 1 Joris Guisson 2010-12-15 21:24:04 UTC

*** This bug has been marked as a duplicate of bug 251117 ***