Bug 251117 - Crash after enable uTorrent protocol
Summary: Crash after enable uTorrent protocol
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 248645 250845 250918 252316 252341 253798 255785 257144 258207 259715 259975 260940 261506 268219 268690 270540 270542 270547 270931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-13 16:23 UTC by BRULE Herman
Modified: 2011-04-14 18:05 UTC (History)
18 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BRULE Herman 2010-09-13 16:23:11 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

Hello, I crash after have enable uTorrent protocole:
Starting program: /usr/bin/ktorrent --nofork
[Thread debugging using libthread_db enabled]
Qt: gdb: -nograb added to command-line options.
         Use the -dograb option to enforce grabbing.
[New Thread 0x7fffe66b7710 (LWP 30251)]
[New Thread 0x7fffe5eb6710 (LWP 30252)]
[Thread 0x7fffe66b7710 (LWP 30251) exited]
Warning: QObject::connect: Connecting from QAction::toggled(bool) to COMPAT slot (kt::HintLineEdit::setShown(bool))
Warning: QObject::connect: Connecting from COMPAT signal (QComboBox::textChanged(QString))
[New Thread 0x7fffe66b7710 (LWP 30261)]
[New Thread 0x7fffd3d8e710 (LWP 30262)]
[New Thread 0x7fffd358d710 (LWP 30263)]
[New Thread 0x7fffd2d8c710 (LWP 30264)]
[New Thread 0x7fffd258b710 (LWP 30265)]
[New Thread 0x7fffd196d710 (LWP 30266)]
[New Thread 0x7fffd116c710 (LWP 30267)]
[New Thread 0x7fffd096b710 (LWP 30268)]
Warning: QObject::killTimers: timers cannot be stopped from another thread

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffe5eb6710 (LWP 30252)]
QCoreApplication::notifyInternal (this=0x7fffffffcf90, receiver=0x7fffcc7b1c80, event=0x7fffe5eb5b60) at kernel/qcoreapplication.cpp:714
714     kernel/qcoreapplication.cpp: No such file or directory.
        in kernel/qcoreapplication.cpp
(gdb) bt
#0  QCoreApplication::notifyInternal (this=0x7fffffffcf90, receiver=0x7fffcc7b1c80, event=0x7fffe5eb5b60) at kernel/qcoreapplication.cpp:714
#1  0x00007ffff5ad8a62 in QCoreApplication::sendEvent (this=0x8a3f50) at kernel/qcoreapplication.h:215
#2  QTimerInfoList::activateTimers (this=0x8a3f50) at kernel/qeventdispatcher_unix.cpp:603
#3  0x00007ffff5ad51d8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#4  idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#5  0x00007fffeff3483f in g_main_dispatch (context=0x8a3530) at gmain.c:1960
#6  IA__g_main_context_dispatch (context=0x8a3530) at gmain.c:2513
#7  0x00007fffeff38bf8 in g_main_context_iterate (context=0x8a3530, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#8  0x00007fffeff38dac in IA__g_main_context_iteration (context=0x8a3530, may_block=1) at gmain.c:2654
#9  0x00007ffff5ad4df3 in QEventDispatcherGlib::processEvents (this=0x8a3440, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#10 0x00007ffff5aa18b2 in QEventLoop::processEvents (this=<value optimized out>, flags=DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjuction with DW_OP_piece.
) at kernel/qeventloop.cpp:149
#11 0x00007ffff5aa1d55 in QEventLoop::exec (this=0x7fffe5eb5dd0, flags=DWARF-2 expression error: DW_OP_reg operations must be used either alone or in conjuction with DW_OP_piece.
) at kernel/qeventloop.cpp:201
#12 0x00007ffff59904ad in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#13 0x00007ffff7b3b7f6 in utp::UTPServerThread::run (this=0x868c90) at /var/tmp/portage/net-libs/libktorrent-1.0.3/work/libktorrent-1.0.3/src/utp/utpserverthread.cpp:44
#14 0x00007ffff59930fa in QThreadPrivate::start (arg=0x868c90) at thread/qthread_unix.cpp:248
#15 0x00007ffff56fc894 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#16 0x00007ffff3eff27d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Reproducible: Always
Comment 1 Joris Guisson 2010-09-13 20:30:35 UTC
*** Bug 250845 has been marked as a duplicate of this bug. ***
Comment 2 Joris Guisson 2010-09-16 19:49:42 UTC
SVN commit 1176107 by guisson:

Fix race condition causing timers not to be removed in the µTP code, resulting in a crash 

BUG: 251117

 M  +3 -0      ChangeLog  
 M  +4 -1      src/utp/connection.cpp  
 M  +19 -0     src/utp/remotewindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1176107
Comment 3 Joris Guisson 2010-09-16 19:57:20 UTC
*** Bug 248645 has been marked as a duplicate of this bug. ***
Comment 4 Joris Guisson 2010-09-25 11:11:50 UTC
*** Bug 252316 has been marked as a duplicate of this bug. ***
Comment 5 Joris Guisson 2010-10-14 18:12:53 UTC
*** Bug 253798 has been marked as a duplicate of this bug. ***
Comment 6 Joris Guisson 2010-11-01 09:31:15 UTC
*** Bug 255785 has been marked as a duplicate of this bug. ***
Comment 7 Joris Guisson 2010-11-17 18:08:58 UTC
*** Bug 257144 has been marked as a duplicate of this bug. ***
Comment 8 Joris Guisson 2010-12-14 19:31:30 UTC
*** Bug 259715 has been marked as a duplicate of this bug. ***
Comment 9 Joris Guisson 2010-12-14 19:34:48 UTC
*** Bug 250918 has been marked as a duplicate of this bug. ***
Comment 10 Joris Guisson 2010-12-14 19:37:10 UTC
*** Bug 252341 has been marked as a duplicate of this bug. ***
Comment 11 Joris Guisson 2010-12-14 19:39:13 UTC
*** Bug 258207 has been marked as a duplicate of this bug. ***
Comment 12 Joris Guisson 2010-12-15 21:24:04 UTC
*** Bug 259975 has been marked as a duplicate of this bug. ***
Comment 13 Joris Guisson 2010-12-24 12:58:59 UTC
*** Bug 260940 has been marked as a duplicate of this bug. ***
Comment 14 Joris Guisson 2010-12-29 12:28:59 UTC
*** Bug 261506 has been marked as a duplicate of this bug. ***
Comment 15 Joris Guisson 2011-02-27 10:24:14 UTC
*** Bug 267184 has been marked as a duplicate of this bug. ***
Comment 16 Joris Guisson 2011-03-11 19:22:04 UTC
*** Bug 268219 has been marked as a duplicate of this bug. ***
Comment 17 Joris Guisson 2011-03-17 19:26:49 UTC
*** Bug 268690 has been marked as a duplicate of this bug. ***
Comment 18 Joris Guisson 2011-04-10 10:40:33 UTC
*** Bug 270547 has been marked as a duplicate of this bug. ***
Comment 19 Joris Guisson 2011-04-10 11:06:21 UTC
*** Bug 270540 has been marked as a duplicate of this bug. ***
Comment 20 Joris Guisson 2011-04-10 11:06:54 UTC
*** Bug 270542 has been marked as a duplicate of this bug. ***
Comment 21 Joris Guisson 2011-04-14 18:05:17 UTC
*** Bug 270931 has been marked as a duplicate of this bug. ***