Bug 259781 - digiKam crash when left open
Summary: digiKam crash when left open
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Runtime (show other bugs)
Version: 1.6.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-13 22:33 UTC by Antti Poikela
Modified: 2022-01-21 12:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Poikela 2010-12-13 22:33:42 UTC
Application: digikam (1.6.0)
KDE Platform Version: 4.5.85 (4.6 Beta2)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I downloaded a couple of photos from a Canon camera and left the application open. When coming back some 14 hours later the application had crashed. This may not be very informative, I hope the crash trace gives some more insight.

The crash reporting assistant returned some 700 other crash reports to compare so I must admit I didn't properly check for duplicates.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
[Current thread is 1 (Thread 0x7fbfd86477c0 (LWP 1467))]

Thread 4 (Thread 0x7fbfbe137710 (LWP 1475)):
#0  0x00007fbfcfd7a39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbfd395310b in wait (this=<value optimized out>, mutex=0xc89368, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xc89368, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fbfd5cab577 in ?? () from /usr/lib64/libdigikamcore.so.1
#4  0x00007fbfd3952a1e in QThreadPrivate::start (arg=0xc89350) at thread/qthread_unix.cpp:285
#5  0x00007fbfcfd75a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007fbfd1fb282d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fbfbd936710 (LWP 1476)):
#0  timerSourcePrepare (source=0x115da00, timeout=0x7fbfbd935c2c) at kernel/qeventdispatcher_glib.cpp:160
#1  0x00007fbfc9e6cf7f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fbfc9e6de69 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbfc9e6e510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fbfd3a68ae6 in QEventDispatcherGlib::processEvents (this=0x12ce3a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fbfd3a3d262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fbfd3a3d475 in QEventLoop::exec (this=0x7fbfbd935dc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fbfd39501a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fbfd3952a1e in QThreadPrivate::start (arg=0x12e9420) at thread/qthread_unix.cpp:285
#9  0x00007fbfcfd75a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fbfd1fb282d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fbfbd135710 (LWP 1477)):
#0  0x00007fbfcfd780b4 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007fbfc9e6e0a2 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fbfc9e6e510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbfd3a68ae6 in QEventDispatcherGlib::processEvents (this=0xd9b5f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbfd3a3d262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbfd3a3d475 in QEventLoop::exec (this=0x7fbfbd134dc0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fbfd39501a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fbfd3952a1e in QThreadPrivate::start (arg=0xc0b1e0) at thread/qthread_unix.cpp:285
#8  0x00007fbfcfd75a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007fbfd1fb282d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbfd86477c0 (LWP 1467)):
[KCrash Handler]
#6  0x00007fbfd1f149e5 in raise () from /lib64/libc.so.6
#7  0x00007fbfd1f15ee6 in abort () from /lib64/libc.so.6
#8  0x00007fbfd1f4fc53 in __libc_message () from /lib64/libc.so.6
#9  0x00007fbfd1f55226 in malloc_printerr () from /lib64/libc.so.6
#10 0x00007fbfd274feb9 in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::~basic_string() () from /usr/lib64/libstdc++.so.6
#11 0x00007fbfd1f174e1 in __run_exit_handlers () from /lib64/libc.so.6
#12 0x00007fbfd1f17535 in exit () from /lib64/libc.so.6
#13 0x00007fbfd1f00b84 in __libc_start_main () from /lib64/libc.so.6
#14 0x000000000047d3b9 in _start ()

Possible duplicates by query: bug 259505, bug 259472, bug 259428, bug 259415, bug 259370.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-12-13 22:52:46 UTC
backtrace is uncomplete. please install debug package and try again. Run also digiKam into GDB to get a complete backtrace

Gilles Caulier
Comment 2 Antti Poikela 2010-12-16 23:28:29 UTC
I installed "digikam-debuginfo" but didn't get any better traces. The crash occurs every time I close showFoto:

1. Open shoFoto
2. Open any image in application
3. Close application -> crash

Using gdb I got the following trace:

Program received signal SIGABRT, Aborted.
0x00007ffff46dd9e5 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x00007ffff46dd9e5 in raise () from /lib64/libc.so.6
#1  0x00007ffff46deee6 in abort () from /lib64/libc.so.6
#2  0x00007ffff4718c53 in __libc_message () from /lib64/libc.so.6
#3  0x00007ffff471e226 in malloc_printerr () from /lib64/libc.so.6
#4  0x00007ffff4f18eb9 in std::basic_string<char, std::char_traits<char>, std::allocator<char> >::~basic_string() ()
   from /usr/lib64/libstdc++.so.6
#5  0x00007ffff46e04e1 in __run_exit_handlers () from /lib64/libc.so.6
#6  0x00007ffff46e0535 in exit () from /lib64/libc.so.6
#7  0x00007ffff46c9b84 in __libc_start_main () from /lib64/libc.so.6
#8  0x0000000000412c69 in _start () at ../sysdeps/x86_64/elf/start.S:113

This doesn't look exactly helpful either. Just point out if there is something else I could do.
Comment 3 Dario Andres 2010-12-19 19:11:57 UTC
[Comment from a bug triager]
This is likely to be an OpenSuse + Strigi bug, being tracked at bug 257944. (It is actually about Dolphin, but there are reports about other applications crashing on exit too)
Regards
Comment 4 Dario Andres 2011-01-01 14:54:12 UTC
[Comment from a bug triager]
Merging with bug 257944. Thanks

*** This bug has been marked as a duplicate of bug 257944 ***
Comment 5 caulier.gilles 2022-01-21 12:56:31 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=257944