Bug 259178 - KMail duplicates Mails from pop3-Account randomly
Summary: KMail duplicates Mails from pop3-Account randomly
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Unclassified
Component: pop3 (show other bugs)
Version: 1.13.2
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-08 00:57 UTC by Joe Hurke
Modified: 2015-04-12 09:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Hurke 2010-12-08 00:57:11 UTC
Version:           1.13.2 (using KDE 4.4.2) 
OS:                Linux

I have NOT selected KMail to leave messages at the pop-server.
But it looks like, KMail IS leaving "some" messages at the pop-server.
So the next time I download eMails, "these" messages are downloaded again.
So they become duplicated in my eMail-folders.
I still found no rule, which messages become duplicated.
I have activated a pop-filter for messages bigger than 50KB.
But some duplicated messages are bigger, some are smaller than 50KB.
I looks like, "some" messages are left about a week on the server. (After that they are no more duplicated, when downloading eMails.)
No, I have NOT selected KMail to leave messages at the pop-server.
Deleting duplicated messages is probably my most often called action with KMail, since I tried to work with KDE4.

Reproducible: Always

Steps to Reproduce:
This problem happend every time when downloading eMail (from my pop-accounts), since I switched from KDE 3.5.10 to KDE 4.
KDE 3 was not affected by this problem.



OS: Linux (i686) release 2.6.32-26-generic
Compiler: cc
Comment 1 Joe Hurke 2010-12-22 04:29:49 UTC
Perhaps this problem is caused by the same reason as Bug 218590 https://bugs.kde.org/show_bug.cgi?id=218590 .
But here so far never all messages became duplicated but only "some messages of the last week".
Comment 2 Laurent Montel 2015-04-12 09:45:19 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.