Bug 259109 - Plasma crashes just as desktop boots up
Summary: Plasma crashes just as desktop boots up
Status: RESOLVED DUPLICATE of bug 257658
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-07 13:20 UTC by Dave Burkholder
Modified: 2010-12-07 13:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Burkholder 2010-12-07 13:20:50 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Plasma crashes every time my computer boots up, before I get to a usable desktop.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc733755760 (LWP 2320))]

Thread 2 (Thread 0x7fc7130f6710 (LWP 2322)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fffdf3a17a1 in ?? ()
#2  0x00007fc72df502a3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007fc732369522 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007fc73242d4ad in QTimerInfoList::updateCurrentTime (this=0xbd5380) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007fc73242d835 in QTimerInfoList::timerWait (this=0xbd5380, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007fc73242c2ec in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7fc7130f5c4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007fc73242c395 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007fc72dca7f7f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fc72dca8e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fc72dca9510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#12 0x00007fc73242cae6 in QEventDispatcherGlib::processEvents (this=0xc988a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007fc732401262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fc732401475 in QEventLoop::exec (this=0x7fc7130f5de0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007fc7323141a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007fc7323e2918 in QInotifyFileSystemWatcherEngine::run (this=0xc4b7c0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007fc732316a1e in QThreadPrivate::start (arg=0xc4b7c0) at thread/qthread_unix.cpp:285
#18 0x00007fc732087a4f in start_thread () from /lib64/libpthread.so.0
#19 0x00007fc730e3f82d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc733755760 (LWP 2320)):
[KCrash Handler]
#6  Plasma::ExtenderItem::group (this=0x11d2c20) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extenderitem.cpp:476
#7  0x00007fc72918d1e6 in Plasma::Extender::itemAddedEvent (this=0xe771d0, item=0x11d2c20, pos=...) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extender.cpp:490
#8  0x00007fc72918d6e4 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0xe75aa0) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extender.cpp:805
#9  0x00007fc72918ef92 in Plasma::Extender::qt_metacall (this=0xe771d0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xcf8cf0) at /usr/src/debug/kdelibs-4.5.80/build/plasma/extender.moc:105
#10 0x00007fc732415c6a in QObject::event (this=0xe771d0, e=<value optimized out>) at kernel/qobject.cpp:1211
#11 0x00007fc731bc771b in QGraphicsWidget::event (this=0xe771d0, event=0x1153640) at graphicsview/qgraphicswidget.cpp:1407
#12 0x00007fc7315a2cd4 in QApplicationPrivate::notify_helper (this=0x6add70, receiver=0xe771d0, e=0x1153640) at kernel/qapplication.cpp:4445
#13 0x00007fc7315ab1ca in QApplication::notify (this=<value optimized out>, receiver=0xe771d0, e=0x1153640) at kernel/qapplication.cpp:4324
#14 0x00007fc7330b4976 in KApplication::notify (this=0x6a49d0, receiver=0xe771d0, event=0x1153640) at /usr/src/debug/kdelibs-4.5.80/kdeui/kernel/kapplication.cpp:311
#15 0x00007fc732401e2c in QCoreApplication::notifyInternal (this=0x6a49d0, receiver=0xe771d0, event=0x1153640) at kernel/qcoreapplication.cpp:732
#16 0x00007fc732405625 in sendEvent (receiver=0x0, event_type=0, data=0x610420) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x610420) at kernel/qcoreapplication.cpp:1373
#18 0x00007fc73242c8f3 in sendPostedEvents (s=0x6b1090) at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=0x6b1090) at kernel/qeventdispatcher_glib.cpp:277
#20 0x00007fc72dca8a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fc72dca9270 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fc72dca9510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fc73242ca8f in QEventDispatcherGlib::processEvents (this=0x6adaa0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007fc731647eae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007fc732401262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fc732401475 in QEventLoop::exec (this=0x7fffdf20ce00, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007fc7324058db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#28 0x00007fc722f68578 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#29 0x0000000000407609 in _start ()

This bug may be a duplicate of or related to bug 257658.

Possible duplicates by query: bug 258362, bug 257658.

Reported using DrKonqi
Comment 1 Marco Martin 2010-12-07 13:42:42 UTC

*** This bug has been marked as a duplicate of bug 257658 ***