Bug 257658 - KDE4.5.77 plasma shell often crashes at startup [Plasma::ExtenderItem::group. Plasma::Extender::itemAddedEvent , Plasma::ExtenderPrivate::delayItemAddedEvent]
Summary: KDE4.5.77 plasma shell often crashes at startup [Plasma::ExtenderItem::group....
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 258362 259109 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-23 00:57 UTC by Ric
Modified: 2011-02-05 22:47 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.87 KB, text/plain)
2010-11-23 01:18 UTC, Ric
Details
New crash information added by DrKonqi (5.50 KB, text/plain)
2010-11-23 01:44 UTC, Ric
Details
New crash information added by DrKonqi (9.31 KB, text/plain)
2010-11-30 16:15 UTC, Philip Muškovac
Details
plasma-desktop-appletsrc (12.62 KB, text/plain)
2010-11-30 16:21 UTC, Philip Muškovac
Details
New crash information added by DrKonqi (4.71 KB, text/plain)
2010-12-02 16:54 UTC, Manuel Stol
Details
New crash information added by DrKonqi (7.39 KB, text/plain)
2010-12-06 10:20 UTC, Forger
Details
New crash information added by DrKonqi (4.81 KB, text/plain)
2010-12-24 21:39 UTC, Manuel Stol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ric 2010-11-23 00:57:47 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.36-desktop-2mnb x86_64
Distribution (Platform): Mandriva RPMs

-- Information about the crash:
- What I was doing when the application crashed:

Used startx to start KDE from console. Shell never appeared.
The same has happened many times by starting with KDM but it is not every time. 
This one was second attempt after a logout from a session that started normally(using startx). C-A-B was used to kill the X-server on the first attempt.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3513eeb720 (LWP 9539))]

Thread 2 (Thread 0x7f34f23ab710 (LWP 9541)):
#0  0x00007f3511549663 in poll () from /lib64/libc.so.6
#1  0x00007f350e5a44c4 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f350e5a49fd in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f3512b298d6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f3512afdae2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f3512afdd2c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f3512a12f24 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f3512adf598 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f3512a1573e in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f351278dd25 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f3511553efd in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3513eeb720 (LWP 9539)):
[KCrash Handler]
#6  Plasma::ExtenderItem::group (this=0xde2e50) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extenderitem.cpp:476
#7  0x00007f3509b50b16 in Plasma::Extender::itemAddedEvent (this=0xd8b1e0, item=0xde2e50, pos=...) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extender.cpp:490
#8  0x00007f3509b516d9 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0xd89e10) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extender.cpp:805
#9  0x00007f3509b52ac2 in Plasma::Extender::qt_metacall (this=0xd8b1e0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xde7790) at /usr/src/debug/kdelibs-4.5.77svn1198704/build/plasma/extender.moc:105
#10 0x00007f3512b12aea in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#11 0x00007f35122cca5b in QGraphicsWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#12 0x00007f3511cab3b4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#13 0x00007f3511cafeca in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#14 0x00007f3513878926 in KApplication::notify (this=0x938d50, receiver=0xd8b1e0, event=0xdebba0) at /usr/src/debug/kdelibs-4.5.77svn1198704/kdeui/kernel/kapplication.cpp:311
#15 0x00007f3512afe74c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#16 0x00007f3512b01f35 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#17 0x00007f3512b296e3 in ?? () from /usr/lib64/libQtCore.so.4
#18 0x00007f350e5a3f83 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#19 0x00007f350e5a4760 in ?? () from /lib64/libglib-2.0.so.0
#20 0x00007f350e5a49fd in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#21 0x00007f3512b2987f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#22 0x00007f3511d5073e in ?? () from /usr/lib64/libQtGui.so.4
#23 0x00007f3512afdae2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#24 0x00007f3512afdd2c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#25 0x00007f3512b021eb in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#26 0x00007f3502c6f2ac in kdemain (argc=1, argv=0x88c1f0) at /usr/src/debug/kdebase-workspace-4.5.77svn1198704/plasma/desktop/shell/main.cpp:118
#27 0x0000000000407a1a in launch (argc=<value optimized out>, _name=0x8cf0b8 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=0, envs=<value optimized out>, reset_env=false, 
    tty=0x0, avoid_loops=false, startup_id_str=0x40b4c1 "0") at /usr/src/debug/kdelibs-4.5.77svn1198704/kinit/kinit.cpp:730
#28 0x0000000000408333 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at /usr/src/debug/kdelibs-4.5.77svn1198704/kinit/kinit.cpp:1222
#29 0x00000000004089c1 in handle_requests (waitForPid=0) at /usr/src/debug/kdelibs-4.5.77svn1198704/kinit/kinit.cpp:1415
#30 0x0000000000409248 in main (argc=4, argv=0x7ffff9def798, envp=0x7ffff9def7c0) at /usr/src/debug/kdelibs-4.5.77svn1198704/kinit/kinit.cpp:1901

Reported using DrKonqi
Comment 1 Ric 2010-11-23 01:18:00 UTC
Created attachment 53646 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.80 (4.6 Beta1) using Qt 4.7.1

- What I was doing when the application crashed:
Login using KDM. Shell never appeared.
As you see, it is repeatable but not at will.

- Custom settings of the application:
I forgot to mention in OR that Desktop Effects are on but only a subset of the default.

-- Backtrace (Reduced):
#6  Plasma::ExtenderItem::group (this=0x15f14a0) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extenderitem.cpp:476
#7  0x00007ff36d382b16 in Plasma::Extender::itemAddedEvent (this=0x158e0d0, item=0x15f14a0, pos=...) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extender.cpp:490
#8  0x00007ff36d3836d9 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0x158cc90) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extender.cpp:805
#9  0x00007ff36d384ac2 in Plasma::Extender::qt_metacall (this=0x158e0d0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x15f2d00)
    at /usr/src/debug/kdelibs-4.5.77svn1198704/build/plasma/extender.moc:105
#10 0x00007ff376344aea in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
Comment 2 Ric 2010-11-23 01:44:07 UTC
Created attachment 53647 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.80 (4.6 Beta1) using Qt 4.7.1

- What I was doing when the application crashed:

Login from KDM ... Plasma Shell never appeared.


- Unusual behavior I noticed:

Used ALT-F2 and entered /usr/bin/plasma-desktop. Shell started and is running.


- Custom settings of the application:

Used a different  x86_64 kernel.  
#> uname -srv
Linux 2.6.36-tmb-desktop-4mdv #1 SMP PREEMPT Fri Nov 19 02:58:54 UTC 2010

-- Backtrace (Reduced):
#6  Plasma::ExtenderItem::group (this=0x27326e0) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extenderitem.cpp:476
#7  0x00007fc9d1254b16 in Plasma::Extender::itemAddedEvent (this=0x271e560, item=0x27326e0, pos=...) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extender.cpp:490
#8  0x00007fc9d12556d9 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0x271d120) at /usr/src/debug/kdelibs-4.5.77svn1198704/plasma/extenders/extender.cpp:805
#9  0x00007fc9d1256ac2 in Plasma::Extender::qt_metacall (this=0x271e560, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x276f3a0)
    at /usr/src/debug/kdelibs-4.5.77svn1198704/build/plasma/extender.moc:105
#10 0x00007fc9da216aea in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
Comment 3 Beat Wolf 2010-11-30 13:58:13 UTC
*** Bug 258362 has been marked as a duplicate of this bug. ***
Comment 4 Philip Muškovac 2010-11-30 16:15:42 UTC
Created attachment 53891 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.80 (4.6 Beta1) using Qt 4.7.1

- What I was doing when the application crashed:

plasma-desktop crashed every time I tried to started it until I deleted
.kde/share/config/plasma-desktop-appletsrc

restoring the file from backup made it crash again

-- Backtrace (Reduced):
#6  Plasma::ExtenderItem::group (this=0x1e312f0) at ../../plasma/extenders/extenderitem.cpp:476
#7  0x00007f7c037a8a4c in Plasma::Extender::itemAddedEvent (this=0x1e77c40, item=0x1e312f0, pos=...) at ../../plasma/extenders/extender.cpp:490
#8  0x00007f7c037a9064 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0x1e76120) at ../../plasma/extenders/extender.cpp:805
#9  0x00007f7c037aa792 in Plasma::Extender::qt_metacall (this=0x1e77c40, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x1daf860) at ./extender.moc:105
#10 0x00007f7c01072f2a in QObject::event (this=0x1e77c40, e=<value optimized out>) at kernel/qobject.cpp:1219
Comment 5 Philip Muškovac 2010-11-30 16:21:32 UTC
Created attachment 53892 [details]
plasma-desktop-appletsrc

The original plasma-desktop-appletsrc that plasma-desktop crashed with. I removed the notes contents though (private).
Comment 6 Anne-Marie Mahfouf 2010-12-02 15:20:07 UTC
BugSquad: Philip on trunk I can load your plasma-desktop-appletsrc file OK, no crash!
Comment 7 Manuel Stol 2010-12-02 16:54:00 UTC
Created attachment 53980 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.80 (4.6 Beta1) using Qt 4.7.1

- What I was doing when the application crashed:
  Booted-up the computer (cold boot; not a restart).
- Unusual behavior I noticed:
  During start-up there is an error that Nepomuk could not be started.

-- Backtrace (Reduced):
#6  0x00007f7a07eee7f4 in Plasma::ExtenderItem::group (this=0xeb3530) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extenderitem.cpp:476
#7  0x00007f7a07ee6896 in Plasma::Extender::itemAddedEvent (this=0xe8da80, item=0xeb3530, pos=...) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extender.cpp:490
#8  0x00007f7a07ee481c in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0xec73e0) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extender.cpp:805
#9  0x00007f7a07ee8cf2 in Plasma::Extender::qt_metacall (this=0xe8da80, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0xfdd0b0) at /usr/src/debug/kdelibs-4.5.80/build/plasma/extender.moc:105
#10 0x00007f7a1116863e in QObject::event (this=0xe8da80, e=0xeb3530) at kernel/qobject.cpp:1211
Comment 8 Anne-Marie Mahfouf 2010-12-02 17:53:15 UTC
Manuel: what KDE version? What distribution? what applets do you have on your desktop and panels?
Comment 9 Forger 2010-12-06 10:20:59 UTC
Created attachment 54195 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.80 (4.6 Beta1) using Qt 4.7.0

Every time when I try to start plasma-desktop it crashes. It worked fine for a couple of hours and suddenly stopped.

-- Backtrace (Reduced):
#6  0x00007f5ff63be1d4 in Plasma::ExtenderItem::group (this=0x342f190) at ../../plasma/extenders/extenderitem.cpp:476
#7  0x00007f5ff63b71c6 in Plasma::Extender::itemAddedEvent (this=0x33cc680, item=0x342f190, pos=...) at ../../plasma/extenders/extender.cpp:490
#8  0x00007f5ff63b420c in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0x3412fa0) at ../../plasma/extenders/extender.cpp:805
#9  0x00007f5ff63b8712 in Plasma::Extender::qt_metacall (this=0x33cc680, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x329b240) at ./extender.moc:105
#10 0x00007f5ff3be2bde in QObject::event (this=0x33cc680, e=0x342f190) at kernel/qobject.cpp:1219
Comment 10 Marco Martin 2010-12-07 13:42:42 UTC
*** Bug 259109 has been marked as a duplicate of this bug. ***
Comment 11 Marco Martin 2010-12-07 14:43:18 UTC
SVN commit 1204476 by mart:

 ensure everything has been cleaned up when an extender item dies
BUG:257658


 M  +4 -0      extender.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1204476
Comment 12 Manuel Stol 2010-12-24 21:39:07 UTC
Created attachment 55213 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.85 (4.6 Beta2) using Qt 4.7.1

- Accedentally clicked on restart insteas of shutdown.
- While the notebook was starting-up showin the BIOS messages,
  I shutdown the notebook by keeping the power button pressed.
- The next time I booted the notebook, Plasma crashed.

Note:
- The plasma config files are read-only.

-- Backtrace (Reduced):
#6  Plasma::ExtenderItem::group (this=0xa37c00) at /usr/src/debug/kdelibs-4.5.85/plasma/extenders/extenderitem.cpp:476
#7  0x00007f1ddef341d6 in Plasma::Extender::itemAddedEvent (this=0x8a6da0, item=0xa37c00, pos=...) at /usr/src/debug/kdelibs-4.5.85/plasma/extenders/extender.cpp:490
#8  0x00007f1ddef346d4 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0x8f92b0) at /usr/src/debug/kdelibs-4.5.85/plasma/extenders/extender.cpp:805
#9  0x00007f1ddef35f82 in Plasma::Extender::qt_metacall (this=0x8a6da0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x9ebf40) at /usr/src/debug/kdelibs-4.5.85/build/plasma/extender.moc:105
#10 0x00007f1de81c9c6a in QObject::event (this=0x8a6da0, e=<value optimized out>) at kernel/qobject.cpp:1211
Comment 13 Ric 2011-02-05 22:47:04 UTC
Thanks ... :).