Bug 258867 - [steps] Plasma crashes on logout (related to the Weather Applet) [QGraphicsLayoutItem::setParentLayoutItem, QGraphicsLinearLayout::*, Plasma::TabBar::~TabBar, ..., ~BackgroundWidget]
Summary: [steps] Plasma crashes on logout (related to the Weather Applet) [QGraphicsLa...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 259133 259520 260674 260896 261348 261682 261804 261855 262360 262838 262976 263375 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-05 01:50 UTC by Alex Merry
Modified: 2011-01-24 12:36 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.0


Attachments
New crash information added by DrKonqi (8.24 KB, text/plain)
2010-12-14 22:39 UTC, Unknown
Details
New crash information added by DrKonqi (6.44 KB, text/plain)
2010-12-15 18:42 UTC, tom
Details
New crash information added by DrKonqi (8.02 KB, text/plain)
2010-12-23 11:29 UTC, Victor Santos
Details
New crash information added by DrKonqi (6.55 KB, text/plain)
2010-12-23 23:28 UTC, Stratos Zolotas
Details
New crash information added by DrKonqi (14.92 KB, text/plain)
2010-12-29 15:43 UTC, omega
Details
New crash information added by DrKonqi (9.01 KB, text/plain)
2011-01-01 05:25 UTC, Waleed Hamra
Details
New crash information added by DrKonqi (12.09 KB, text/plain)
2011-01-02 00:04 UTC, Ronald Holshausen
Details
New crash information added by DrKonqi (9.87 KB, text/plain)
2011-01-02 10:20 UTC, e.crepieux
Details
New crash information added by DrKonqi (19.58 KB, text/plain)
2011-01-14 23:39 UTC, Stratos Zolotas
Details
New crash information added by DrKonqi (16.04 KB, text/plain)
2011-01-24 08:03 UTC, Waleed Hamra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Merry 2010-12-05 01:50:58 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.5.82 (4.6 >=20101201) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.36-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

Plasma has crashed on logout the last couple of times (since I updated from trunk).  This was a completely clean build.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f336406b760 (LWP 4887))]

Thread 2 (Thread 0x7f33431ba710 (LWP 4893)):
#0  0x00007f3360c8b173 in poll () from /lib/libc.so.6
#1  0x00007f335d5aa134 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f335d5aa66d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f3362951fa6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f3362926252 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f336292649c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f336283bd64 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f3362907e38 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f336283e53e in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f33625b5cb0 in start_thread () from /lib/libpthread.so.0
#10 0x00007f3360c939dd in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f336406b760 (LWP 4887)):
[KCrash Handler]
#6  0x00007f33620b71d4 in QGraphicsLayoutItem::setParentLayoutItem(QGraphicsLayoutItem*) () from /usr/lib/libQtGui.so.4
#7  0x00007f33620b74ba in QGraphicsLinearLayout::removeAt(int) () from /usr/lib/libQtGui.so.4
#8  0x00007f33620b756c in QGraphicsLinearLayout::~QGraphicsLinearLayout() () from /usr/lib/libQtGui.so.4
#9  0x00007f33620b75c9 in QGraphicsLinearLayout::~QGraphicsLinearLayout() () from /usr/lib/libQtGui.so.4
#10 0x00007f33620b7590 in QGraphicsLinearLayout::~QGraphicsLinearLayout() () from /usr/lib/libQtGui.so.4
#11 0x00007f33620b75c9 in QGraphicsLinearLayout::~QGraphicsLinearLayout() () from /usr/lib/libQtGui.so.4
#12 0x00007f33620f7a81 in QGraphicsWidget::~QGraphicsWidget() () from /usr/lib/libQtGui.so.4
#13 0x00007f3358fcf1f5 in Plasma::TabBar::~TabBar (this=0x23175b0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/widgets/tabbar.cpp:269
#14 0x00007f3358fcf23a in Plasma::TabBar::~TabBar (this=0x23175b0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/widgets/tabbar.cpp:272
#15 0x00007f33620a77dc in QGraphicsItem::~QGraphicsItem() () from /usr/lib/libQtGui.so.4
#16 0x00007f33620f7af0 in QGraphicsWidget::~QGraphicsWidget() () from /usr/lib/libQtGui.so.4
#17 0x00007f33410dd9fe in BackgroundWidget::~BackgroundWidget (this=0x2020ca0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdeplasma-addons/applets/weather/weatherapplet.cpp:63
#18 0x00007f33410dda42 in BackgroundWidget::~BackgroundWidget (this=0x2020ca0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdeplasma-addons/applets/weather/weatherapplet.cpp:63
#19 0x00007f3362939884 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#20 0x00007f336293e3c2 in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#21 0x00007f33620f7af8 in QGraphicsWidget::~QGraphicsWidget() () from /usr/lib/libQtGui.so.4
#22 0x00007f3358e8c920 in Plasma::Applet::~Applet (this=0x2004c30, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/applet.cpp:199
#23 0x00007f3358f0d3c5 in Plasma::PopupApplet::~PopupApplet (this=0x2004c30, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/popupapplet.cpp:69
#24 0x00007f3340eb0791 in WeatherPopupApplet::~WeatherPopupApplet (this=0x2004c30, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdeplasma-addons/libs/plasmaweather/weatherpopupapplet.cpp:197
#25 0x00007f33410d32ca in WeatherApplet::~WeatherApplet (this=0x2004c30, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdeplasma-addons/applets/weather/weatherapplet.cpp:205
#26 0x00007f33410d330e in WeatherApplet::~WeatherApplet (this=0x2004c30, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdeplasma-addons/applets/weather/weatherapplet.cpp:207
#27 0x00007f33620a77dc in QGraphicsItem::~QGraphicsItem() () from /usr/lib/libQtGui.so.4
#28 0x00007f33620f7af0 in QGraphicsWidget::~QGraphicsWidget() () from /usr/lib/libQtGui.so.4
#29 0x00007f3345514f81 in SystemTray::TaskArea::~TaskArea (this=0x1accf60, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/generic/applets/systemtray/ui/taskarea.cpp:145
#30 0x00007f3345514fc6 in SystemTray::TaskArea::~TaskArea (this=0x1accf60, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/generic/applets/systemtray/ui/taskarea.cpp:152
#31 0x00007f3345506dc5 in SystemTray::Applet::~Applet (this=0x1ad1e40, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/generic/applets/systemtray/ui/applet.cpp:121
#32 0x00007f3345506fd0 in SystemTray::Applet::~Applet (this=0x1ad1e40, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/generic/applets/systemtray/ui/applet.cpp:139
#33 0x00007f3358ec29a6 in qDeleteAll<QList<Plasma::Applet*>::const_iterator> (begin=..., end=...) at /usr/include/QtCore/qalgorithms.h:322
#34 0x00007f3358ebfe3b in qDeleteAll<QList<Plasma::Applet*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#35 0x00007f3358ebf960 in Plasma::ContainmentPrivate::~ContainmentPrivate (this=0x1a2ace0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/private/containment_p.h:69
#36 0x00007f3358eaec35 in Plasma::Containment::~Containment (this=0x1a27cb0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/containment.cpp:148
#37 0x00007f3346ae4d16 in Panel::~Panel (this=0x1a27cb0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/desktop/containments/panel/panel.cpp:117
#38 0x00007f3346ae4d54 in Panel::~Panel (this=0x1a27cb0, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/desktop/containments/panel/panel.cpp:119
#39 0x00007f3358ed0944 in qDeleteAll<QList<Plasma::Containment*>::const_iterator> (begin=..., end=...) at /usr/include/QtCore/qalgorithms.h:322
#40 0x00007f3358ecf565 in qDeleteAll<QList<Plasma::Containment*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#41 0x00007f3358ece0a2 in Plasma::CoronaPrivate::~CoronaPrivate (this=0x16b9880, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/corona.cpp:84
#42 0x00007f3358ec9be9 in Plasma::Corona::~Corona (this=0x16af130, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdelibs/plasma/corona.cpp:315
#43 0x00007f33540d5d3a in DesktopCorona::~DesktopCorona (this=0x16af130, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/desktop/shell/desktopcorona.cpp:70
#44 0x00007f33540d5d6c in DesktopCorona::~DesktopCorona (this=0x16af130, __in_chrg=<value optimized out>) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/desktop/shell/desktopcorona.cpp:73
#45 0x00007f3354100ffb in PlasmaApp::cleanup (this=0x16091a0) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/desktop/shell/plasmaapp.cpp:369
#46 0x00007f33541071f7 in PlasmaApp::qt_metacall (this=0x16091a0, _c=QMetaObject::InvokeMetaMethod, _id=19, _a=0x7fffe3d0b2b0) at /home/kde-devel/build/KDE/kdebase/workspace/plasma/desktop/shell/plasmaapp.moc:159
#47 0x00007f336293c33f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#48 0x00007f336292a9c3 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#49 0x00007f33540e555c in kdemain (argc=1, argv=0x15f5ee0) at /home/kde-devel/src/KDE/kdebase/workspace/plasma/desktop/shell/main.cpp:118
#50 0x00000000004072d3 in launch (argc=1, _name=0x16015c8 "/home/kde-devel/kde/bin/plasma-desktop", args=0x16015ef "", cwd=0x0, envc=0, envs=0x16015f7 "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40cf55 "0") at /home/kde-devel/src/KDE/kdelibs/kinit/kinit.cpp:730
#51 0x00000000004083fa in handle_launcher_request (sock=8, who=0x40d1ec "launcher") at /home/kde-devel/src/KDE/kdelibs/kinit/kinit.cpp:1222
#52 0x0000000000408cae in handle_requests (waitForPid=0) at /home/kde-devel/src/KDE/kdelibs/kinit/kinit.cpp:1415
#53 0x000000000040a738 in main (argc=4, argv=0x7fffe3d0c148, envp=0x7fffe3d0c170) at /home/kde-devel/src/KDE/kdelibs/kinit/kinit.cpp:1901

Reported using DrKonqi
Comment 1 Marco Martin 2010-12-09 19:48:02 UTC
*** Bug 259133 has been marked as a duplicate of this bug. ***
Comment 2 Dario Andres 2010-12-11 15:11:53 UTC
[Comment from a bug triager]
Full backtrace from bug 259520:
Thread 1 (Thread 0x7f8320e17760 (LWP 6832)):
[KCrash Handler]
#6  0x00007f831f25b674 in QGraphicsLayoutItem::setParentLayoutItem
(this=0x150d900, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007f831f25b95a in QGraphicsLinearLayout::removeAt (this=<value
optimized out>, index=<value optimized out>) at
graphicsview/qgraphicslinearlayout.cpp:338
#8  0x00007f831f25ba0c in QGraphicsLinearLayout::~QGraphicsLinearLayout
(this=0x146bd00, __in_chrg=<value optimized out>) at
graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007f831f25ba69 in QGraphicsLinearLayout::~QGraphicsLinearLayout
(this=0x146bd00, __in_chrg=<value optimized out>) at
graphicsview/qgraphicslinearlayout.cpp:219
#10 0x00007f831f25ba30 in QGraphicsLinearLayout::~QGraphicsLinearLayout
(this=0xd946b0, __in_chrg=<value optimized out>) at
graphicsview/qgraphicslinearlayout.cpp:216
#11 0x00007f831f25ba69 in QGraphicsLinearLayout::~QGraphicsLinearLayout
(this=0xd946b0, __in_chrg=<value optimized out>) at
graphicsview/qgraphicslinearlayout.cpp:219
#12 0x00007f831f29c621 in QGraphicsWidget::~QGraphicsWidget (this=0x13f8290,
__in_chrg=<value optimized out>) at graphicsview/qgraphicswidget.cpp:272
#13 0x00007f8316920699 in Plasma::TabBar::~TabBar (this=0x13f8290,
__in_chrg=<value optimized out>) at
/usr/src/debug/kdelibs-4.5.85/plasma/widgets/tabbar.cpp:272
#14 0x00007f831f24b9bc in QGraphicsItem::~QGraphicsItem (this=0x131bf20,
__in_chrg=<value optimized out>) at graphicsview/qgraphicsitem.cpp:1481
#15 0x00007f831f29c690 in ~QGraphicsObject (this=0x131bf10, __in_chrg=<value
optimized out>) at ../../src/gui/graphicsview/qgraphicsitem.h:547
#16 QGraphicsWidget::~QGraphicsWidget (this=0x131bf10, __in_chrg=<value
optimized out>) at graphicsview/qgraphicswidget.cpp:232
#17 0x00007f82fe44b625 in ~BackgroundWidget (this=0x131bf10, __in_chrg=<value
optimized out>) at
/usr/src/debug/kdeplasma-addons-4.5.85/applets/weather/weatherapplet.cpp:63
#18 BackgroundWidget::~BackgroundWidget (this=0x131bf10, __in_chrg=<value
optimized out>) at
/usr/src/debug/kdeplasma-addons-4.5.85/applets/weather/weatherapplet.cpp:63
#19 0x00007f831fae53c4 in QObjectPrivate::deleteChildren (this=0x1317790) at
kernel/qobject.cpp:1949
#20 0x00007f831faea072 in QObject::~QObject (this=0x136a960, __in_chrg=<value
optimized out>) at kernel/qobject.cpp:945
#21 0x00007f831f29c698 in ~QGraphicsObject (this=0x136a960, __in_chrg=<value
optimized out>) at ../../src/gui/graphicsview/qgraphicsitem.h:547
#22 QGraphicsWidget::~QGraphicsWidget (this=0x136a960, __in_chrg=<value
optimized out>) at graphicsview/qgraphicswidget.cpp:232
#23 0x00007f831681ec33 in Plasma::Applet::~Applet (this=0x136a960,
__in_chrg=<value optimized out>) at
/usr/src/debug/kdelibs-4.5.85/plasma/applet.cpp:199
#24 0x00007f82fe43fee9 in WeatherApplet::~WeatherApplet (this=0x136a960,
__in_chrg=<value optimized out>) at
/usr/src/debug/kdeplasma-addons-4.5.85/applets/weather/weatherapplet.cpp:207
#25 0x00007f831f24b9bc in QGraphicsItem::~QGraphicsItem (this=0xd03890,
__in_chrg=<value optimized out>) at graphicsview/qgraphicsitem.cpp:1481
#26 0x00007f831f29c690 in ~QGraphicsObject (this=0xd03880, __in_chrg=<value
optimized out>) at ../../src/gui/graphicsview/qgraphicsitem.h:547
#27 QGraphicsWidget::~QGraphicsWidget (this=0xd03880, __in_chrg=<value
optimized out>) at graphicsview/qgraphicswidget.cpp:232
#28 0x00007f8301364f99 in SystemTray::TaskArea::~TaskArea (this=0xd03880,
__in_chrg=<value optimized out>)
    at
/usr/src/debug/kdebase-workspace-4.5.85/plasma/generic/applets/systemtray/ui/taskarea.cpp:152
#29 0x00007f830135b85d in SystemTray::Applet::~Applet (this=0xae9680,
__in_chrg=<value optimized out>) at
/usr/src/debug/kdebase-workspace-4.5.85/plasma/generic/applets/systemtray/ui/applet.cpp:121
#30 0x00007f830135ba69 in SystemTray::Applet::~Applet (this=0xae9680,
__in_chrg=<value optimized out>) at
/usr/src/debug/kdebase-workspace-4.5.85/plasma/generic/applets/systemtray/ui/applet.cpp:139
#31 0x00007f831682f02f in qDeleteAll<QList<Plasma::Applet*>::const_iterator>
(this=0xaff0f0, __in_chrg=<value optimized out>) at
/usr/include/QtCore/qalgorithms.h:322
#32 qDeleteAll<QList<Plasma::Applet*> > (this=0xaff0f0, __in_chrg=<value
optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#33 ~ContainmentPrivate (this=0xaff0f0, __in_chrg=<value optimized out>) at
/usr/src/debug/kdelibs-4.5.85/plasma/private/containment_p.h:70
#34 Plasma::Containment::~Containment (this=0xaff0f0, __in_chrg=<value
optimized out>) at /usr/src/debug/kdelibs-4.5.85/plasma/containment.cpp:160
#35 0x00007f83033e0679 in Panel::~Panel (this=0xaff0f0, __in_chrg=<value
optimized out>) at
/usr/src/debug/kdebase-workspace-4.5.85/plasma/desktop/containments/panel/panel.cpp:119
#36 0x00007f8316840d9f in
qDeleteAll<QList<Plasma::Containment*>::const_iterator> (this=0x733fb0,
__in_chrg=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#37 qDeleteAll<QList<Plasma::Containment*> > (this=0x733fb0, __in_chrg=<value
optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#38 ~CoronaPrivate (this=0x733fb0, __in_chrg=<value optimized out>) at
/usr/src/debug/kdelibs-4.5.85/plasma/corona.cpp:84
#39 Plasma::Corona::~Corona (this=0x733fb0, __in_chrg=<value optimized out>) at
/usr/src/debug/kdelibs-4.5.85/plasma/corona.cpp:317
#40 0x00007f831061b439 in DesktopCorona::~DesktopCorona (this=0x733fb0,
__in_chrg=<value optimized out>) at
/usr/src/debug/kdebase-workspace-4.5.85/plasma/desktop/shell/desktopcorona.cpp:73
#41 0x00007f831063d1b6 in PlasmaApp::cleanup (this=0x6bb830) at
/usr/src/debug/kdebase-workspace-4.5.85/plasma/desktop/shell/plasmaapp.cpp:369
#42 0x00007f831064057d in PlasmaApp::qt_metacall (this=0x6bb830,
_c=QMetaObject::InvokeMetaMethod, _id=19, _a=0x7fff0b8e31d0)
    at
/usr/src/debug/kdebase-workspace-4.5.85/build/plasma/desktop/shell/plasmaapp.moc:159
#43 0x00007f831fae7fef in QMetaObject::activate (sender=0x6bb830, m=<value
optimized out>, local_signal_index=<value optimized out>, argv=0x0) at
kernel/qobject.cpp:3272
#44 0x00007f831fad6903 in QCoreApplication::exec () at
kernel/qcoreapplication.cpp:1014
#45 0x00007f8310626808 in kdemain (argc=1, argv=0x684df0) at
/usr/src/debug/kdebase-workspace-4.5.85/plasma/desktop/shell/main.cpp:118
#46 0x0000000000407609 in _start ()
Comment 3 Dario Andres 2010-12-11 15:12:01 UTC
*** Bug 259520 has been marked as a duplicate of this bug. ***
Comment 4 Dario Andres 2010-12-11 15:59:53 UTC
[Comment from a bug triager]
I can reproduce this bug some of the times on KDE SC 4.6beta2 + Qt 4.7.1 on ArchLinux 686 (running on a VM).

- Add a Weather Forecast widget to the desktop
- Configure a location for it
The information is displayed
- Click on the tabbar which switches the widget's mode (current info - forecast). Switch the tabs a couple of times (clicking on both of them in the tabbar, or using the mouse scroll on the tabbar).
- If you remover the Weather Forecast widget, or if you restart plasma (with kquitapp), Plasma will crash

Important Note: trying to reproduce this crash using plasmoidviewer seems to have more reproducibility rate than trying it on Plasma Desktop
Comment 5 Dario Andres 2010-12-11 16:47:38 UTC
[Comment from a bug triager]
The crash can also be reproduced on:
KDE Development Platform: 4.5.86 (4.6 >= 20101210), Qt: 4.7.1
kdelibs SVN Revision: 1205555
kdebase SVN Revision: 1205555
on ArchLinux i686 (2.6.36-ARCH)
Comment 6 JanKusanagi 2010-12-11 19:21:43 UTC
I get a similar crash sometimes, also on logout (4.6beta2 on Archlinux).
My trace wasn't useful, but it seemed to be related to the weather plasmoid, which, in my case, has been there for ages, before upgrading to 4.6 beta 1 and later beta 2.
I'll try removing it and see if it happens again.
Comment 7 Unknown 2010-12-14 22:39:03 UTC
Created attachment 54560 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.85 (4.6 Beta2) using Qt 4.7.1

Plasma crashed when I logged out from KDE and tried to restart machine.

-- Backtrace (Reduced):
#6  0x00007f2f38925674 in QGraphicsLayoutItem::setParentLayoutItem (this=0xe8b010, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007f2f3892595a in QGraphicsLinearLayout::removeAt (this=<value optimized out>, index=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:338
#8  0x00007f2f38925a0c in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xe95710, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007f2f38925a69 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xe95710, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:219
#10 0x00007f2f38925a30 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xe85820, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
Comment 8 tom 2010-12-15 18:42:33 UTC
Created attachment 54595 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.85 (4.6 Beta2) using Qt 4.7.1

- What I was doing when the application crashed:
I was shutting down my computer, than i got this crash report.

-- Backtrace (Reduced):
#6  0x00007f7469853f04 in QGraphicsLayoutItem::setParentLayoutItem (this=0xee1ea0, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007f74698541ea in QGraphicsLinearLayout::removeAt (this=<value optimized out>, index=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:338
#8  0x00007f746985429c in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xe9bb00, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007f74698542f9 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xe9bb00, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:219
#10 0x00007f74698542c0 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xeb5dd0, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
Comment 9 Beat Wolf 2010-12-19 13:03:37 UTC
*** Bug 260674 has been marked as a duplicate of this bug. ***
Comment 10 Dario Andres 2010-12-21 17:57:16 UTC
*** Bug 260896 has been marked as a duplicate of this bug. ***
Comment 11 Victor Santos 2010-12-23 11:29:31 UTC
Created attachment 55185 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.85 (4.6 Beta2) using Qt 4.7.0

- What I was doing when the application crashed:

KDE crash when I logoff, restart or shutdown PC. If I do it on console nothing happens.

-- Backtrace (Reduced):
#6  0x00007ffeea713694 in QGraphicsLayoutItem::setParentLayoutItem (this=0x143c910, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007ffeea714c8a in QGraphicsLinearLayout::removeAt (this=0x143c620, index=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:334
#8  0x00007ffeea714d3c in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x143c620, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007ffeea714d60 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x149a340, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
#10 0x00007ffeea75af94 in QGraphicsWidget::~QGraphicsWidget (this=0x13dded0, __in_chrg=<value optimized out>) at graphicsview/qgraphicswidget.cpp:272
Comment 12 Dario Andres 2010-12-23 13:33:36 UTC
[Comment from a bug triager]
Some investigation:

Commenting out the line
"m_tabBar->setTabBarShown(m_tabBar->count() > 1);"
in weatherapplet.cpp:742 seems to fix the crash!

These commits may be related:
http://websvn.kde.org/?view=revision&revision=1201861 (weather applet)
and
http://websvn.kde.org/?view=revision&revision=1202099 (libplasma tabbar)

@Marco; Davide: may be you can look at this ?

Thanks
Comment 13 Stratos Zolotas 2010-12-23 23:28:42 UTC
Created attachment 55200 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.1

Justto report that i have upgraded to 4.5.90 and it seems that the bug still exists.

-- Backtrace (Reduced):
#6  0x00007fdbe3422674 in QGraphicsLayoutItem::setParentLayoutItem (this=0xacb8c0, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007fdbe342295a in QGraphicsLinearLayout::removeAt (this=<value optimized out>, index=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:338
#8  0x00007fdbe3422a0c in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xaea680, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007fdbe3422a69 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xaea680, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:219
#10 0x00007fdbe3422a30 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xad3f70, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
Comment 14 Nicolas L. 2010-12-27 09:37:29 UTC
*** Bug 261348 has been marked as a duplicate of this bug. ***
Comment 15 omega 2010-12-29 15:43:26 UTC
Created attachment 55351 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.1

- What I was doing when the application crashed:

I was shutting down my computer, than i got this crash report.

-- Backtrace (Reduced):
#6  0x00007f2aab8256e4 in QGraphicsLayoutItem::setParentLayoutItem (this=0x1fedeb0, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007f2aab8259ca in QGraphicsLinearLayout::removeAt (this=0x1ff7970, index=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:338
#8  0x00007f2aab825a7c in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x1ff7970, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007f2aab825ad9 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x1ff7970, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:219
#10 0x00007f2aab825aa0 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x1f56ed0, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
Comment 16 Christoph Feck 2011-01-01 03:56:17 UTC
*** Bug 261682 has been marked as a duplicate of this bug. ***
Comment 17 Waleed Hamra 2011-01-01 05:25:02 UTC
Created attachment 55433 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.0

- What I was doing when the application crashed:
logging out of KDE
OR
removing the weather forecast widget

- Custom settings of the application:
the weather forecast widget is added somewhere on desktop or the panels.
if widget is not added, KDE logs out without a crash.

-- Backtrace (Reduced):
#7  0x06a66c3c in QGraphicsLayoutItem::setParentLayoutItem (this=0xa7b8460, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#8  0x06a6841d in QGraphicsLinearLayout::removeAt (this=0xa7b0a90, index=0) at graphicsview/qgraphicslinearlayout.cpp:334
#9  0x06a684c5 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xa7b0a90, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#10 0x06a684ed in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xa7b88f8, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
#11 0x06ab3060 in QGraphicsWidget::~QGraphicsWidget (this=0xa7c24b0, __in_chrg=<value optimized out>) at graphicsview/qgraphicswidget.cpp:272
Comment 18 Christoph Feck 2011-01-01 20:18:02 UTC
*** Bug 261804 has been marked as a duplicate of this bug. ***
Comment 19 Ronald Holshausen 2011-01-02 00:04:31 UTC
Created attachment 55457 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.0

- What I was doing when the application crashed:
This crash occurs when logging out or shutting down

-- Backtrace (Reduced):
#6  0x00007f3a4f94b694 in QGraphicsLayoutItem::setParentLayoutItem (this=0x3d02440, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007f3a4f94cc8a in QGraphicsLinearLayout::removeAt (this=0x3ce62e0, index=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:334
#8  0x00007f3a4f94cd3c in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x3ce62e0, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007f3a4f94cd60 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x3dcd8e0, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
#10 0x00007f3a4f992f94 in QGraphicsWidget::~QGraphicsWidget (this=0x3ea3180, __in_chrg=<value optimized out>) at graphicsview/qgraphicswidget.cpp:272
Comment 20 e.crepieux 2011-01-02 10:20:37 UTC
Created attachment 55461 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.90 (4.6 RC1) using Qt 4.7.0

- What I was doing when the application crashed:
I was shutting down my computer.
however, it doesn't happen every time.
I'm running Kubuntu 10.10

-- Backtrace (Reduced):
#7  0x05f1fc3c in QGraphicsLayoutItem::setParentLayoutItem (this=0xa0c3748, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#8  0x05f2141d in QGraphicsLinearLayout::removeAt (this=0x9fc0f70, index=0) at graphicsview/qgraphicslinearlayout.cpp:334
#9  0x05f214c5 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x9fc0f70, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#10 0x05f214ed in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x9f918f0, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
#11 0x05f6c060 in QGraphicsWidget::~QGraphicsWidget (this=0xa07aac8, __in_chrg=<value optimized out>) at graphicsview/qgraphicswidget.cpp:272
Comment 21 Dario Andres 2011-01-02 12:52:04 UTC
*** Bug 261855 has been marked as a duplicate of this bug. ***
Comment 22 Alex Merry 2011-01-06 21:35:09 UTC
SVN commit 1212395 by alexmerry:

Don't add the tabbar to the layout twice, or try to remove it twice.

BUG: 258867



 M  +3 -0      tabbar.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1212395
Comment 23 Alex Merry 2011-01-06 21:38:18 UTC
SVN commit 1212396 by alexmerry:

Backport r258867: Don't add the tabbar to the layout twice, or try to remove it twice.

CCBUG: 258867



 M  +3 -0      tabbar.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1212396
Comment 24 Christoph Feck 2011-01-07 02:33:47 UTC
*** Bug 262360 has been marked as a duplicate of this bug. ***
Comment 25 Aaron J. Seigo 2011-01-07 20:26:24 UTC
*** Bug 259133 has been marked as a duplicate of this bug. ***
Comment 26 Marco Martin 2011-01-11 20:30:35 UTC
*** Bug 262838 has been marked as a duplicate of this bug. ***
Comment 27 Aaron J. Seigo 2011-01-12 19:57:37 UTC
*** Bug 262976 has been marked as a duplicate of this bug. ***
Comment 28 Marcelo Bossoni 2011-01-13 15:46:00 UTC
Same here:
KDE 4.6 RC2 from Kubuntu PPA repositories for maverick

Thread 10 (Thread 0x7f03170c8700 (LWP 1850)):
#0  0x00007f033c754203 in poll () from /lib/libc.so.6
#1  0x00007f0331505009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f033150545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f0339ad71e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f0339aa9a02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f0339aa9dec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f03399b42fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f0339a895f8 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#11 0x00007f033c76092d in clone () from /lib/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f03166bd700 (LWP 1851)):
#0  0x00007f033c77035b in pthread_mutex_lock () from /lib/libc.so.6
#1  0x00007f0331504a43 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x00007f0331504e78 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f033150545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f0339ad71e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f0339aa9a02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f0339aa9dec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f03399b42fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x00007f0339a895f8 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#12 0x00007f033c76092d in clone () from /lib/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f0315ebc700 (LWP 1852)):
#0  0xffffffffff60014c in ?? ()
#1  0x00007f0315ebb9b0 in ?? ()
#2  0x00007fffc3bff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 7 (Thread 0x7f031053b700 (LWP 1905)):
#0  0x00007f0331bbac70 in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0x00007f0331504ded in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f033150545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f0339ad71e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f0339aa9a02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f0339aa9dec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f03399b42fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f0339a895f8 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#11 0x00007f033c76092d in clone () from /lib/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f030ed38700 (LWP 2313)):
#0  0x00007f0331bbba9c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f03399b7e3b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0335d42d64 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f0335d45f6b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f0335d444df in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f0335d44a38 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#8  0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#9  0x00007f033c76092d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f030f539700 (LWP 2314)):
#0  0x00007f0331bbba9c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f03399b7e3b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0335d42d64 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f0335d45f6b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f0335d444df in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f0335d44a38 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#8  0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#9  0x00007f033c76092d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f030fd3a700 (LWP 2315)):
#0  0x00007f0331bbba9c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f03399b7e3b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0335d42d64 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f0335d45f6b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f0335d444df in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f0335d44a38 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#8  0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#9  0x00007f033c76092d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f0311946700 (LWP 2316)):
#0  0x00007f0331bbba9c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f03399b7e3b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0335d42d64 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f0335d45f6b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f0335d444df in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f0335d44a38 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#8  0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#9  0x00007f033c76092d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f030bd18700 (LWP 2317)):
#0  0x00007f0331bbba9c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f03399b7e3b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0335d42d64 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f0335d45f6b in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f0335d444df in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f0335d44a38 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f03399b727e in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f0334d35ae3 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#8  0x00007f0331bb7971 in start_thread () from /lib/libpthread.so.0
#9  0x00007f033c76092d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f033ce547a0 (LWP 1846)):
[KCrash Handler]
#6  0x00007f0339449694 in QGraphicsLayoutItem::setParentLayoutItem(QGraphicsLayoutItem*) () from /usr/lib/libQtGui.so.4
#7  0x00007f033944ac8a in QGraphicsLinearLayout::removeAt(int) () from /usr/lib/libQtGui.so.4
#8  0x00007f033944ad3c in QGraphicsLinearLayout::~QGraphicsLinearLayout() () from /usr/lib/libQtGui.so.4
#9  0x00007f033944ad60 in QGraphicsLinearLayout::~QGraphicsLinearLayout() () from /usr/lib/libQtGui.so.4
#10 0x00007f0339490f94 in QGraphicsWidget::~QGraphicsWidget() () from /usr/lib/libQtGui.so.4
#11 0x00007f033c3718b5 in Plasma::TabBar::~TabBar() () from /usr/lib/libplasma.so.3
#12 0x00007f03394331df in QGraphicsItem::~QGraphicsItem() () from /usr/lib/libQtGui.so.4
#13 0x00007f0339491090 in QGraphicsWidget::~QGraphicsWidget() () from /usr/lib/libQtGui.so.4
#14 0x00007f031f4c9be5 in ?? () from /usr/lib/kde4/plasma_applet_weather.so
#15 0x00007f03394331df in QGraphicsItem::~QGraphicsItem() () from /usr/lib/libQtGui.so.4
#16 0x00007f0339491090 in QGraphicsWidget::~QGraphicsWidget() () from /usr/lib/libQtGui.so.4
#17 0x00007f033c2570cb in Plasma::Applet::~Applet() () from /usr/lib/libplasma.so.3
#18 0x00007f031f4bd597 in ?? () from /usr/lib/kde4/plasma_applet_weather.so
#19 0x00007f033c27462f in Plasma::Containment::~Containment() () from /usr/lib/libplasma.so.3
#20 0x00007f031fb661e9 in ?? () from /usr/lib/kde4/plasma_containment_desktop.so
#21 0x00007f033c28458f in Plasma::Corona::~Corona() () from /usr/lib/libplasma.so.3
#22 0x00007f033ca31814 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#23 0x00007f033ca55796 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#24 0x00007f033ca5b98d in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#25 0x00007f0339ac2b27 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#26 0x00007f0339aadee3 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#27 0x00007f033ca3eca3 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#28 0x00007f033c698d8e in __libc_start_main () from /lib/libc.so.6
#29 0x0000000000400669 in _start ()
Comment 29 Stratos Zolotas 2011-01-14 23:39:07 UTC
Created attachment 56031 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.1

- What I was doing when the application crashed:

Still getting this crash (4.6RC2) and i don't have the weather applet activated. It is the same or not?

-- Backtrace (Reduced):
#6  0x00007feae3620674 in QGraphicsLayoutItem::setParentLayoutItem (this=0xb31ff0, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#7  0x00007feae362095a in QGraphicsLinearLayout::removeAt (this=<value optimized out>, index=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:338
#8  0x00007feae3620a0c in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xaf1590, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#9  0x00007feae3620a69 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xaf1590, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:219
#10 0x00007feae3620a30 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0xad1cd0, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
Comment 30 Dario Andres 2011-01-14 23:47:32 UTC
[Comment from a bug triager]
- The fix is not included in KDE SC 4.6 RC2
@Stratos Zolotas: the weather applet is mentioned in your backtrace.
Regards
Comment 31 Stratos Zolotas 2011-01-15 00:05:09 UTC
Thanks for the answer. Looking forward for the final release!!!

Yes i saw that the weather applet is mentioned, but i have not activated it. Is this normal?

Excuse my lack of deeper knowledge on the subject.

Best regards.
Comment 32 Alex Merry 2011-01-15 04:51:30 UTC
It's the same crash, and (from your backtrace) it's still the weather applet causing trouble.
Comment 33 Dario Andres 2011-01-18 00:51:19 UTC
*** Bug 263375 has been marked as a duplicate of this bug. ***
Comment 34 Waleed Hamra 2011-01-24 08:03:44 UTC
Created attachment 56371 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.0

- What I was doing when the application crashed:

removing the weather forecast widget
this is KDE 4.6 RC2, and bug still happening. not sure why it's marked fixed.

-- Backtrace (Reduced):
#7  0x01940c3c in QGraphicsLayoutItem::setParentLayoutItem (this=0x975ed88, parent=0x0) at graphicsview/qgraphicslayoutitem.cpp:793
#8  0x0194241d in QGraphicsLinearLayout::removeAt (this=0x94ce6b8, index=0) at graphicsview/qgraphicslinearlayout.cpp:334
#9  0x019424c5 in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x94ce6b8, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:212
#10 0x019424ed in QGraphicsLinearLayout::~QGraphicsLinearLayout (this=0x96db6d0, __in_chrg=<value optimized out>) at graphicsview/qgraphicslinearlayout.cpp:216
#11 0x0198d060 in QGraphicsWidget::~QGraphicsWidget (this=0x984dc50, __in_chrg=<value optimized out>) at graphicsview/qgraphicswidget.cpp:272
Comment 35 Alex Merry 2011-01-24 12:36:00 UTC
Because it was fixed after 4.6 RC2.  The fix will be in the next release in the 4.6 series (RC3 or the final release).