Bug 258740 - Changing color theme and programming
Summary: Changing color theme and programming
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: 3.7
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-03 22:15 UTC by naether.markus
Modified: 2010-12-03 23:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description naether.markus 2010-12-03 22:15:45 UTC
Application: kmix (3.7)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35.6-45.fc14.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
Just programming within KWrite and compiling within the Konsole.
Some hours befor that I changed the color theme.

-- Backtrace:
Application: KMix (kmix), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x0000003f85a22933 in SharedMemory::removeEntry (this=0x7fd0fd54b000, index=9304) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1160
#7  0x0000003f85a23dc8 in KSharedDataCache::insert (this=0x1c71370, key=..., data=...) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1269
#8  0x0000003f88a8e85d in KImageCache::insertImage (this=0x1c71370, key=..., image=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:86
#9  0x0000003f88a8eec6 in KImageCache::insertPixmap (this=0x1c71370, key=..., pixmap=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:105
#10 0x0000003f929c8df5 in Plasma::ThemePrivate::scheduledCacheUpdate (this=0x1c67fe0) at /usr/src/debug/kdelibs-4.5.2/plasma/theme.cpp:272
#11 0x0000003f929cb442 in Plasma::Theme::qt_metacall (this=0x1c67f20, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x7fff69ac8470) at /usr/src/debug/kdelibs-4.5.2/x86_64-redhat-linux-gnu/plasma/theme.moc:119
#12 0x0000003f82f7003f in QMetaObject::activate (sender=0x1c6cc30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#13 0x0000003f82f6f869 in QObject::event (this=0x1c6cc30, e=<value optimized out>) at kernel/qobject.cpp:1175
#14 0x0000003f873b4b64 in QApplicationPrivate::notify_helper (this=0x1b55340, receiver=0x1c6cc30, e=0x7fff69ac8bc0) at kernel/qapplication.cpp:4396
#15 0x0000003f873b95da in QApplication::notify (this=<value optimized out>, receiver=0x1c6cc30, e=0x7fff69ac8bc0) at kernel/qapplication.cpp:4277
#16 0x0000003f88a20416 in KApplication::notify (this=0x1b46580, receiver=0x1c6cc30, event=0x7fff69ac8bc0) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#17 0x0000003f82f5b7bc in QCoreApplication::notifyInternal (this=0x1b46580, receiver=0x1c6cc30, event=0x7fff69ac8bc0) at kernel/qcoreapplication.cpp:732
#18 0x0000003f82f89402 in sendEvent (this=0x1b5cb70) at kernel/qcoreapplication.h:215
#19 QTimerInfoList::activateTimers (this=0x1b5cb70) at kernel/qeventdispatcher_unix.cpp:602
#20 0x0000003f82f86218 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#21 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#22 0x0000003f7c641e33 in g_main_dispatch (context=0x1b5b920) at gmain.c:2149
#23 g_main_context_dispatch (context=0x1b5b920) at gmain.c:2702
#24 0x0000003f7c642610 in g_main_context_iterate (context=0x1b5b920, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#25 0x0000003f7c6428ad in g_main_context_iteration (context=0x1b5b920, may_block=1) at gmain.c:2843
#26 0x0000003f82f868df in QEventDispatcherGlib::processEvents (this=0x1b2b090, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#27 0x0000003f874587ae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x0000003f82f5ab52 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x0000003f82f5ad9c in QEventLoop::exec (this=0x7fff69ac8e40, flags=...) at kernel/qeventloop.cpp:201
#30 0x0000003f82f5f21b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#31 0x0000003f8ca2346a in kdemain (argc=1, argv=0x7fff69ac93c8) at /usr/src/debug/kdemultimedia-4.5.2/kmix/main.cpp:72
#32 0x0000003f7a21ee7d in __libc_start_main (main=0x400890 <main(int, char**)>, argc=1, ubp_av=0x7fff69ac93c8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff69ac93b8) at libc-start.c:226
#33 0x00000000004007b9 in _start ()

Possible duplicates by query: bug 256072, bug 254625, bug 253795.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-12-03 23:43:41 UTC

*** This bug has been marked as a duplicate of bug 253795 ***