Bug 256072 - Plasma Crashing After Login
Summary: Plasma Crashing After Login
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kshareddatacache (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 20:06 UTC by consigliog
Modified: 2010-11-04 21:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description consigliog 2010-11-04 20:06:09 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35.6-48.fc14.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
nothing at all, i just open the new session and the deskopt crashes

-- Backtrace:
Application: Spazio di lavoro di Plasma (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f33e3bf7840 (LWP 2436))]

Thread 2 (Thread 0x7f33c3270700 (LWP 2518)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f33e75dace4 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f33e78f2d80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f33e75dad19 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f33e7900e54) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00000038e4c06d5b in start_thread (arg=0x7f33c3270700) at pthread_create.c:301
#4  0x00000038e40e427d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f33e3bf7840 (LWP 2436)):
[KCrash Handler]
#6  0x00000038ef822933 in SharedMemory::removeEntry (this=0x7f33d2818000, index=9972) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1160
#7  0x00000038ef823dc8 in KSharedDataCache::insert (this=0xfb6920, key=..., data=...) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kshareddatacache.cpp:1269
#8  0x00000038f168e85d in KImageCache::insertImage (this=0xfb6920, key=..., image=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:86
#9  0x00000038f168eec6 in KImageCache::insertPixmap (this=0xfb6920, key=..., pixmap=...) at /usr/src/debug/kdelibs-4.5.2/kdeui/util/kimagecache.cpp:105
#10 0x00000038f9bc8df5 in Plasma::ThemePrivate::scheduledCacheUpdate (this=0xfaf740) at /usr/src/debug/kdelibs-4.5.2/plasma/theme.cpp:272
#11 0x00000038f9bcb442 in Plasma::Theme::qt_metacall (this=0xfa1aa0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x7fff19f24570) at /usr/src/debug/kdelibs-4.5.2/x86_64-redhat-linux-gnu/plasma/theme.moc:119
#12 0x00007f33e694f02f in QMetaObject::activate (sender=0xfb5b20, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#13 0x00007f33e694e859 in QObject::event (this=0xfb5b20, e=<value optimized out>) at kernel/qobject.cpp:1175
#14 0x00007f33e5d0cb64 in QApplicationPrivate::notify_helper (this=0xe94070, receiver=0xfb5b20, e=0x7fff19f24cc0) at kernel/qapplication.cpp:4396
#15 0x00007f33e5d115da in QApplication::notify (this=<value optimized out>, receiver=0xfb5b20, e=0x7fff19f24cc0) at kernel/qapplication.cpp:4277
#16 0x00000038f1620416 in KApplication::notify (this=0xe822b0, receiver=0xfb5b20, event=0x7fff19f24cc0) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#17 0x00007f33e693a7ac in QCoreApplication::notifyInternal (this=0xe822b0, receiver=0xfb5b20, event=0x7fff19f24cc0) at kernel/qcoreapplication.cpp:732
#18 0x00007f33e69683d2 in sendEvent (this=0xe977f0) at kernel/qcoreapplication.h:215
#19 QTimerInfoList::activateTimers (this=0xe977f0) at kernel/qeventdispatcher_unix.cpp:602
#20 0x00007f33e69651e8 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#21 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#22 0x00000038e5c41e33 in g_main_dispatch (context=0xe96920) at gmain.c:2149
#23 g_main_context_dispatch (context=0xe96920) at gmain.c:2702
#24 0x00000038e5c42610 in g_main_context_iterate (context=0xe96920, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#25 0x00000038e5c428ad in g_main_context_iteration (context=0xe96920, may_block=1) at gmain.c:2843
#26 0x00007f33e69658af in QEventDispatcherGlib::processEvents (this=0xe68700, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#27 0x00007f33e5db06ee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f33e6939b42 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f33e6939d8c in QEventLoop::exec (this=0x7fff19f24f40, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007f33e693e20b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#31 0x00000038f823802b in kdemain (argc=1, argv=0x7fff19f25328) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#32 0x00000038e401ee7d in __libc_start_main (main=0x400920 <main(int, char**)>, argc=1, ubp_av=0x7fff19f25328, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff19f25318) at libc-start.c:226
#33 0x0000000000400849 in _start ()

This bug may be a duplicate of or related to bug 253795.

Possible duplicates by query: bug 255719, bug 255717, bug 255709, bug 254625, bug 254176.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-11-04 21:00:42 UTC

*** This bug has been marked as a duplicate of bug 253795 ***