Bug 258125 - Plasma calendar and calendar dataengine calendar have no akonadi events
Summary: Plasma calendar and calendar dataengine calendar have no akonadi events
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-clock (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: John Layt
URL:
Keywords:
: 264637 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-27 23:13 UTC by Andreas Kuhl
Modified: 2011-08-03 05:58 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kuhl 2010-11-27 23:13:40 UTC
Version:           unspecified (using KDE 4.5.80) 
OS:                Linux

I fetched my events with Akonadi GroupDAV agent from eGroupWare. Akonadi Console browser no shows me that "eGroupWare -> Calendar" has multiple events of mime type "application/xvnd.aonadi.calendar.event". The events doappear in KOrganizer (version 4.6 pre).

But plasmaengineexplorer shows that engine "calendar" is empty. I queried it with "events:2010-01-01:2011-01-01" and several events should be within this year. But no event shows. Therefore, the calendar plasmoid only shows holidays but no events show up.

What's wrong here?

Reproducible: Always
Comment 1 Ezio Vergine 2011-01-27 01:26:11 UTC
Same issue for me.
kde 4.6.0 on kubuntu 10.10
Comment 2 John Layt 2011-02-02 01:03:53 UTC
*** Bug 264637 has been marked as a duplicate of this bug. ***
Comment 3 John Layt 2011-03-02 00:42:54 UTC
Git commit 226c69c40de9db1b749c663cb08c97de9ed57f8b by John Layt.
Committed on 27/02/2011 at 17:43.
Pushed by jlayt into branch 'KDE/4.6'.

Plasma Calendar: Re-enable akonadi event updates

Fix the plasma calendar to set the right flag to indicate a refresh of
the akonadi events is required.  This should fix the problem, but while
I have confirmed this does now send a query to akonadi again, I don't
get any events back, but this si probably an artifact of my test
environment, it should work ok once in a full desktop/akonadi
environment.

CCBUG: 258125

M  +1    -1    libs/plasmaclock/calendartable.cpp     

http://commits.kde.org/kde-workspace/226c69c40de9db1b749c663cb08c97de9ed57f8b
Comment 4 John Layt 2011-03-02 01:26:49 UTC
Git commit de8cbed0e7a9951c5ef994da89361b23de020efd by John Layt.
Committed on 27/02/2011 at 17:43.
Pushed by jlayt into branch 'master'.

Plasma Calendar: Re-enable akonadi event updates

Fix the plasma calendar to set the right flag to indicate a refresh of
the akonadi events is required.  This should fix the problem, but while
I have confirmed this does now send a query to akonadi again, I don't
get any events back, but this si probably an artifact of my test
environment, it should work ok once in a full desktop/akonadi
environment.

CCBUG: 258125
(cherry picked from commit 226c69c40de9db1b749c663cb08c97de9ed57f8b)

M  +1    -1    libs/plasmaclock/calendartable.cpp     

http://commits.kde.org/kde-workspace/de8cbed0e7a9951c5ef994da89361b23de020efd
Comment 5 Will Stephenson 2011-03-15 10:11:03 UTC
can anyone confirm this is fixed now?
Comment 6 Anders Lund 2011-03-15 10:48:20 UTC
When I installed 4.6.1, the calendar stopped indicating events, so the problem is currently hidden. I hope the events will turn up again with 4.6.2, it is such a nice feature :)
Comment 7 Christian (Fuchs) 2011-04-16 00:08:10 UTC
This problem still exists in 4.6.2, the calendar is not able to show any events other than holidays, and the events are not appearing in plasmaengineexplorer as well. 

Kind regards
Comment 8 Andreas Kuhl 2011-04-16 09:52:28 UTC
Still not working for me in KDE SC 4.6.2 with a Google calendar Akonadi resource. The events are shown in KOrganizer but not in Plasma calendar. :-(
Comment 9 Ryan Rix 2011-05-10 18:28:39 UTC
Git commit 27bbec14986188825bca4a5af65a27284a34c1a3 by Ryan Rix.
Committed on 10/05/2011 at 18:26.
Pushed by ryanrix into branch 'master'.

BUGFIX: Correctly populate incidenceData's Type

KCalCore::Event, KCalCore::Todo, etc have type() method which returns
the enum value, and typeStr() which returns string values. calendar engine
works with the strings, not sure how this ever worked, but it works now :)

BUG: 258125

M  +1    -1    plasma/generic/dataengines/calendar/eventdatacontainer.cpp     

http://commits.kde.org/kde-workspace/27bbec14986188825bca4a5af65a27284a34c1a3
Comment 10 Ryan Rix 2011-05-10 18:58:42 UTC
Git commit d060ab6125229772439af5b7c5171a5edfd12ea5 by Ryan Rix.
Committed on 10/05/2011 at 18:57.
Pushed by ryanrix into branch 'KDE/4.6'.

BUGFIX: Correctly populate incidenceData's Type

Backport of 27bbec14986188825bca4a5af65a27284a34c1a3 to KDE/4.6

BUG: 258125

M  +1    -1    plasma/generic/dataengines/calendar/eventdatacontainer.cpp     

http://commits.kde.org/kde-workspace/d060ab6125229772439af5b7c5171a5edfd12ea5
Comment 11 Christian (Fuchs) 2011-05-11 20:09:42 UTC
Fix confirmed, thanks a lot for the good work. 

Interesting to see that such a small change can get this to work again. 

Kind regards
Comment 12 Nayar Joolfoo 2011-08-03 05:58:13 UTC
Is this bug fix incorporated in KDE 4.7?