Bug 257953 - Missing switches
Summary: Missing switches
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: HI normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-26 11:06 UTC by Kristjan Ugrin
Modified: 2011-12-30 10:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
SB Live 51, output of amixer (10.85 KB, text/plain)
2011-12-14 20:06 UTC, Roman Fietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kristjan Ugrin 2010-11-26 11:06:18 UTC
Version:           unspecified (using KDE 4.5.80) 
OS:                Linux

With newest 4.6b1 I'm missing some features like Tone switch.
Without it, I cannot enable tone correction, though sliders for bass / treble are
available. They are listed and available in alsamixer and previous kmix from 4.5.

Reproducible: Didn't try




Sound card: SB Live! 5.1 Digital
Comment 1 Roman Fietze 2011-10-08 15:12:43 UTC
Still true for kmix 3.8.

Package from openSUSE repos Release:/46

Can turn on Tone switch using alsamixer. AFter that e.g. the Treble and Bass sliders of kmix work as expected.
Comment 2 Christian Esken 2011-12-13 21:33:46 UTC
For further insight into this, please post the following information:

- Which sound backend is used. Please copy the output from
    KMix menu => Help => Hardware information

- The ouput of "amixer" (or "amixer -c 1" or any other number that corresponds to the affected soundcard).
Comment 3 Roman Fietze 2011-12-14 20:06:17 UTC
Created attachment 66758 [details]
SB Live 51, output of amixer
Comment 4 Roman Fietze 2011-12-14 20:09:18 UTC
(In reply to comment #2)

> - Which sound backend is used. Please copy the output from
>     KMix menu => Help => Hardware information

Sound drivers used: ALSA
 
> - The ouput of "amixer" (or "amixer -c 1" or any other number that corresponds
> to the affected soundcard).

See attachment "SB Live 51, output of amixer".
Comment 5 Christian Esken 2011-12-14 23:01:46 UTC
Thanks for the quick reply. While I have no such control and can not test it I think I now know what is wrong. I'll give it a quick look right now.
Comment 6 Christian Esken 2011-12-14 23:28:05 UTC
I can reproduce that with my card 2 (amixer -c 1):

Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined cswitch cswitch-joined penum
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined penum

I plan to fix it for KDE4.8. Missing controls are quite bad -raising prority.
Comment 7 Christian Esken 2011-12-14 23:31:10 UTC
*** Bug 265733 has been marked as a duplicate of this bug. ***
Comment 8 Christian Esken 2011-12-22 12:53:59 UTC
When trying to find the issue I was lead on the wrong path due to a bug in the "amixer" output. I opened a bug report at ALSA. [1]

So in the end it was not a "enum vs regular control" conflict, but the KMix GUI simply rejected controls without volume level. I fixed it and will commit it soon. I will also do a backport - at least to KDE4.7.



[1] https://bugtrack.alsa-project.org/alsa-bug/view.php?id=5496
Comment 9 Christian Esken 2011-12-22 13:02:48 UTC
Fixed in trunk (targeted for KDE4.8). See bug 265733 for the link to the patch.
Comment 10 Christian Esken 2011-12-22 13:16:38 UTC
Also fixed in branch 4.7 and 4.6.
Comment 11 Antonio Rojas 2011-12-24 09:44:30 UTC
(In reply to comment #9)
> Fixed in trunk (targeted for KDE4.8). See bug 265733 for the link to the patch.

Trunk is not 4.8 anymore, you need to backport to 4.8 branch also
Comment 12 Christian Esken 2011-12-30 10:30:10 UTC
SVN commit 1270920 by esken:

Fix broken Enum controls in ALSA Backend: A "penum" will now get a different ID as a "cenum", so a selem's with both won't interfere. (Adding patch also to 4.8, as it is already fixed in trunk, 4.7 and 4.6 - thanks for the notification, A Rojas).

 M  +2 -0      TestCases  
 M  +34 -25    backends/mixer_alsa9.cpp  
 M  +3 -2      gui/viewsliders.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1270920