Bug 257489 - system settings manager crashed
Summary: system settings manager crashed
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_clock (show other bugs)
Version: 1.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Paul Campbell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-21 08:07 UTC by rajarshighosh.raj
Modified: 2011-08-13 15:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rajarshighosh.raj 2010-11-21 08:07:24 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-23-generic i686
Distribution: KXStudio 10.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
1.firefox, dolphin file manager was running. etc/sysctl.conf open on kate (no changes were made)
2.had opened partition manager. exited it.
3.checked date and time settings
4.clicked close button on title bar of system settings.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
[Current thread is 1 (Thread 0xb775a710 (LWP 4510))]

Thread 2 (Thread 0xb2487b70 (LWP 4513)):
#0  0x01f19e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x04dff48b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x04ed5965 in QTimerInfoList::updateCurrentTime (this=0x9a6f67c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x04ed59aa in QTimerInfoList::timerWait (this=0x9a6f67c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x04ed3a38 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb24870bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x04ed3ac5 in timerSourcePrepare (source=0x0, timeout=0x1f1dff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01734aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x01734ee9 in ?? () from /lib/libglib-2.0.so.0
#9  0x017354b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x04ed382f in QEventDispatcherGlib::processEvents (this=0x9a57258, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x04ea3a99 in QEventLoop::processEvents (this=0xb2487290, flags=) at kernel/qeventloop.cpp:149
#12 0x04ea3f1a in QEventLoop::exec (this=0xb2487290, flags=...) at kernel/qeventloop.cpp:201
#13 0x04da0c5e in QThread::exec (this=0x9a679f0) at thread/qthread.cpp:490
#14 0x04e829ab in QInotifyFileSystemWatcherEngine::run (this=0x9a679f0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x04da3f39 in QThreadPrivate::start (arg=0x9a679f0) at thread/qthread_unix.cpp:266
#16 0x0019196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#17 0x04683a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb775a710 (LWP 4510)):
[KCrash Handler]
#7  0x00e6d1ca in ~QRasterWindowSurface (this=0xaa67940, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#8  0x00e8b949 in ~QWidgetBackingStore (this=0xaae4cc0, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00c87f3b in QWidgetBackingStoreTracker::destroy (this=0xab12e80) at kernel/qwidget.cpp:205
#10 0x00c89ed1 in QWidgetPrivate::deleteExtra (this=0xaa6e4f0) at kernel/qwidget.cpp:1739
#11 0x00c8a11f in ~QWidgetPrivate (this=0xaa6e4f0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:318
#12 0x04ebf3d1 in QScopedPointerDeleter<QObjectData>::cleanup (this=0xaa6cda8, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#13 ~QScopedPointer (this=0xaa6cda8, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#14 ~QObject (this=0xaa6cda8, __in_chrg=<value optimized out>) at kernel/qobject.cpp:963
#15 0x00c99206 in ~QWidget (this=0xaa6cda8, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1609
#16 0x0059c165 in ?? () from /usr/lib/libkdeui.so.5
#17 0x0059ad84 in KSelectionWatcher::~KSelectionWatcher() () from /usr/lib/libkdeui.so.5
#18 0x04eb7c36 in QObjectPrivate::deleteChildren (this=0xaa6cda8) at kernel/qobject.cpp:1957
#19 0x04ebf380 in ~QObject (this=0xaa6a4d8, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#20 0x0219812f in Plasma::Theme::~Theme() () from /usr/lib/libplasma.so.3
#21 0x0219825a in ?? () from /usr/lib/libplasma.so.3
#22 0x0209848b in ?? () from /usr/lib/libplasma.so.3
#23 0x045e51bf in ?? () from /lib/tls/i686/cmov/libc.so.6
#24 0x045e522f in exit () from /lib/tls/i686/cmov/libc.so.6
#25 0x045ccbde in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#26 0x08050c01 in _start ()

Possible duplicates by query: bug 255081.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-05-14 14:35:52 UTC

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 2 Thomas Lübking 2011-08-13 15:20:16 UTC
Do you use the Bespin UI style?